Jump to content
Froxlor Forum
  • 0

LE Zertifikate werden nicht kopiert


Question

Moin,

seit kurzem funktionierte LE nicht mehr. Aus den Logs entnahm ich, dass es ein Problem mit der acme.sh gab. ACME neu installiert und konfiguriert. Für eine neu angelegte Domain klappt alles problemlos, jedoch für die alten Domains nicht. Die Zertifikate werden erfolgreich in /root/.acme.sh/ angelegt jedoch nicht in die vHosts von Froxlor geschrieben und nicht in /etc/ssl/froxlor-custom/ kopiert.

Bisher probiert:

  • LE Zerts zwangs erneuern (wie von d00p erläutert)
  • Cronjobs und Konfigs gecheckt
  • LE für Domains deaktiviert+reaktiviert
  • LE Cronjob manuell ausgführt
Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 1
2 minutes ago, Pagefreak said:

Ich wusste nicht, dass dann der Cronjob nicht ausgeführt wird.

??? das hat auch niemand behauptet....es ist nur einfach quatsch. Aber wenn du es so möchtest, mach. 

 

3 minutes ago, Pagefreak said:

Die Zertfikiate werden angelegt, aber in der DB/im Panel erscheinen trotzdem nur die neu angelegten.

und wieder einmal keinerlei logs oder angaben dazu, was du gemacht hast...wie soll man dir so helfen? Ich kann mich nur jedes mal wiederholen...lies bitte alle meine antworten hier und alle anderen threads bzgl. lets encrypt probleme. Ich kann es nicht reproduzieren also muss ich davon ausgehen das es irgendwas auf deiner seite ist was ich nicht nachvollziehen kann, weil ich dir alles aus der nase ziehen muss und keine hilfreiche info kommt.

Ich schau mir das gerne mal auf deiner kiste an wenn du willst, ich bin mir ziemlich ziemlich sicher das es eine kleinigkeit ist, wie in 99%  der fälle in dieser situation wenn ich am ende auf die kiste gucke einfach weil die leute die entscheidenden infos nicht geben die es vllt im vorfeld geklärt hätten.

Link to post
Share on other sites
  • 0

Und wo ist der debug output das wir Mal sehen was "funktioniert nicht mehr" bei dir bedeutet...so lässt sich schwer helfen...

Link to post
Share on other sites
  • 0
vor 7 Minuten schrieb d00p:

Und wo ist der debug output das wir Mal sehen was "funktioniert nicht mehr" bei dir bedeutet...so lässt sich schwer helfen...

[information] Requesting/renewing Let's Encrypt certificates
[information] Creating certificate for Webdesign-JH.de
[information] Adding SAN entry: Webdesign-JH.de
[information] Adding SAN entry: www.Webdesign-JH.de
[information] Checking for LetsEncrypt client upgrades before renewing certificates:
[Wed Apr 29 13:28:55 CEST 2020] Already uptodate!
[Wed Apr 29 13:28:55 CEST 2020] Upgrade success!
[Wed Apr 29 13:28:55 CEST 2020] Removing cron job
[Wed Apr 29 13:28:55 CEST 2020] Lets find script dir.
[Wed Apr 29 13:28:55 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Wed Apr 29 13:28:55 CEST 2020] _script='/root/.acme.sh/acme.sh'
[Wed Apr 29 13:28:56 CEST 2020] _script_home='/root/.acme.sh'
[Wed Apr 29 13:28:56 CEST 2020] Using default home:/root/.acme.sh
[Wed Apr 29 13:28:56 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 13:28:56 CEST 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 13:28:56 CEST 2020] Running cmd: issue
[Wed Apr 29 13:28:56 CEST 2020] _main_domain='webdesign-jh.de'
[Wed Apr 29 13:28:56 CEST 2020] _alt_domains='www.webdesign-jh.de'
[Wed Apr 29 13:28:56 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 13:28:56 CEST 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 13:28:56 CEST 2020] DOMAIN_PATH='/root/.acme.sh/webdesign-jh.de'
[Wed Apr 29 13:28:56 CEST 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 13:28:56 CEST 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 13:28:56 CEST 2020] GET
[Wed Apr 29 13:28:56 CEST 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 13:28:56 CEST 2020] timeout=
[Wed Apr 29 13:28:56 CEST 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Wed Apr 29 13:28:56 CEST 2020] ret='0'
[Wed Apr 29 13:28:56 CEST 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Wed Apr 29 13:28:56 CEST 2020] ACME_NEW_AUTHZ
[Wed Apr 29 13:28:56 CEST 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Wed Apr 29 13:28:56 CEST 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Wed Apr 29 13:28:56 CEST 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Wed Apr 29 13:28:56 CEST 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Wed Apr 29 13:28:56 CEST 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Wed Apr 29 13:28:56 CEST 2020] ACME_VERSION='2'
[Wed Apr 29 13:28:56 CEST 2020] Le_NextRenewTime='1593256244'
[Wed Apr 29 13:28:56 CEST 2020] _saved_domain='webdesign-jh.de'
[Wed Apr 29 13:28:56 CEST 2020] _saved_alt='www.webdesign-jh.de'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6

Im Error.log steht nur:

[Wed Apr 29 13:15:11.732242 2020] [ssl:warn] [pid 22976] AH01909: ServerRISE.com:443:0 server certificate does NOT include an ID which matches the server name

Es scheint ja soweit zu funktionieren. Die werden nur nicht kopiert bzw. in den vHosts geschrieben.

Link to post
Share on other sites
  • 0
28 minutes ago, Pagefreak said:

Es scheint ja soweit zu funktionieren. Die werden nur nicht kopiert bzw. in den vHosts geschrieben

Komplette Ausgabe von 

php /var/www/froxlor/Scripts/froxlor_master_cronjob.php --force --debug

In deinem Output ist nix zu sehen, und wenn alles geklappt hat, dann hat froxlor die Zertifikate auch in deiner Datenbank (siehe Anzeige "SSL Zertifikate" im Menü links) und dann schreibt er die auch - außer es gibt ein anderes Problem und das zeigt der cron an, also bitte, komplette Ausgabe

Link to post
Share on other sites
  • 0
[information] TasksCron: Searching for tasks to do
[information] Running Let's Encrypt cronjob prior to regenerating webserver config files
[information] Requesting/renewing Let's Encrypt certificates
[information] Creating certificate for Webdesign-JH.de
[information] Adding SAN entry: Webdesign-JH.de
[information] Adding SAN entry: www.Webdesign-JH.de
[information] Checking for LetsEncrypt client upgrades before renewing certificates:
[Wed Apr 29 14:12:10 CEST 2020] Already uptodate!
[Wed Apr 29 14:12:10 CEST 2020] Upgrade success!
[Wed Apr 29 14:12:11 CEST 2020] Removing cron job
[Wed Apr 29 14:12:11 CEST 2020] Lets find script dir.
[Wed Apr 29 14:12:11 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:11 CEST 2020] _script='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:11 CEST 2020] _script_home='/root/.acme.sh'
[Wed Apr 29 14:12:11 CEST 2020] Using default home:/root/.acme.sh
[Wed Apr 29 14:12:11 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:11 CEST 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:11 CEST 2020] Running cmd: issue
[Wed Apr 29 14:12:11 CEST 2020] _main_domain='webdesign-jh.de'
[Wed Apr 29 14:12:11 CEST 2020] _alt_domains='www.webdesign-jh.de'
[Wed Apr 29 14:12:11 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:11 CEST 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:11 CEST 2020] DOMAIN_PATH='/root/.acme.sh/webdesign-jh.de'
[Wed Apr 29 14:12:11 CEST 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:11 CEST 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:11 CEST 2020] GET
[Wed Apr 29 14:12:11 CEST 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:11 CEST 2020] timeout=
[Wed Apr 29 14:12:11 CEST 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Wed Apr 29 14:12:12 CEST 2020] ret='0'
[Wed Apr 29 14:12:12 CEST 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Wed Apr 29 14:12:12 CEST 2020] ACME_NEW_AUTHZ
[Wed Apr 29 14:12:12 CEST 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Wed Apr 29 14:12:12 CEST 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Wed Apr 29 14:12:12 CEST 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Wed Apr 29 14:12:12 CEST 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Wed Apr 29 14:12:12 CEST 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Wed Apr 29 14:12:12 CEST 2020] ACME_VERSION='2'
[Wed Apr 29 14:12:12 CEST 2020] Le_NextRenewTime='1593256244'
[Wed Apr 29 14:12:12 CEST 2020] _saved_domain='webdesign-jh.de'
[Wed Apr 29 14:12:12 CEST 2020] _saved_alt='www.webdesign-jh.de'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:12 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:12 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:10:44 UTC 2020
[Wed Apr 29 14:12:12 CEST 2020] Add '--force' to force to renew.
[error] Could not get Let's Encrypt certificate for Webdesign-JH.de:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:12 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:12 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:10:44 UTC 2020
[Wed Apr 29 14:12:12 CEST 2020] Add '--force' to force to renew.
[information] Creating certificate for Lolex-Knives.com
[information] Adding SAN entry: Lolex-Knives.com
[information] Adding SAN entry: www.Lolex-Knives.com
[Wed Apr 29 14:12:12 CEST 2020] Lets find script dir.
[Wed Apr 29 14:12:12 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:12 CEST 2020] _script='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:12 CEST 2020] _script_home='/root/.acme.sh'
[Wed Apr 29 14:12:12 CEST 2020] Using default home:/root/.acme.sh
[Wed Apr 29 14:12:12 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:12 CEST 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:12 CEST 2020] Running cmd: issue
[Wed Apr 29 14:12:12 CEST 2020] _main_domain='lolex-knives.com'
[Wed Apr 29 14:12:12 CEST 2020] _alt_domains='www.lolex-knives.com'
[Wed Apr 29 14:12:12 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:12 CEST 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:12 CEST 2020] DOMAIN_PATH='/root/.acme.sh/lolex-knives.com'
[Wed Apr 29 14:12:12 CEST 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:12 CEST 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:12 CEST 2020] GET
[Wed Apr 29 14:12:12 CEST 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:12 CEST 2020] timeout=
[Wed Apr 29 14:12:12 CEST 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Wed Apr 29 14:12:13 CEST 2020] ret='0'
[Wed Apr 29 14:12:13 CEST 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Wed Apr 29 14:12:13 CEST 2020] ACME_NEW_AUTHZ
[Wed Apr 29 14:12:13 CEST 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Wed Apr 29 14:12:13 CEST 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Wed Apr 29 14:12:13 CEST 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Wed Apr 29 14:12:13 CEST 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Wed Apr 29 14:12:13 CEST 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Wed Apr 29 14:12:13 CEST 2020] ACME_VERSION='2'
[Wed Apr 29 14:12:13 CEST 2020] Le_NextRenewTime='1593256254'
[Wed Apr 29 14:12:13 CEST 2020] _saved_domain='lolex-knives.com'
[Wed Apr 29 14:12:13 CEST 2020] _saved_alt='www.lolex-knives.com'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:13 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:13 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:10:54 UTC 2020
[Wed Apr 29 14:12:13 CEST 2020] Add '--force' to force to renew.
[error] Could not get Let's Encrypt certificate for Lolex-Knives.com:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:13 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:13 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:10:54 UTC 2020
[Wed Apr 29 14:12:13 CEST 2020] Add '--force' to force to renew.
[information] Creating certificate for ServerRISE.com
[information] Adding SAN entry: ServerRISE.com
[information] Adding SAN entry: www.ServerRISE.com
[Wed Apr 29 14:12:13 CEST 2020] Lets find script dir.
[Wed Apr 29 14:12:13 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:13 CEST 2020] _script='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:13 CEST 2020] _script_home='/root/.acme.sh'
[Wed Apr 29 14:12:13 CEST 2020] Using default home:/root/.acme.sh
[Wed Apr 29 14:12:13 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:13 CEST 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:13 CEST 2020] Running cmd: issue
[Wed Apr 29 14:12:13 CEST 2020] _main_domain='serverrise.com'
[Wed Apr 29 14:12:13 CEST 2020] _alt_domains='www.serverrise.com'
[Wed Apr 29 14:12:13 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:13 CEST 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:14 CEST 2020] DOMAIN_PATH='/root/.acme.sh/serverrise.com'
[Wed Apr 29 14:12:14 CEST 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:14 CEST 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:14 CEST 2020] GET
[Wed Apr 29 14:12:14 CEST 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:14 CEST 2020] timeout=
[Wed Apr 29 14:12:14 CEST 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Wed Apr 29 14:12:14 CEST 2020] ret='0'
[Wed Apr 29 14:12:14 CEST 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Wed Apr 29 14:12:14 CEST 2020] ACME_NEW_AUTHZ
[Wed Apr 29 14:12:14 CEST 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Wed Apr 29 14:12:14 CEST 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Wed Apr 29 14:12:15 CEST 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Wed Apr 29 14:12:15 CEST 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Wed Apr 29 14:12:15 CEST 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Wed Apr 29 14:12:15 CEST 2020] ACME_VERSION='2'
[Wed Apr 29 14:12:15 CEST 2020] Le_NextRenewTime='1593256263'
[Wed Apr 29 14:12:15 CEST 2020] _saved_domain='serverrise.com'
[Wed Apr 29 14:12:15 CEST 2020] _saved_alt='www.serverrise.com'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:15 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:15 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:03 UTC 2020
[Wed Apr 29 14:12:15 CEST 2020] Add '--force' to force to renew.
[error] Could not get Let's Encrypt certificate for ServerRISE.com:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:15 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:15 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:03 UTC 2020
[Wed Apr 29 14:12:15 CEST 2020] Add '--force' to force to renew.
[information] Creating certificate for seahub.ServerRISE.com
[information] Adding SAN entry: seahub.ServerRISE.com
[Wed Apr 29 14:12:15 CEST 2020] Lets find script dir.
[Wed Apr 29 14:12:15 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:15 CEST 2020] _script='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:15 CEST 2020] _script_home='/root/.acme.sh'
[Wed Apr 29 14:12:15 CEST 2020] Using default home:/root/.acme.sh
[Wed Apr 29 14:12:15 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:15 CEST 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:15 CEST 2020] Running cmd: issue
[Wed Apr 29 14:12:15 CEST 2020] _main_domain='seahub.serverrise.com'
[Wed Apr 29 14:12:15 CEST 2020] _alt_domains='no'
[Wed Apr 29 14:12:15 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:15 CEST 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:15 CEST 2020] DOMAIN_PATH='/root/.acme.sh/seahub.serverrise.com'
[Wed Apr 29 14:12:15 CEST 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:15 CEST 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:15 CEST 2020] GET
[Wed Apr 29 14:12:15 CEST 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:15 CEST 2020] timeout=
[Wed Apr 29 14:12:15 CEST 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Wed Apr 29 14:12:16 CEST 2020] ret='0'
[Wed Apr 29 14:12:16 CEST 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Wed Apr 29 14:12:16 CEST 2020] ACME_NEW_AUTHZ
[Wed Apr 29 14:12:16 CEST 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Wed Apr 29 14:12:16 CEST 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Wed Apr 29 14:12:16 CEST 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Wed Apr 29 14:12:16 CEST 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Wed Apr 29 14:12:16 CEST 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Wed Apr 29 14:12:16 CEST 2020] ACME_VERSION='2'
[Wed Apr 29 14:12:16 CEST 2020] Le_NextRenewTime='1593256273'
[Wed Apr 29 14:12:16 CEST 2020] _saved_domain='seahub.serverrise.com'
[Wed Apr 29 14:12:16 CEST 2020] _saved_alt='no'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:16 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:16 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:13 UTC 2020
[Wed Apr 29 14:12:16 CEST 2020] Add '--force' to force to renew.
[error] Could not get Let's Encrypt certificate for seahub.ServerRISE.com:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:16 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:16 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:13 UTC 2020
[Wed Apr 29 14:12:16 CEST 2020] Add '--force' to force to renew.
[information] Creating certificate for hosting.ServerRISE.com
[information] Adding SAN entry: hosting.ServerRISE.com
[information] Adding SAN entry: www.hosting.ServerRISE.com
[Wed Apr 29 14:12:16 CEST 2020] Lets find script dir.
[Wed Apr 29 14:12:16 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:16 CEST 2020] _script='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:16 CEST 2020] _script_home='/root/.acme.sh'
[Wed Apr 29 14:12:16 CEST 2020] Using default home:/root/.acme.sh
[Wed Apr 29 14:12:16 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:16 CEST 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:16 CEST 2020] Running cmd: issue
[Wed Apr 29 14:12:16 CEST 2020] _main_domain='hosting.serverrise.com'
[Wed Apr 29 14:12:16 CEST 2020] _alt_domains='www.hosting.serverrise.com'
[Wed Apr 29 14:12:16 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:16 CEST 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:16 CEST 2020] DOMAIN_PATH='/root/.acme.sh/hosting.serverrise.com'
[Wed Apr 29 14:12:16 CEST 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:16 CEST 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:16 CEST 2020] GET
[Wed Apr 29 14:12:16 CEST 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:16 CEST 2020] timeout=
[Wed Apr 29 14:12:17 CEST 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Wed Apr 29 14:12:17 CEST 2020] ret='0'
[Wed Apr 29 14:12:17 CEST 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Wed Apr 29 14:12:17 CEST 2020] ACME_NEW_AUTHZ
[Wed Apr 29 14:12:17 CEST 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Wed Apr 29 14:12:17 CEST 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Wed Apr 29 14:12:17 CEST 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Wed Apr 29 14:12:17 CEST 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Wed Apr 29 14:12:17 CEST 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Wed Apr 29 14:12:17 CEST 2020] ACME_VERSION='2'
[Wed Apr 29 14:12:17 CEST 2020] Le_NextRenewTime='1593256282'
[Wed Apr 29 14:12:17 CEST 2020] _saved_domain='hosting.serverrise.com'
[Wed Apr 29 14:12:17 CEST 2020] _saved_alt='www.hosting.serverrise.com'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:17 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:17 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:22 UTC 2020
[Wed Apr 29 14:12:17 CEST 2020] Add '--force' to force to renew.
[error] Could not get Let's Encrypt certificate for hosting.ServerRISE.com:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:17 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:17 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:22 UTC 2020
[Wed Apr 29 14:12:17 CEST 2020] Add '--force' to force to renew.
[information] Creating certificate for GeschenkfuerMaja.pro
[information] Adding SAN entry: GeschenkfuerMaja.pro
[Wed Apr 29 14:12:17 CEST 2020] Lets find script dir.
[Wed Apr 29 14:12:18 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:18 CEST 2020] _script='/root/.acme.sh/acme.sh'
[Wed Apr 29 14:12:18 CEST 2020] _script_home='/root/.acme.sh'
[Wed Apr 29 14:12:18 CEST 2020] Using default home:/root/.acme.sh
[Wed Apr 29 14:12:18 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:18 CEST 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:18 CEST 2020] Running cmd: issue
[Wed Apr 29 14:12:18 CEST 2020] _main_domain='geschenkfuermaja.pro'
[Wed Apr 29 14:12:18 CEST 2020] _alt_domains='no'
[Wed Apr 29 14:12:18 CEST 2020] Using config home:/root/.acme.sh
[Wed Apr 29 14:12:18 CEST 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:18 CEST 2020] DOMAIN_PATH='/root/.acme.sh/geschenkfuermaja.pro'
[Wed Apr 29 14:12:18 CEST 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:18 CEST 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Wed Apr 29 14:12:18 CEST 2020] GET
[Wed Apr 29 14:12:18 CEST 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Wed Apr 29 14:12:18 CEST 2020] timeout=
[Wed Apr 29 14:12:18 CEST 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Wed Apr 29 14:12:18 CEST 2020] ret='0'
[Wed Apr 29 14:12:18 CEST 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Wed Apr 29 14:12:18 CEST 2020] ACME_NEW_AUTHZ
[Wed Apr 29 14:12:18 CEST 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Wed Apr 29 14:12:18 CEST 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Wed Apr 29 14:12:18 CEST 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Wed Apr 29 14:12:18 CEST 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Wed Apr 29 14:12:18 CEST 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Wed Apr 29 14:12:18 CEST 2020] ACME_VERSION='2'
[Wed Apr 29 14:12:18 CEST 2020] Le_NextRenewTime='1593256289'
[Wed Apr 29 14:12:18 CEST 2020] _saved_domain='geschenkfuermaja.pro'
[Wed Apr 29 14:12:18 CEST 2020] _saved_alt='no'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:18 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:18 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:29 UTC 2020
[Wed Apr 29 14:12:18 CEST 2020] Add '--force' to force to renew.
[error] Could not get Let's Encrypt certificate for GeschenkfuerMaja.pro:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Wed Apr 29 14:12:18 CEST 2020] Domains not changed.
[Wed Apr 29 14:12:18 CEST 2020] Skip, Next renewal time is: Sun Jun 28 11:11:29 UTC 2020
[Wed Apr 29 14:12:18 CEST 2020] Add '--force' to force to renew.
[information] No new certificates or certificates due for renewal found
[information] apache::createIpPort: creating ip/port settings for  213.202.252.247:80
[notice] 213.202.252.247:80 :: namevirtualhost-statement no longer needed for apache-2.4
[debug] 213.202.252.247:80 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  213.202.252.247:443
[information] apache::createVirtualHosts: creating vhost container for domain 18, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 32, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 19, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 17, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 14, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 28, customer Lolex
[information] apache::createVirtualHosts: creating vhost container for domain 20, customer Lolex
[information] apache::createVirtualHosts: creating vhost container for domain 34, customer BN
[information] apache::createVirtualHosts: creating vhost container for domain 33, customer BN
[information] apache::createVirtualHosts: creating vhost container for domain 13, customer BN
[information] apache::createVirtualHosts: creating vhost container for domain 35, customer WDJH
[information] apache::createVirtualHosts: creating vhost container for domain 36, customer WDJH
[information] apache::createVirtualHosts: creating vhost container for domain 37, customer WDJH
[information] apache::createVirtualHosts: creating vhost container for domain 6, customer BN
[information] apache::createVirtualHosts: creating vhost container for domain 21, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 31, customer JLaubner
[information] apache::createVirtualHosts: creating vhost container for domain 29, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 9, customer Lolex
[information] apache::createVirtualHosts: creating vhost container for domain 26, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 12, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 39, customer PSchmidt
[information] apache::createVirtualHosts: creating vhost container for domain 2, customer WDJH
[information] apache::createVirtualHosts: creating vhost container for domain 3, customer BN
[information] apache::createVirtualHosts: creating vhost container for domain 30, customer JLaubner
[information] apache::createVirtualHosts: creating vhost container for domain 4, customer Lolex
[information] apache::createVirtualHosts: creating vhost container for domain 38, customer PSchmidt
[information] apache::createVirtualHosts: creating vhost container for domain 5, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 24, customer ServerRISE
[information] apache::createVirtualHosts: creating vhost container for domain 1, customer WDJH
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi
[notice] Checking system's last guid

Im Panel erscheint lediglich die neu angelegte Domain. Die bisherigen tauchen nicht auf.

Link to post
Share on other sites
  • 0
9 minutes ago, Pagefreak said:

Im Panel erscheint lediglich die neu angelegte Domain. Die bisherigen tauchen nicht auf.

Domains? oder Zertifikate? von was sprichst du? Sorry, das macht so keinen Sinn. Ich kann nicht nachvollziehen was du da fummelst oder machst; lösche die Let's Encrypt Zertifikate aus Froxlor und die entsprechenden Domain-ordner aus /root/.acme.sh/ und fang noch mal von vorne an - die log sagt ja auch: domain key gibts, kein renew; also ist da so nix zu machen, außer du gehst jetzt vllt auf die aktuelle github-master version, da gibts einen dateisystem-abgleich für Let's Encrypt Zertifikate. Ich rate dennoch zu einem "sauberen nochmal von vorne" in dem du alles leerst.

Link to post
Share on other sites
  • 0
vor 2 Minuten schrieb d00p:

Domains? oder Zertifikate? von was sprichst du? Sorry, das macht so keinen Sinn. Ich kann nicht nachvollziehen was du da fummelst oder machst; lösche die Let's Encrypt Zertifikate aus Froxlor und die entsprechenden Domain-ordner aus /root/.acme.sh/ und fang noch mal von vorne an - die log sagt ja auch: domain key gibts, kein renew; also ist da so nix zu machen, außer du gehst jetzt vllt auf die aktuelle github-master version, da gibts einen dateisystem-abgleich für Let's Encrypt Zertifikate. Ich rate dennoch zu einem "sauberen nochmal von vorne" in dem du alles leerst.

Ich meine natürlich die Zertifikate. Ich werde es nochmal probieren, alles zu löschen und hoffe, dass sie dann eventuell auch von froxlor angelegt werden. Erkennt Froxlor selbstständig, dass keine Zertifikate vorhanden sind bzw. dass die vHosts aktualisiert werden müssen?

Link to post
Share on other sites
  • 0
7 minutes ago, Pagefreak said:

Erkennt Froxlor selbstständig, dass keine Zertifikate vorhanden sind bzw. dass die vHosts aktualisiert werden müssen?

ja sicher, Let's encrypt ist für die domain aktiviert und es gibt kein zertifikat, also holt er eins

Link to post
Share on other sites
  • 0

Hilft leider alles nichts. Lediglich wenn ich die Domains neu anlege klappt es auch mit Let'sEncrypt. Bleibt mir wohl nichts anderes über. Kann ich die auch neu anlegen, ohne das die Mail Adressen und alles flöten gehen?

Link to post
Share on other sites
  • 0

Quatsch das hat null mit Neuanlegen der Domain in froxlor zu tun....was treibst du denn da? 

Du gibst halt auch null Info auf das ganze Zeug was man dir vorschlägt, immer nur "ne geht nicht", "leider immer noch"... Rück halt ein paar Infos raus, sonst kann man dir nicht helfen. 

Ich kann dir nur sagen dass das bei mir auf zig Servern wunderbar funktioniert - also schau bitte nach wo du da ggfls vom Default werten abgewichen bist oder irgendwas manuell gemacht hast oder sonstwas.

Anders kann ich dir leider nicht helfen, es gibt schon genügend let's encrypt threads hier im Forum und am Ende ist es immer und immer wieder das selbe: entweder Problem bei DNS der Domain oder wie schon zig Mal gesagt, einfach alle let's encrypt Zertifikate in froxlor UND acme.sh homedir löschen und frisch beantragen 

Link to post
Share on other sites
  • 0
Am 29.4.2020 um 17:30 schrieb d00p:

Quatsch das hat null mit Neuanlegen der Domain in froxlor zu tun....was treibst du denn da? 

Du gibst halt auch null Info auf das ganze Zeug was man dir vorschlägt, immer nur "ne geht nicht", "leider immer noch"... Rück halt ein paar Infos raus, sonst kann man dir nicht helfen. 

Ich kann dir nur sagen dass das bei mir auf zig Servern wunderbar funktioniert - also schau bitte nach wo du da ggfls vom Default werten abgewichen bist oder irgendwas manuell gemacht hast oder sonstwas.

Anders kann ich dir leider nicht helfen, es gibt schon genügend let's encrypt threads hier im Forum und am Ende ist es immer und immer wieder das selbe: entweder Problem bei DNS der Domain oder wie schon zig Mal gesagt, einfach alle let's encrypt Zertifikate in froxlor UND acme.sh homedir löschen und frisch beantragen 

Ich bin jetzt wie folgt vorgegangen:

  • Cron gestoppt
  • Domain Ordner in /root/.acme.sh/ gelöscht
  • Cron gestartet

Der Cron für die Webserver-Konfiguration scheint nicht zu funktionieren, wenn ich ihn nicht manuell starte. Die Ordner/Zertifikaten wurde entsprechend auch nicht wieder in /.root/acme.sh/ angelegt. Die Crons passen meines Erachtens:

*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers/webs/ServerRISE/froxlor.ServerRISE.com/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null
0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers/webs/ServerRISE/froxlor.ServerRISE.com/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers/webs/ServerRISE/froxlor.ServerRISE.com/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null
0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers/webs/ServerRISE/froxlor.ServerRISE.com/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers/webs/ServerRISE/froxlor.ServerRISE.com/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null
10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers/webs/ServerRISE/froxlor.ServerRISE.com/scripts/froxlor_master_cronjob.php --backup 1> /dev/null

 

Screenshot_2.png

Link to post
Share on other sites
  • 0
15 minutes ago, Pagefreak said:

Ich bin jetzt wie folgt vorgegangen:

  • Cron gestoppt
  • Domain Ordner in /root/.acme.sh/ gelöscht
  • Cron gestartet

und nicht richtig gelesen...du solltest neben den Domain Ordner in /root/.acme.sh/ auch alle Let's Encrypt Zertifikate in der Froxlor "SSL Zertifikate" löschen, sonst weiss froxlor nix von "neu holen" sondern arbeitet mit dem was in der Datenbank ist.

16 minutes ago, Pagefreak said:

/var/customers/webs/ServerRISE/froxlor.ServerRISE.com/

und warum zur Hölle liegt dein Froxlor in einem KUNDEN homedir? Hat da absolut nix verloren

Link to post
Share on other sites
  • 0

Ich wusste nicht, dass dann der Cronjob nicht ausgeführt wird. Die Zertfikiate werden angelegt, aber in der DB/im Panel erscheinen trotzdem nur die neu angelegten.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...