April 4, 20206 yr Author 4 minutes ago, d00p said: Hast du evtl. zu einem späteren zeitpunkt ECC aktiviert? Dann würde froxlor davon ausgehen dass die daten in /root/.acme.sh/a.mein****.de_ecc/ liegen.... DAS ist, was ich gemacht habe, bevor das mit den Fehlern losging. Wie sieht jetzt Deine Handlungsempfehlung aus?
April 4, 20206 yr Tja, hm, das ist aktuell leider nur eine system-weite einstellung, ich könnte als fallback auf "nicht-ecc" gucken und abgleichen....aber es wird dann bei einem renew halt auch aus einem nicht-ecc zertifikat kein ecc-zertifikat, das gilt nur für neue
April 4, 20206 yr Author Für offenbar jede Domain kommt PHP Warning: Use of undefined constant LOG_WARN - assumed 'LOG_WARN' (this will throw an Error in a future version of PHP) in /var/www/webs/its/froxlor.DOMAIN.de/lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php on line 461 Und bei einer der betroffenen Domains siehts so aus PHP Warning: Use of undefined constant LOG_WARN - assumed 'LOG_WARN' (this will throw an Error in a future version of PHP) in /var/www/webs/its/froxlor.DOMAIN.de/lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php on line 461 [unknown] ECC certificates activated but found only non-ecc file [information] Updated Let's Encrypt certificate for a.mein****.de
April 4, 20206 yr Author Auf dem 2. Server wo die Diskrepanz zwischen Expiration im Dateisystem und der DB war, ist jetzt "Einigkeit" ohne, dass sich an dem Zertifikat im Dateisystem etwas geändert hätte. Du hast es also offenbar geschafft, dass sich FROXLOR an den Daten im Dateisystem bedient und damit die DB füttert.
April 7, 20206 yr On 4/4/2020 at 5:26 PM, d00p said: Okay, also noch die LOG_WARN kacke weg und dann läuft's merci - kann das hier bestätigen, nach einem --force sind die LE-Certs wieder gut. Krieg ich eventuell einen Tipp, wie dsa LOG_WARN wegzubekommen wäre? Danke!
April 7, 20206 yr Oh sorry, ja, hatte es schon im code commited; einfach nach "LOG_WARN" suchen und "LOG_WARNING" draus machen, da hat wohl die autovervollständigung versagt
April 7, 20206 yr Danke - noch eine Kleinigkeit: hätte jetzt auch das LE-Cert für den froxlor-VHost gelöscht - aber das wird anscheinend nicht wieder generiert?
April 7, 20206 yr Das wird eigentlich genauso behandelt wie die anderen auch, wie genau hast du was wo gelöscht?
April 7, 20206 yr Just now, d00p said: Das wird eigentlich genauso behandelt wie die anderen auch, wie genau hast du was wo gelöscht? Froxor -> Ressourcen -> SSL-Zertifikate -> dort das LE-Cert für den VHost gelöscht.
April 7, 20206 yr Okay, das löscht lediglich den Froxlor Datenbankeintrag, ich schau noch mal gerade in den code, kann sein dass er da vllt nicht abgleicht, da die domain keine "normale" domain ist wie die anderen
April 7, 20206 yr Folgende Datei kann zum Testen genutzt werden, ich habe jetzt bisher noch keinen Live-Test machen können AcmeSh.php.txt
April 7, 20206 yr 17 minutes ago, d00p said: Folgende Datei kann zum Testen genutzt werden, ich habe jetzt bisher noch keinen Live-Test machen können AcmeSh.php.txt 18.38 kB · 0 downloads jap - schaut gut aus Danke!
May 2, 20206 yr Author Ich muss mich hier leider wieder melden, weil ich noch die hier genannte AcmeSh.php einsetze. Inzwischen häufen sich Meldungen wie: [Do 30. Apr 15:34:31 CEST 2020] DOMAIN.TLD:Verify error:The key authorization file from the server did not match this challenge [Do 30. Apr 15:34:32 CEST 2020] Please add '--debug' or '--log' to check more details. [Do 30. Apr 15:34:32 CEST 2020] See: https://github.com/acmesh-official/acme.sh/wiki/How-to-debug-acme.sh
May 2, 20206 yr domain? ipv4/ipv6? Ist die Domain neu oder renew? Schon mal in froxlor und .acme.sh Ordner gelöscht und nochmal versucht? etc.etc.etc.
May 2, 20206 yr Author Die Domain war vor den ganzen hier diskutierten Anpassungen am FROXLOR dort bereits in Verwaltung und mit LE versehen. Es geht also um einen RENEW. Im konkreten Beispiel rein IPv4. Ich habe in FROXLOR schon LE deaktiviert, den Zertifikatsordner aus /root/.acme gelöscht, Configs neu geschrieben und LE wieder für die Domain aktiviert sowie Configs neu geschrieben. Das konnte dann kein CRT beziehen, hat nur .conf, .csr und .key angelegt.
May 2, 20206 yr Jemand hatte diesen Fehler schon in einem anderen Thread hier; das Internet sagt: entweder DNS falsch (oder eben anfragen auf ipv6 und kein ipv6 container, o.ä.) oder etwas stimmt mit dem lokalen (lets encrypt) account nicht, siehe
May 5, 20206 yr Author Danke fürs unterstützen. Ich bin leider schon wieder darauf reingefallen, dass ein "Reseller" längst einen anderen A-record für www. eingetragen hat und vergas, das LE zu deaktivieren. Das mit 3 Domains und die Vierte, mit der ich die Gegenprobe machen wollte hatte längst den Provider gewechselt, ohne dass mir das der Kunde sagte. Ich freue mich riesig auf den Fix mit der DNS-Gegenprobe.
Archived
This topic is now archived and is closed to further replies.