Jump to content
Froxlor Forum

hk@

Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About hk@

  • Rank
    Froxie
  1. Hi good news! Is there a sane way for current debian-package-users to upgrade without breaking anything (ie. upgrading using the latest tar.gz)? thx, hk
  2. tried that, tried it again, but even after removing all certificate data from the domain, deactivating ssl for the domain and then re-enabling it and setting LE enabled - it keeps telling me the same... please advise, hk
  3. with letsencrypt arriving for froxlor, I wonder if there is a sane way to get https for froxlor itself this way? thank you in advance, hk
  4. Hi I'm stuck in quite a similar limbo, in this case the domain had a startssl cert before, then I simply activated LetsEncrypt and well - it plain doesn't work: /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [debug] Updating xyzdomaincom [debug] letsencrypt generating new key / SAN for xyzdomain.com [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org'to generate certificate [information] letsencrypt Account already registered. Continuing. [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for xyzdomain.com [information] letsencrypt Sending signed request to /acme/new-authz [error] Could not get Let's Encrypt certificate for xyzdomain.com: No challenges received for xyzdomain.com. Whole response: {"type":"urn:acme:error:unauthorized","detail":"No registration exists matching provided key","status":403} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid any help is greatly appreciated.
  5. hk@

    cronjob debugging - howto?

    Hi as I'm trying to find the reason behind letsencrypt not working at all, I tried to enable cronjob-debugging, I happily check the box to enable debugging, but in fact I have no idea, where those lock and hopefully logfiles might be found on the system... please advise, hk
  6. Hi after upgrading to 0.9.35.1-1+wheezy1 (DB: 201603150) and trying to enable letsencrypt I don't see any commands to create the mentioned directory in the setup process. Should this one be autocreated? (if so it doesn't seem to work) Or should I manually create it (if so please update the release notes https://forum.froxlor.org/index.php/topic/13348-release-0935-lets-encrypt-auto-update-and-more/ ) regards hk
  7. hk@

    Global htpasswd for securing the froxlor root

    Well, given the information-leak yesterday, I'd vote for something additionally Especially as phpMyAdmin and other additional apps do not provide features against brute-force-attacks, this would benefit all users and having to enter ones access-credentials twice would not do much harm anyways. Authentication could be done using mysql (at least in apache) directly and I'd appreciate this additional layer of security. Thank you in advance, hk
  8. hk@

    Important bugfix release 0.9.33.2

    Hi actually this fix is missing the removal of the compromised logfiles, otherwise it fixes future logging of passwords, but not the access to the logfile that has been compromised. I ask you to add a proper .htaccess-block for the logs-directory _and_ remove the logfiles from there as they - if kept - are still a security-risk in the current release. thx hk
  9. Hmm - ich hab intensiv gesucht, insbesondere das Setup eines Froxlor von 0 weg gemacht, dennoch passiert dieses Problem wieder. Ich find das nicht sonderlich motivierend, wenn ein Setup von 0 weg geplant scheitert und dann wieder irgendwo was zu suchen ist (Info zu wo w?re auch hilfreich gewesen)
  10. hk@

    apache2 mit php5-fpm

    nochmal in der DB alles nachgearbeitet bei dem fpm Einstellungen, dann wieder gelitten und am Ende gings dann, aber ich erlaub mir die Behautpung, dass hier noch Verbesserungspotential liegt...
  11. hk@

    apache2 mit php5-fpm

    Hi Krise f?ngt im Forum an: nach "fpm" darf man nicht suchen, sind keine 4 Zeichen Nach bestem Gewissen froxlor via .deb und dann webinterface auf einem neuen debian 7 (wheezy) installiert, erst nat?rlich die Einstellungn gemacht und danach die Konfiguration. Haken: Allein nach der Konfiguration ist noch kein php5-fpm aktiv, also nochmal nach dem (alten) Handbuch im redmine vorgegangen, das bringt den Erfolg, dass apache (nona) kein php mehr interpretiert, aber l?uft, der php5-fpm aber kalt mit: [21-Apr-2015 20:24:48] ERROR: No pool defined. at least one pool section must be specified in config file [21-Apr-2015 20:24:48] ERROR: failed to post process the configuration [21-Apr-2015 20:24:48] ERROR: FPM initialization failed nicht ins Laufen kommt. f?rs Protokoll: der cron-job (--force) generiert auch weiterhin die sites-enabled-files mit "php_admin_value", man kann das h?ndisch kommentieren, freilich hilft das am Ende produktiv nichts. bisher hat das nur auf einem wheezy (in einer Notnachtschicht) geklappt, aber scheinbar hat sich das inzwischen entweder wieder ver?ndert oder aber ich scheitere an mir selbst, jedenfalls bin ich mit der Doku bzw. dem Vorgehen laut froxlor-config nicht gl?cklich und am Leiden. hk
×