Jump to content
Froxlor Forum
  • 0

PHP Einstellung "openssl.cafile" vornehmen


Go to solution Solved by d00p,

Question

Hallo,

ich versuche über Froxlor die Einstellung "openssl.cafile" in die php.ini zu integrieren.

Als Ort habe ich PHP -> PHP-Konfigurationen -> Default Config bzw. Froxlor Vhost Config -> php.ini-Einstellungen gewählt.

Wenn ich den Master Cronjob ausführe und die PHPinfo() Seite anschaue steht dort unverändert der (leere) Master value.

Nun lautet meine Frage: Habe ich die Änderung an der falschen Stelle gemacht oder irgendetwas vergessen?

Wenn ich die Änderung direkt in /etc/php/7.4/fpm/php.ini vornehme funktioniert es.

Nutze PHP 7.4 mit FPM.

VG,

Afox

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1
  • Solution

Da fpm diese Optionen in der Pool config via php_admin_value/flag bzw php_valie/flag setzt und wir dafür eine Zuordnung in diese Kategorien brauchen gibt es hierfür Einstellungen unter "Einstellungen" -> "PHP-FPM"; zu welcher Kategorie das gewünschte flag gehört findest du über die php-doku raus. Wenn du dort an entsprechende Stelle dein "openssl.cafile" einträgst "erkennt" froxlor das auch für das erstellen der pool-configs.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...