Jump to content
Froxlor Forum
  • 0
clarkx86

Root-Verzeichnis ändert sich von /var/www/html/ zu /var/www/

Question

Guten Abend liebe Froxlor-Community,

ich habe soeben meinen vServer frisch aufgesetzt und Froxlor neuinstalliert. Alles hat auch wieder reibungslos geklappt und ich habe nach der Installation alles Eingerichtet (ProFTPd, Cronjobs, etc.), Kunden erstellt und alles läuft super.

Das einzig Merkwürdige ist, dass nachdem Froxlor das erste mal die Cronjobs ausgeführt hat, die Froxlor-Login Seite nicht mehr unter der IP/ dem Hostnamen meines Servers zu erreichen ist, sondern plötzlich ein Verzeichnis darüber landet, also nicht /var/www/html/ sondern /var/www/, sodass ich auf der "Index of /" Seite von Apache lande und erst einmal auf das Verzeichnes "html" klicken muss, bis ich dann wieder auf der Froxlor-Seite lande.
Wie gesagt, ich kann bestätigen dass der Hostname nach frischer Froxlor-Installation auf das richtige Verzeichnis verweist, doch nach dem ersten Ausführen der Cronjobs plötzlich ein Verzeichnis höher rutscht.

Dies hat nach meiner Erfahrung bisher keine weitere Probleme mit sich geführt, dennoch fand ich dies etwas merkwürdig und ich denke ich habe etwas falsch konfiguriert (?).

Hat jemand einen Schimmer woran dies liegen könnte? Möglicherweise geht das auch alles mit rechten Dingen zu und ich hatte nur vorher immer etwas falsch eingestellt...

Ich bedanke mich schon einmal im Vorraus und wünsche noch einen schönen Abend!

EDIT: Ich habe nun herausgefunden, dass der Cronjob den VirtualHost für "/etc/apache2/sites-enabled/10_froxlor_ipandport_<meine_ip>.conf" umschreibt und den DocumentRoot von "/var/www/html/" zu "/var/www"/ ändert. Sollte ich Froxlor von Anfang in dieses Verzeichnes extrahieren (bzw. /var/www/froxlor/ statt /var/www/html/) oder lässt sich der Pfad anderweitig konfigurieren? Lg :)

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
6 hours ago, clarkx86 said:

Das einzig Merkwürdige ist, dass nachdem Froxlor das erste mal die Cronjobs ausgeführt hat, die Froxlor-Login Seite nicht mehr unter der IP/ dem Hostnamen meines Servers zu erreichen ist, sondern plötzlich ein Verzeichnis darüber landet, also nicht /var/www/html/ sondern /var/www/, sodass ich auf der "Index of /" Seite von Apache lande und erst einmal auf das Verzeichnes "html" klicken muss, bis ich dann wieder auf der Froxlor-Seite lande.

Alles eine Frage der Einstellungen...aber auf jeden fall gibst du ja bei der Installationen eine Domainnamen an, der als Froxlor-Vhost/System-Host verwendet wird und über den froxlor auch erreichbar ist, sofern entsprechende optionen (default ist das so) aktiviert sind.

6 hours ago, clarkx86 said:

EDIT: Ich habe nun herausgefunden, dass der Cronjob den VirtualHost für "/etc/apache2/sites-enabled/10_froxlor_ipandport_<meine_ip>.conf" umschreibt und den DocumentRoot von "/var/www/html/" zu "/var/www"/ ändert. Sollte ich Froxlor von Anfang in dieses Verzeichnes extrahieren (bzw. /var/www/froxlor/ statt /var/www/html/) oder lässt sich der Pfad anderweitig konfigurieren? Lg :)

der schreibt nichts "um", der tut das was ihm gesagt wird. Froxlor solltest du laut wiki nach /var/www/ entpacken, ergo gibt es dann /var/www/froxlor. Du kannst natürlich genauso nach /var/www/html/ entpacken um dann /var/www/html/froxlor zu haben. Ganz egal.

Per default wird froxlor den vhost mit seinem Elternverzeichnis erstellen, der aufruf von froxlor folgt dann via http://hostname/froxlor - alternativ kannst du die einstellung "froxlor direkt über hostnamen verfügbar machen" aktivieren und froxlor wird in den vhost /var/www/froxlor statt /var/www/ schreiben und froxlor erreichst du dann via http://hostname/

 

Share this post


Link to post
Share on other sites
  • 0

Vielen Dank für die schnelle Antwort.


Okay, dann geht ja doch alles mit rechten Dingen zu :D!

vor 6 Stunden schrieb d00p:

alternativ kannst du die einstellung "froxlor direkt über hostnamen verfügbar machen" aktivieren

Genau das hab ich gesucht :)! Super, tausend Dank!

LG

(kann gerne geschlossen werden :))

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...