Jump to content
Froxlor Forum
  • 0
witschi

FCGID Timeout

Question

Hallo,

ich habe ein Problem mit FCGID Timeout. Ich nutze froxlor in der neusten Version (0.9.40.1-1). Außerdem haben wir einen Apache2 mit FCGID im Einsatz. Nun habe ich ein Script, das länger als 10 Minuten benötigt. Ich bekomme jedoch in meiner Log-Datei von vhost immer folgenden Fehler:

[Wed Jun 19 10:17:34.467769 2019] [fcgid:warn] [pid 22291] [client 87.167.97.19:54254] mod_fcgid: read data timeout in 600 seconds, referer: https://example.de/
[Wed Jun 19 10:17:34.467852 2019] [core:error] [pid 22291] [client 87.167.97.19:54254] End of script output before headers: sync_zast.php, referer: https://example.de/

In den Einstellungen für den Apache gibt es nichts bezüglich des Timeouts. In den Einstellungen des vhosts habe ich die max_execution_time erhöht. Hat jedoch keine Auswirkungen.

In den Einstellungen des FCGID habe ich dann die Einstellung "Idle-Timeout - Timeout-Einstellung für mod_FastCGI." gefunden. Dies stand jedoch auf 60 Sekunden, damit war die Verwirrung perfekt.

In der Datei /etc/apache2/mods-available/fcgid.conf finde ich jedoch die Zeile "FcgidIOTimeout 600". Ist das nochmal ein anderer Timeout? kommen sich hier verschiedene Timeouts in die Quere? Ich komme nicht mit und bin mir nicht sicher, ob ich irgendetwas nicht richtig verstehe, oder die Einstellung von froxlor nicht richtig übernommen wird.

Danke für die Hilfe!

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1
Just now, witschi said:

Heißt aber, dass die Option in froxlor nicht konfigurierbar ist, sondern ich in die fcgid.conf anpassen muss?

Generell, ja

Just now, witschi said:

Oder kann ich die Option irgendwie auch für bestimmte vhosts erstellt werden?

Ja, in den "eigene vhost Einstellungen" pro Domain kannst du natürlich die Option einfach angeben, z.B.

FcgidIOTimeout 1200

Der Cronjob schreibt dir das dann in den entsprechenden Vhost

Share this post


Link to post
Share on other sites
  • 0

Bei read data timeout sollte FcgidIOTimeout die entsprechende konfiguration sein ja

Share this post


Link to post
Share on other sites
  • 0

Heißt aber, dass die Option in froxlor nicht konfigurierbar ist, sondern ich in die fcgid.conf anpassen muss?

Oder kann ich die Option irgendwie auch für bestimmte vhosts erstellt werden?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...