Jump to content
Froxlor Forum

witschi

Members
  • Content Count

    30
  • Joined

  • Last visited

Everything posted by witschi

  1. Das Query Log bringt mich dann wohl auch nicht weiter. Da drin sieht aber auch alles gut aus. Die Cronjobs laufen durch und enden auch mit einem QUIT. Das Problem muss also libnss sein. Kann ich nicht den Server nicht auch ohne libnss konfigurieren? Ich komme nicht dahinter, warum er nicht connecten kann. Die sock-Datei ist vorhanden und ist sogar mit 777 für jeden lesbar.
  2. Ja, genau. libnss-extrausers gibt es nicht. Ich sehe aber gerade im messages-Log, dass der Cronjob Fehler wirft: Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/
  3. Hallo Zusammen, ich habe gerade das Problem, dass pro Sekunde etwa zwei weitere Connections zu MariaDB aufgebaut werden (die scheinbar nie quittiert werden). Das hat zur Folge, dass irgendwann alles zusammenbricht. show status where variable_name LIKE '%conne%' Damit bekomme ich die Variablen Connections (steht aktuell bei 2733 und verändert sich sekündlich). Threads_connected steht bei 210, was mir auch sehr hoch erscheint. Wenn ich mir nun die Processlist ansehe: select * from information_schema.processlist sind 99% vom user froxlor auf die Datenbank froxlor.
  4. Das hat geholfen. Komisch. Vielen Dank für deine Hilfe!
  5. Nein, direkt beim Aufsetzen des Servers wurde auf FPM gesetzt.
  6. Ja, nutze ich. Und habe es auch entsprechend der Konfigurationsanleitung konfiguriert. Müsste da schon der User/die Gruppe froxlorlocal drin sein? cat /var/lib/extrausers/group customer:x:10000:customer,www-data,customerftp1 cat /var/lib/extrausers/passwd customer:x:10000:10000:Customer:/var/customers/webs/customer/:/bin/false customerftp1:x:10000:10000:Customer:/var/customers/webs/customer/example.com/:/bin/bash
  7. ich habe die gruppe und den user froxlorlocal selbst angelegt. sollte ich das lieber durch den cronjob erledigen lassen? Dann würde ich jetzt php-fpm noch mal stoppen, gruppe und user froxlorlocal löschen und den cronjob laufen lassen?!
  8. Hi d00p, ich habe folgendes Problem: Ubuntu Bionic mit Apache 2.4 und PHP-FPM. Alles funktioniert tadellos, mit einer Ausnahme: In den Panel-Einstellungen habe ich die Pfad-Eingabemethode auf Auswahlliste gestellt. Wenn ich mich nun mit einem User öffne und dort eine Domain bearbeiten möchte, bekomme ich folgende Fehlermeldung: Offensichtlich kann froxlorlocal nicht in dem Verzeichnis des Users lesen. Wenn ich id customer ausführe, erhalte ich folgende Rückmeldung: uid=10000(customer) gid=10000(customer) groups=10000(customer) Wahrscheinlich auch
  9. Hallo d00p, ich wollte gerade Froxlor in einem Redhat-System aufsetzen. Kann es sein, dass die Kompatibilität dort nicht gegeben ist? Einen Ordner /etc/apache2/ gibt es da ja nicht, weil die Configs in /etc/httpd/ liegen. Auch die Crons kann ich nicht einrichten: /usr/bin/php /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --run-task 99 sh: /etc/init.d/cron: Datei oder Verzeichnis nicht gefunden Kannst du mir da weiterhelfen? Viele Grüße und ein besinnliches Fest Christoph
  10. Heißt aber, dass die Option in froxlor nicht konfigurierbar ist, sondern ich in die fcgid.conf anpassen muss? Oder kann ich die Option irgendwie auch für bestimmte vhosts erstellt werden?
  11. Hallo, ich habe ein Problem mit FCGID Timeout. Ich nutze froxlor in der neusten Version (0.9.40.1-1). Außerdem haben wir einen Apache2 mit FCGID im Einsatz. Nun habe ich ein Script, das länger als 10 Minuten benötigt. Ich bekomme jedoch in meiner Log-Datei von vhost immer folgenden Fehler: [Wed Jun 19 10:17:34.467769 2019] [fcgid:warn] [pid 22291] [client 87.167.97.19:54254] mod_fcgid: read data timeout in 600 seconds, referer: https://example.de/ [Wed Jun 19 10:17:34.467852 2019] [core:error] [pid 22291] [client 87.167.97.19:54254] End of script output before headers: sync_zast.php,
  12. Danke, tatsächlich lässt froxlor da ziemlich Datenmüll liegen. Nicht nur beim deaktivieren vom Nameserver für eine Domain. Auch beim Löschen einer Domain bleiben alle Einträge für die entsprechende Domain in der Tabelle vorhanden. Sowohl in der Tabelle domains, als auch in der records. Soll ich dir das mal im github notieren?
  13. Das gilt ja nur für diese eine Domain. Für eine vielzahl anderer Domains bin ich der Haupt-Nameserver.
  14. Dem ist leider nicht so. Im folgenden Screenshot ist zu sehen, wie die Domain konfiguriert ist: Die entsprechenden Einstellungen sind somit alle deaktiviert. Was mich außerdem sehr gewundert hat ist, dass ich in der Datenbank pdns.domains ganz viele Einträge zu Domains finde, die ich schon lange nicht mehr in froxlor verwalte. Kann es also sein, dass auch die Einträge in pdns.records Leichen sind?
  15. Hallo liebe Gemeinde :), folgende Situation herrscht aktuell vor: Ich betreibe einen debian stretch mit froxlor und pdns als standalone. Nun habe ich eine Domain, dessen Internetseite auf diesem Server läuft. Der Mail-Server ist extern. Nun habe ich jedoch das Problem, dass die Internetseite (ein Online-Shop) bei Bestellungseingang eine Mail an shop@domain.tld sendet. Wenn ich nun aber den pdns gestartet habe, dann bekomme ich einen Fehler beim Mailversand (status=bounced (mail for domain.tld loops back to myself)). Ich habe gehofft, dass ich dieses Problem nicht mehr habe, wenn ich
  16. nscd ist installiert und es funktioniert inzwischen alles tadellos. Anmerkungen findest du weiter oben.
  17. seaside64:x:10031:10031:Froxlor Customer:/var/customers/webs/seaside64/:/bin/false
  18. # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat mysql group: compat mysql shadow: compat mysql hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files
  19. Nein, das Problem sind folgende Dateirechte, die du in der Konfiguration von libnss-mysql beschreibst: chmod 0600 "/etc/libnss-mysql.cfg" Dadurch ist es anderen Usern nicht möglich die eigenen Informationen auszulesen und somit funktioniert am Ende auch das versenden von Mails aus einem Cronjob nicht. Man könnte natürlich auch sagen, dass man alles so lässt und nur die Dateirechte der Config auf 0644 setzt, aber meine bedenken dazu habe ich ja bereits geäußert...
  20. Ich dachte mir schon, dass eine solche Antwort kommt. Wie du dir aber sicher denken kannst, war dies als konstruktive Kritik zu verstehen. ;-)
  21. Es ist doch so, dass ein User immer in der Lage sein sollte, seine eigenen Informationen abzufragen. Dazu müsste aber die libnss-mysql.cfg lesbar für alle sein. Da dort aber der Zugang zur Froxlor-Datenbank drin steht, ist das natürlich keine Option. Deswegen habe ich nun einen nss-user angelegt (mit den entsprechenden SELECT-Rechten auf die Tabellen ftp_users und ftp_groups) und diesen in die libnss-mysql.cfg geschrieben. In der libnss-mysql-root.cfg steht natürlich weiterhin der root-user für die Froxlor-Datenbank. Nun konnte ich also auch die libnss-mysql.cfg lesbar für alle machen und sieh
×
×
  • Create New...