Jump to content
Froxlor Forum

witschi

Members
  • Posts

    30
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

witschi's Achievements

Explorer

Explorer (4/14)

  • Conversation Starter
  • Week One Done
  • One Month Later
  • One Year In
  • First Post

Recent Badges

0

Reputation

  1. Das Query Log bringt mich dann wohl auch nicht weiter. Da drin sieht aber auch alles gut aus. Die Cronjobs laufen durch und enden auch mit einem QUIT. Das Problem muss also libnss sein. Kann ich nicht den Server nicht auch ohne libnss konfigurieren? Ich komme nicht dahinter, warum er nicht connecten kann. Die sock-Datei ist vorhanden und ist sogar mit 777 f├╝r jeden lesbar.
  2. Ja, genau. libnss-extrausers gibt es nicht. Ich sehe aber gerade im messages-Log, dass der Cronjob Fehler wirft: Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Apr 7 11:00:03 akqhplvap202 journal: aster process (/etc/php-fpm.conf): libnss-mysql: Connection to server 'localhost' failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (11) Obowohl die .sock-Datei vorhanden ist. User und Group sind mysql. Wie schalte ich das query-debugging ein? Google macht mich da nicht schlauer. ­čśä
  3. Hallo Zusammen, ich habe gerade das Problem, dass pro Sekunde etwa zwei weitere Connections zu MariaDB aufgebaut werden (die scheinbar nie quittiert werden). Das hat zur Folge, dass irgendwann alles zusammenbricht. show status where variable_name LIKE '%conne%' Damit bekomme ich die Variablen Connections (steht aktuell bei 2733 und ver├Ąndert sich sek├╝ndlich). Threads_connected steht bei 210, was mir auch sehr hoch erscheint. Wenn ich mir nun die Processlist ansehe: select * from information_schema.processlist sind 99% vom user froxlor auf die Datenbank froxlor. Zu meiner Konfiguration: NAME="Red Hat Enterprise Linux Server" VERSION="7.9 (Maipo)" Der Webserver ist ein Apache 2 mit PHP-FPM. Nun hatte ich ebenfalls eine Weile das Problem, dass die socket-Datei in /var/lib/apache2/fastcgi nicht gelesen werden konnte. Nachdem ich dort mit chmod 777 die Rechte ge├Ąndert habe, gab es auch kein 503er vom Webserver mehr. Meine Vermutung ist, dass der nscd die Verbindung zur Datenbank nicht terminiert und auch nicht cached. Ich wei├č aber nicht so Recht wie ich das pr├╝fen soll. Kann man die offenen Connections irgendwie pr├╝fen? Gibts ansonsten irgendwelche Anhaltspunkte, die ich verfolgen k├Ânnte? Alle eingesetzten Pakete sind ├╝brigens in der neusten Version aus den Repos. Auch Froxlor ist in der neusten Version 0.10.25 installiert. Webserver: Apache/2.4.35 (IUS) OpenSSL/1.0.2k-fips mod_fcgid/2.3.9 PHP/7.3.27 PHP-Version: 7.3.27 MySQL-Server-Version: 5.5.68-MariaDB Webserver-Interface: FPM-FCGI Speicherauslastung: MemTotal: 49294584 kB MemFree: 33253948 kB MemAvailable: 39656604 kB System-Auslastung: 0.45 / 0.58 / 0.65 Kernel: 3.10.0-1160.21.1.el7.x86_64 (x86_64) Uptime: 7d, 15h, 6m, 16s Ich k├Ânnte ├╝brigens auch auf nscd verzichten, da eh nur ein "Kunde" auf dem Server liegt. Vielen Dank schon Mal!
  4. Das hat geholfen. Komisch. Vielen Dank f├╝r deine Hilfe!
  5. Nein, direkt beim Aufsetzen des Servers wurde auf FPM gesetzt.
  6. Ja, nutze ich. Und habe es auch entsprechend der Konfigurationsanleitung konfiguriert. M├╝sste da schon der User/die Gruppe froxlorlocal drin sein? cat /var/lib/extrausers/group customer:x:10000:customer,www-data,customerftp1 cat /var/lib/extrausers/passwd customer:x:10000:10000:Customer:/var/customers/webs/customer/:/bin/false customerftp1:x:10000:10000:Customer:/var/customers/webs/customer/example.com/:/bin/bash
  7. ich habe die gruppe und den user froxlorlocal selbst angelegt. sollte ich das lieber durch den cronjob erledigen lassen? Dann w├╝rde ich jetzt php-fpm noch mal stoppen, gruppe und user froxlorlocal l├Âschen und den cronjob laufen lassen?!
  8. Hi d00p, ich habe folgendes Problem: Ubuntu Bionic mit Apache 2.4 und PHP-FPM. Alles funktioniert tadellos, mit einer Ausnahme: In den Panel-Einstellungen habe ich die Pfad-Eingabemethode auf Auswahlliste gestellt. Wenn ich mich nun mit einem User ├Âffne und dort eine Domain bearbeiten m├Âchte, bekomme ich folgende Fehlermeldung: Offensichtlich kann froxlorlocal nicht in dem Verzeichnis des Users lesen. Wenn ich id customer ausf├╝hre, erhalte ich folgende R├╝ckmeldung: uid=10000(customer) gid=10000(customer) groups=10000(customer) Wahrscheinlich auch noch relevant: id www-data uid=33(www-data) gid=33(www-data) groups=9999(froxlorlocal),10000(customer),33(www-data) id froxlorlocal uid=9999(froxlorlocal) gid=9999(froxlorlocal) groups=9999(froxlorlocal) Ist das jetzt noch ein Fehler meiner Konfiguration, oder tats├Ąchlich ein Fehler von Froxlor? Danke f├╝r die R├╝ckmeldung.
  9. Hallo d00p, ich wollte gerade Froxlor in einem Redhat-System aufsetzen. Kann es sein, dass die Kompatibilit├Ąt dort nicht gegeben ist? Einen Ordner /etc/apache2/ gibt es da ja nicht, weil die Configs in /etc/httpd/ liegen. Auch die Crons kann ich nicht einrichten: /usr/bin/php /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --run-task 99 sh: /etc/init.d/cron: Datei oder Verzeichnis nicht gefunden Kannst du mir da weiterhelfen? Viele Gr├╝├če und ein besinnliches Fest Christoph
  10. Hei├čt aber, dass die Option in froxlor nicht konfigurierbar ist, sondern ich in die fcgid.conf anpassen muss? Oder kann ich die Option irgendwie auch f├╝r bestimmte vhosts erstellt werden?
  11. Hallo, ich habe ein Problem mit FCGID Timeout. Ich nutze froxlor in der neusten Version (0.9.40.1-1). Au├čerdem haben wir einen Apache2 mit FCGID im Einsatz. Nun habe ich ein Script, das l├Ąnger als 10 Minuten ben├Âtigt. Ich bekomme jedoch in meiner Log-Datei von vhost immer folgenden Fehler: [Wed Jun 19 10:17:34.467769 2019] [fcgid:warn] [pid 22291] [client 87.167.97.19:54254] mod_fcgid: read data timeout in 600 seconds, referer: https://example.de/ [Wed Jun 19 10:17:34.467852 2019] [core:error] [pid 22291] [client 87.167.97.19:54254] End of script output before headers: sync_zast.php, referer: https://example.de/ In den Einstellungen f├╝r den Apache gibt es nichts bez├╝glich des Timeouts. In den Einstellungen des vhosts habe ich die max_execution_time erh├Âht. Hat jedoch keine Auswirkungen. In den Einstellungen des FCGID habe ich dann die Einstellung "Idle-Timeout - Timeout-Einstellung f├╝r mod_FastCGI." gefunden. Dies stand jedoch auf 60 Sekunden, damit war die Verwirrung perfekt. In der Datei /etc/apache2/mods-available/fcgid.conf finde ich jedoch die Zeile "FcgidIOTimeout 600". Ist das nochmal ein anderer Timeout? kommen sich hier verschiedene Timeouts in die Quere? Ich komme nicht mit und bin mir nicht sicher, ob ich irgendetwas nicht richtig verstehe, oder die Einstellung von froxlor nicht richtig ├╝bernommen wird. Danke f├╝r die Hilfe!
×
×
  • Create New...