Jump to content
Froxlor Forum

witschi

Members
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutral

About witschi

  • Rank
    Froxie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. herzlichen dank!
  2. Heißt aber, dass die Option in froxlor nicht konfigurierbar ist, sondern ich in die fcgid.conf anpassen muss? Oder kann ich die Option irgendwie auch für bestimmte vhosts erstellt werden?
  3. Hallo, ich habe ein Problem mit FCGID Timeout. Ich nutze froxlor in der neusten Version (0.9.40.1-1). Außerdem haben wir einen Apache2 mit FCGID im Einsatz. Nun habe ich ein Script, das länger als 10 Minuten benötigt. Ich bekomme jedoch in meiner Log-Datei von vhost immer folgenden Fehler: [Wed Jun 19 10:17:34.467769 2019] [fcgid:warn] [pid 22291] [client 87.167.97.19:54254] mod_fcgid: read data timeout in 600 seconds, referer: https://example.de/ [Wed Jun 19 10:17:34.467852 2019] [core:error] [pid 22291] [client 87.167.97.19:54254] End of script output before headers: sync_zast.php, referer: https://example.de/ In den Einstellungen für den Apache gibt es nichts bezüglich des Timeouts. In den Einstellungen des vhosts habe ich die max_execution_time erhöht. Hat jedoch keine Auswirkungen. In den Einstellungen des FCGID habe ich dann die Einstellung "Idle-Timeout - Timeout-Einstellung für mod_FastCGI." gefunden. Dies stand jedoch auf 60 Sekunden, damit war die Verwirrung perfekt. In der Datei /etc/apache2/mods-available/fcgid.conf finde ich jedoch die Zeile "FcgidIOTimeout 600". Ist das nochmal ein anderer Timeout? kommen sich hier verschiedene Timeouts in die Quere? Ich komme nicht mit und bin mir nicht sicher, ob ich irgendetwas nicht richtig verstehe, oder die Einstellung von froxlor nicht richtig übernommen wird. Danke für die Hilfe!
  4. Danke, tatsächlich lässt froxlor da ziemlich Datenmüll liegen. Nicht nur beim deaktivieren vom Nameserver für eine Domain. Auch beim Löschen einer Domain bleiben alle Einträge für die entsprechende Domain in der Tabelle vorhanden. Sowohl in der Tabelle domains, als auch in der records. Soll ich dir das mal im github notieren?
  5. Das gilt ja nur für diese eine Domain. Für eine vielzahl anderer Domains bin ich der Haupt-Nameserver.
  6. Dem ist leider nicht so. Im folgenden Screenshot ist zu sehen, wie die Domain konfiguriert ist: Die entsprechenden Einstellungen sind somit alle deaktiviert. Was mich außerdem sehr gewundert hat ist, dass ich in der Datenbank pdns.domains ganz viele Einträge zu Domains finde, die ich schon lange nicht mehr in froxlor verwalte. Kann es also sein, dass auch die Einträge in pdns.records Leichen sind?
  7. Hallo liebe Gemeinde :), folgende Situation herrscht aktuell vor: Ich betreibe einen debian stretch mit froxlor und pdns als standalone. Nun habe ich eine Domain, dessen Internetseite auf diesem Server läuft. Der Mail-Server ist extern. Nun habe ich jedoch das Problem, dass die Internetseite (ein Online-Shop) bei Bestellungseingang eine Mail an shop@domain.tld sendet. Wenn ich nun aber den pdns gestartet habe, dann bekomme ich einen Fehler beim Mailversand (status=bounced (mail for domain.tld loops back to myself)). Ich habe gehofft, dass ich dieses Problem nicht mehr habe, wenn ich den Nameserver für die Domain deaktivere. Leider bleiben dann jedoch folgende Einträge in der Datenbank in pdns.records: (`domain_id`, `name`, `type`, `content`, `ttl`, `prio`, `change_date`, `disabled`, `ordername`, `auth`) (25514, 'domain.tld', 'SOA', 'meine-domain.de. froxlor.meine-domain.de. 2018102204 3600 900 604800 1200', 18000, 0, 2018102205, 0, NULL, 1), (25514, 'domain.tld', 'A', '77.99.77.111', 18000, 0, 2018102205, 0, NULL, 1), (25514, 'www.domain.tld', 'A', '77.99.77.111', 18000, 0, 2018102205, 0, NULL, 1), (25514, 'domain.tld', 'NS', 'meine-domain.de.', 18000, 0, 2018102205, 0, NULL, 1) Ich habe eigentlich erwartet, dass ich gar keinen EIntrag, oder zumindest den SOA Eintrag nicht mehr in der Tabelle finde. Habe ich folglich irgendwas falsch konfiguriert oder was mache ich hier falsch? Sobald ich den pdns-service stoppe, funktioniert der Mail-Versand wieder. Vielen Dank schon mal für die Hilfe. Viele Grüße Christoph
  8. nscd ist installiert und es funktioniert inzwischen alles tadellos. Anmerkungen findest du weiter oben.
  9. seaside64:x:10031:10031:Froxlor Customer:/var/customers/webs/seaside64/:/bin/false
  10. # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat mysql group: compat mysql shadow: compat mysql hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files
  11. Nein, das Problem sind folgende Dateirechte, die du in der Konfiguration von libnss-mysql beschreibst: chmod 0600 "/etc/libnss-mysql.cfg" Dadurch ist es anderen Usern nicht möglich die eigenen Informationen auszulesen und somit funktioniert am Ende auch das versenden von Mails aus einem Cronjob nicht. Man könnte natürlich auch sagen, dass man alles so lässt und nur die Dateirechte der Config auf 0644 setzt, aber meine bedenken dazu habe ich ja bereits geäußert...
  12. Ich dachte mir schon, dass eine solche Antwort kommt. Wie du dir aber sicher denken kannst, war dies als konstruktive Kritik zu verstehen. ;-)
  13. Es ist doch so, dass ein User immer in der Lage sein sollte, seine eigenen Informationen abzufragen. Dazu müsste aber die libnss-mysql.cfg lesbar für alle sein. Da dort aber der Zugang zur Froxlor-Datenbank drin steht, ist das natürlich keine Option. Deswegen habe ich nun einen nss-user angelegt (mit den entsprechenden SELECT-Rechten auf die Tabellen ftp_users und ftp_groups) und diesen in die libnss-mysql.cfg geschrieben. In der libnss-mysql-root.cfg steht natürlich weiterhin der root-user für die Froxlor-Datenbank. Nun konnte ich also auch die libnss-mysql.cfg lesbar für alle machen und siehe da: alle meine Probleme sind gelöst. Die Standard-Beispiel-Configs von libnss-mysql ist es übrigens auch genau so vorgesehen, wie ich es jetzt umgesetzt habe.
  14. Zum Testen habe ich nur ein echo ausgeführt - das sollte dann ja bereits per Mail versandt werden. Aber auch der Test eine E-Mail-Direkt über die User-Shell zu versenden klappt nicht: $ echo "Test" | mail -s "Test Subject" server@nn-webdesign.com send-mail: fatal: no login name found for user ID 10031 Can't send mail: sendmail process failed with error code 75
  15. Leider hilft das nicht weiter. Ich habe dem entsprechenden User die Shell /bin/bash zur Verfügung gestellt - der Fehler im syslog bleibt aber der selbe. Auch nach restart des Postfix und des Cron-Daemons. Ein Login mittels Putty funktioniert jedoch reibungslos...
×
×
  • Create New...