Jump to content
Froxlor Forum
  • 0
veto

debian9, nginx and php7.3-fpm.log

Question

hi,

i try to bring debian9,nginx and php7.3-fpm to work.

at the moment i hang with the error form

tail -f php7.3-fpm.log error

c[14-Mar-2019 06:26:59] ERROR: [pool jewelry.vin] cannot get uid for user 'jewelry'
[14-Mar-2019 06:26:59] ERROR: FPM initialization failed

my user is called jewelry

and i see that froxlor created  automatically the file

/etc/php/7.3/fpm/pool.d/jewelry.vin.conf

 

PHP-FPM configuration for "jewelry.vin" created on 2019.03.14 06:26:59
[jewelry.vin]
listen = /var/run/1-jewelry-jewelry.vin-php-fpm.socket
listen.owner = jewelry
listen.group = jewelry
listen.mode = 0660
user = jewelry
group = jewelry
pm = static
pm.max_children = 1
pm.max_requests = 0
;chroot = /var/customers/webs/jewelry/
security.limit_extensions = .php
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /var/customers/tmp/jewelry/
env[TMPDIR] = /var/customers/tmp/jewelry/
env[TEMP] = /var/customers/tmp/jewelry/
php_admin_value[session.save_path] = /var/customers/tmp/jewelry/
php_admin_value[upload_tmp_dir] = /var/customers/tmp/jewelry/


php_admin_flag[allow_call_time_pass_reference] = Off
php_admin_flag[allow_url_fopen] = On
php_flag[asp_tags] = Off
php_admin_value[disable_classes] =
php_admin_value[disable_functions] = curl_multi_exec,exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system
php_flag[display_errors] = Off
php_flag[display_startup_errors] = Off
php_admin_flag[enable_dl] = Off
php_value[error_reporting] = E_ALL & ~E_NOTICE
php_admin_flag[expose_php] = Off
php_admin_flag[file_uploads] = On
php_admin_flag[cgi.force_redirect] = 1
php_admin_value[gpc_order] = "GPC"
php_flag[html_errors] = Off
php_admin_flag[ignore_repeated_errors] = Off
php_admin_flag[ignore_repeated_source] = Off
php_value[include_path] = ".:/usr/share/php/:/usr/share/php7/"
php_flag[log_errors] = On
php_admin_flag[log_errors] = On
php_value[log_errors_max_len] = 1024
php_flag[magic_quotes_gpc] = Off
php_flag[magic_quotes_runtime] = Off
php_flag[magic_quotes_sybase] = Off
php_value[max_execution_time] = 60
php_admin_value[max_input_time] = 60
php_admin_value[memory_limit] = 128M
php_admin_value[output_buffering] = 4096
php_admin_value[post_max_size] = 16M
php_admin_value[precision] = 14
php_admin_flag[register_argc_argv] = Off
php_admin_flag[report_memleaks] = On
php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i -f pd_web0@body-piercing.com"
php_value[session.auto_start] = 0
php_value[session.cookie_domain] =
php_value[session.cookie_lifetime] = 0
php_value[session.cookie_path] = /
php_admin_value[session.gc_divisor] = 1000
php_admin_value[session.gc_probability] = 1
php_value[session.name] = PHPSESSID
php_value[session.serialize_handler] = php
php_flag[session.use_cookies] = 1
php_flag[short_open_tag] = On
php_flag[suhosin.simulation] = Off
php_flag[track_errors] = Off
php_value[upload_max_filesize] = 32M
php_admin_value[variables_order] = "GPCS"
php_admin_value[opcache.restrict_api] = ""

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

sudo adduser jewelry --disabled-password --no-create-home && sudo usermod -a -G www-data jewelry && service php7.3-fpm restart

  • Downvote 1

Share this post


Link to post
Share on other sites
  • 0

No @irisdina

That is most likely a froxlor user being read from the database so @veto might be missing the libnss setup.

Can you please verify that you've installed and configured libnss-mysql OR libnss-extrausers (if activated in froxlor) according to the froxlor config templates?

Share this post


Link to post
Share on other sites
  • 0

yes, i did not installed the required libnss. but after this setup and restart i still got the same error.

than i did what @irisdina suggested and the error was gone.

1.
adduser jewelry --no-create-home --disabled-password

2.
usermod -a -G www-data jewelry

3.
/etc/init.d/php7.3-fcgi restart

 

still my  php script was not running from my /var/customer/jewelry/info.php

after test-change the permission to 777 of the automatic created socket file

srw-rw----  1 jewelry  jewelry      0 Mar 14 08:19 1-jewelry-jewelry.vin-php-fpm.socket

 

it works.

 

chmod 777 1-jewelry-jewelry.vin-php-fpm.socket

 

 

 

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, veto said:

than i did what @irisdina suggested and the error was gone.

but it's just wrong

Share this post


Link to post
Share on other sites
  • 0

i can confirm, just created a new user and domain

and im getting now 

[14-Mar-2019 08:33:56] ERROR: [pool de.merkuro.com] cannot get uid for user 'merkuro'
[14-Mar-2019 08:33:56] ERROR: FPM initialization failed

i think im missing some settings.

Share this post


Link to post
Share on other sites
  • 0
59 minutes ago, d00p said:

Can you please verify that you've installed and configured libnss-mysql OR libnss-extrausers (if activated in froxlor) according to the froxlor config templates?

 

Share this post


Link to post
Share on other sites
  • 0

yes i followed Configuration>Distribution>Debian9>Service>Others->libnss-extrausers

but i do not have libnss-mysql in debian9

Share this post


Link to post
Share on other sites
  • 0

Did you also activate usage of libnss-extrausers in froxlor settings -> system settings -> Use libnss-extrausers instead of libnss-mysql

Share this post


Link to post
Share on other sites
  • 0

i did not activate it.

YES!! now it works. Thanks a lot for you help.

i will write this down for my next installation.

my time and knowledge is limited, but if i could contribute to froxlor in any way, it  would be a honor.

Share this post


Link to post
Share on other sites
  • 0

but i still had to chmod the  sockets to 777

root@cicurina /var/run # chmod 777 1-jewelry-jewelry.vin-php-fpm.socket
root@cicurina /var/run # chmod 777 1-merkuro-de.merkuro.com-php-fpm.socket

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...