Jump to content
Froxlor Forum
  • 0

E-Mail Piping


Afox
 Share

Question

Hallo,

ich würde gerne sämtlichen E-Mail-Verkehr einer bestimmten Adresse an eine Remote-Adresse (http://www.domain.com/api/api-script pipen.

Wie kann ich das am Froxlor-verträglichsten umsetzen?

Eine Weiterleitung mit der URL darin wird wohl nicht funktionieren gehe ich mal davon aus. Außerdem fände ich in dem Fall nicht so gut, dass die Mail dann doppelt vorhanden wäre.

Gruß,

Afox

Link to comment
Share on other sites

  • Answers 52
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 0

so schaut die Mail aus (DKIM nach dem Received Teil habe ich entfernt)

From sender@domain.tld  Sun Feb 10 21:14:35 2019
Received: from somepc (unknown [#IP#])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(No client certificate requested)
	by mailserver.domain.tld (Postfix) with ESMTPSA id C9BB0100AF9
	for <recipient@domain.tld>; Sun, 10 Feb 2019 21:14:35 +0100 (CET)

Message-ID: <somelettersandnumbers@domain.tld>
Subject: Test
From: "domain.tld" <sender@domain.tld>
To: recipient@domain.tld
Date: Sun, 10 Feb 2019 21:14:34 +0100
Content-Type: text/plain
User-Agent: xxx
MIME-Version: 1.0
Content-Transfer-Encoding: quoted-printable

Test

 

Link to comment
Share on other sites

  • 0

naja, das heisst erstmal nunr das der webserver api/pipe.php gefunden hat und die ausführung keinen internen fehler ausgeworfen hat....garantiert natürlich nich das das ding exakt das gemacht hat was es soll. Ich kenn halt das script nich und das projekt was da dahintersteckt was du einsetzt, daher ist hier hilfe eher schwierig

Link to comment
Share on other sites

  • 0

Laut htaccess geht er ja auf http.php und nicht auf pipe.php...das scheint aber in deinem fall (lokal) korrekt zu sein, allerdings nur wenn du nicht via URL zugreifst, probier doch mal  an /pfad/zu/osTicket/api/pipe.php weiterzuleiten

Allerdings ist das zeug da alles JAHRE alt...ich bin nicht sicher in wieweit das halt mit modernem PHP noch tut....ich seh da echt altes zeug...(z.B. funktions-deklarationen ohne sichtbarkeit etc.)

Link to comment
Share on other sites

  • 0

ehm, mein Fall ist aber remote, also ich komme von einem externen Mailserver der die Mail wie hier in diesem Thema beschrieben an die automail.php (https://github.com/osTicket/osTicket/blob/develop/setup/scripts/automail.php) weiterleitet und die automail.php sollte dann eigentlich alles erledigen. Scheint ja nicht so ganz zu klappen bisher :D

Also soll ich in Froxlor eine Weiterleitung von http.php nach pipe.php machen oder wie meintest du?

Link to comment
Share on other sites

  • 0
Just now, Afox said:

Also soll ich in Froxlor eine Weiterleitung von http.php nach pipe.php machen oder wie meintest du?

Nein natürlich nicht - das eine ist für den aufruf via HTTP protokoll, das andere via Shell...du willst als auf http.php POST'en und nicht auf pipe.php

Vllt fragst du da aber dann besser mal in osTicket foren ... das wird hier langsam sehr speziell und der Fehler liegt dabei nicht bei froxlor

Link to comment
Share on other sites

  • 0

sorry dass ich nochmal schreibe aber ich komme einfach nicht weiter.

Ich glaube das Hauptproblem ist, dass beim Aufruf von

Quote

/api/tickets.email

ein 404 zurückgegeben wird, was ja wiederum bedeutet dass die rewrite Regel nicht angewendet wird(?), die ja eigentlich auf http.php weiterleiten müsste.

Ich habe gecheckt ob mod_rewrite aktiviert ist (ja, ist es), die RewriteEngine wird ja eigentlich durch die htaccess aktiviert und nun weiß ich einfach nicht mehr woran es noch liegen könnte.

In meiner hilflosen Unwissenheit habe ich noch testweise  allow_url_fopen aktiviert, Vermutungen in Richtung php-fpm und/oder den Dateirechten angestellt (steht nun alles in dem api-Ordner auf 777 bis auf die htaccess) oder vermutet dass es an dem Unterschied POSTender Nutzer (33) zu empfangender-Webspace-Nutzer (über 10000) liegt. Zu Letzterem und php-fpm habe ich aber keine Änderungen durchgeführt weil ich auch nicht genau weiß wie bzw. ob das wirklich ein Problem sein kann.

Link to comment
Share on other sites

  • 0
Quote

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} (.*/api)

RewriteRule ^(.*)$ %1/http.php/$1 [L]

</IfModule>

Das Ticketsystem liegt im root Ordner von "customer". Der Aufruf der API wäre dann so http://customerurl.tld/api

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share




×
×
  • Create New...