Jump to content
Froxlor Forum
  • 0
tt33tt

Bug? cron-file benutzt php5

Question

Hallo alle zusammen,

meine Datei /bin/nano /etc/cron.d/froxlor enthält



# automatically generated cron-configuration by froxlor
# do not manually edit this file as it will be re-generated periodically.
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
#
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null
0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --used_tickets_reset 1> /dev/null
7 0 1 * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --ticketarchive 1> /dev/null
10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null
0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null
* * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null

Leider steht dort /usr/bin/php5 Es sollte heißen /usr/bin/php weil das immer auf die aktuellste PHP-Version bei mir verlinkt.

Wenn ich das dort ändere, wird das automatisch überschrieben.

Ich habe herausgefunden, dass ich in den Froxlor-Einstellungen das ändern kann.

Mein Vorschlag: Standardmäßig auf /usr/bin/php beim nächsten Froxlor-Update setzen oder zumindest auf die aktuellste php-Version setzen, die von Froxlor unterstützt wird.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Genau dafür ist das ja eine Einstellung. Und bis vor einiger Zeit war auf den meisten Distributionen nunmal php5 default und deswegen ist diese default-Einstellung so. Froxlor kann NIE für jedes System die perfekten und sofort funktionierenden default settings haben...alle systeme sind unterschiedlich. Gerne setze ich für die zukünftige Version den default auf /usr/bin/php 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...