Jump to content
Froxlor Forum
  • 0
funklaedle

Let's Encrypt error

Question

Hallo. ich bekomme leider irgendwie über lets encryt kein Certifikat zu stande. wenn ich den Cronjob von Hand mit Debug ausführe erhalte ich folgende Ausgae und Fehlermeldung:

 

[information] Updating Let's Encrypt certificates
[information] Updating xxxx.de
[information] Adding SAN entry: xxxx.de
[information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate
[information] letsencrypt Using existing account key
[information] letsencrypt Starting certificate generation process for domains
[information] letsencrypt Requesting challenge for xxxx.de
[information] letsencrypt Sending signed request to /acme/new-authz
[information] letsencrypt Got challenge token for xxxx.de
[information] letsencrypt Token for xxxx.de saved at /var/www/froxlor/.well-known/acme-challenge/UUnpyEOPLHtd_-MxNU5Jo......   and should be available at http://xxxx.de/.well-known/acme-challenge/UUnpyEOPLHtd_-MxNU5Jo.......
[error] Could not get Let's Encrypt certificate for xxxx.de: Curl error: couldn't connect to host
[information] Let's Encrypt certificates have been updated
[notice] Checking system's last guid

Ich bitte um Hilfe, komme nicht weiter, Gruß, Uwe

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Steht doch genau da, er kann nicht auf xxxx.de verbinden...wenn man die domain jetzt kennen würde, könnte ich die DNS Einträge prüfen etc. So, kann es alles sein

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, funklaedle said:

[error] Could not get Let's Encrypt certificate for xxxx.de: Curl error: couldn't connect to host

Aber da stehts halt...konnte nicht verbinden (lokal!) - ist die Domain vllt irgendwo in der /etc/hosts Datei eingetragen und zeigt woanders hin oder sowas?

Share this post


Link to post
Share on other sites
  • 0
46 minutes ago, d00p said:

Aber da stehts halt...konnte nicht verbinden (lokal!) - ist die Domain vllt irgendwo in der /etc/hosts Datei eingetragen und zeigt woanders hin oder sowas?

 

Share this post


Link to post
Share on other sites
  • 0

cat /etc/hosts
127.0.0.1 localhost

#127.0.0.1      localhost
#178.63.5.180   server103.103-webserver.de      server103

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

 

Share this post


Link to post
Share on other sites
  • 0

Mal manuell getestet ob der globale .well-known/acme-challenge alias funktioniert? Wobei wie gesagt, der Fehler ja eindeutig sagt, dass cURL nicht den Host erreichen konnte...mehr kann ich da nicht sagen

Share this post


Link to post
Share on other sites
  • 0

ja der alias funktioniert, ist über die Domain erreichbar. Kann ich ein Cert. von Hand einfügen solange ich dcen Fehler nicht finde damit ich https wenigstens verwenden kann auf dem Server ?

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, funklaedle said:

ja der alias funktioniert, ist über die Domain erreichbar. Kann ich ein Cert. von Hand einfügen solange ich dcen Fehler nicht finde damit ich https wenigstens verwenden kann auf dem Server ?

Ja, du kannst ein cert manuell erstellen bsp. über certbot und in froxlor bei den IP settings eintragen.
Wenn du dies aber machst, empfehle ich dir, deine ganzen urls in ein cert einzutragen.
bsp: certbot certonly --standalone -d deinedomain.xx,www.deinedomain.xx -d deinesubdomain.xx ... usw. bei subdomain das mit www einfach weglassen.

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, funklaedle said:

braucht froxlor noch einen port ausser 80 und 443 ?

 

 

Nein

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×