Jump to content
Froxlor Forum
  • 0

Rapid SSL installation Apache misconfig.


noaim90 ohne
 Share

Question

Hallo zusammen,

ich versuche für eine Domain ein Rapid SSL Zertifikat zu installieren, hierbei bin ich wie folgt vorgegangen, (siehe Einstellungen froxlor die Bilder)

Im Anschluss habe ich ergänzt:

nano /etc/apache2/conf-enabled/acme.conf
Alias "/.well-known/acme-challenge" "/var/www/html/froxlor/.well-known/acme-challenge"
<Directory "/var/www/html/froxlor/.well-known/acme-challenge">
Require all granted
</Directory>

Beim Neustart des Indianers
 

/etc/init.d/apache2 restart

 

erhalte ich nun folgende Ausgabe:

 

Jun 29 15:31:08 XXX apache2[14369]: Starting web server: apache2 failed!
Jun 29 15:31:08 XXX apache2[14369]: The apache2 configtest failed. ... (warning).
Jun 29 15:31:08 XXX apache2[14369]: Output of config test was:
Jun 29 15:31:08 XXX apache2[14369]: AH00526: Syntax error on line 1 of /etc/apache2/conf-enabled/acme.conf:
Jun 29 15:31:08 XXX apache2[14369]: Invalid command 'location', perhaps misspelled or defined by a module not included in the server configuration
Jun 29 15:31:08 XXX apache2[14369]: Action 'configtest' failed.
Jun 29 15:31:08 XXX apache2[14369]: The Apache error log may have more information.
Jun 29 15:31:08 XXX systemd[1]: apache2.service: control process exited, code=exited status=1
Jun 29 15:31:08 XXX systemd[1]: Failed to start LSB: Apache2 web server.

 

Wenn ich nun die acme.conf wieder lösche erhalte ich:


Jun 29 15:39:53 v22017112813055112 apache2[14460]: Starting web server: apache2 failed!
Jun 29 15:39:53 v22017112813055112 apache2[14460]: The apache2 configtest failed. ... (warning).
Jun 29 15:39:53 v22017112813055112 apache2[14460]: Output of config test was:
Jun 29 15:39:53 v22017112813055112 apache2[14460]: AH00526: Syntax error on line 5 of /etc/apache2/sites-enabled/03_froxlor_ocsp_cache.conf:
Jun 29 15:39:53 v22017112813055112 apache2[14460]: Invalid command 'SSLStaplingCache', perhaps misspelled or defined by a module not included in the server configuration
Jun 29 15:39:53 v22017112813055112 apache2[14460]: Action 'configtest' failed.
Jun 29 15:39:53 v22017112813055112 apache2[14460]: The Apache error log may have more information.
Jun 29 15:39:53 v22017112813055112 systemd[1]: apache2.service: control process exited, code=exited status=1
Jun 29 15:39:53 v22017112813055112 systemd[1]: Failed to start LSB: Apache2 web server.
Jun 29 15:39:53 v22017112813055112 systemd[1]: Unit apache2.service entered failed state.
 

 

Weder froxlor noch irgendeine Seite lässt sich nun mehr aufrufen, ein paar der Domains verlinken nun auf die 

Apache2 Debian Default Page oder zeigen 404 

 

Bin echt dankbar für eure Hilfe.

Gruß

 

froxlor_ssl3[1].jpg

froxlor_ssl4[1].jpg

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0
3 minutes ago, noaim90 ohne said:

Danke für die Antwort,

muss ich im ernst für jedes Zertifikat eine andere Configuration vornehmen?

Bei Plesk ging das so einfach ^^


Wie bekomme ich die Einstellungen nun Revidiert?

Was heißt andere Konfiguration. Du mußt bei jeder Domain halt das Zerttifikat, den entsprechenden Public-Key und evtl. Chain und SSL-CA hinterlegen wenn du NICHT Let's Encrypt Zertifikate anlegen willst.

Wenn Plesk toller ist dann nutze halt das ?

Du willst einen Server administrieren wenn du diese wenigen Einstellungen nicht revidiert bekommst? Echt jetzt?

Link to comment
Share on other sites

  • 0

Wenn ich revidiere erhalte ich immer die Ausgabe 
 

Zitat

SSLStaplingCache 

aus der config

Zitat

/etc/apache2/sites-enabled/03_froxlor_ocsp_cache.conf

habe ich dann die Zeile:

Zitat

SSLStaplingCache shmcb:/var/run/apache2/ocsp-stapling.cache(131072)

ausgeklammert krieg ich vom apache direkt den nächsten Error von Froxlor.

In Plesk hinterlegt man die CA und Key einfach zur Domain das wars, anders hab ichs noch nicht gemacht.

image.png.c2584b6b40c1ddc6a6f5171f834a29c5.png

 

Deswegen frage ich lieber, weil ich nicht Experimentieren will. 

 

 

Link to comment
Share on other sites

  • 0
2 hours ago, noaim90 ohne said:

Jun 29 15:31:08 XXX apache2[14369]: AH00526: Syntax error on line 1 of /etc/apache2/conf-enabled/acme.conf:
Jun 29 15:31:08 XXX apache2[14369]: Invalid command 'location', perhaps misspelled or defined by a module not included in the server configuration

das klingt für mich danach als wär in den Einstellungen "nginx" als webserver selektiert worden, woanders kommt keine direktive "location" vor...

 

Für das eintragen von Zertifikaten für Domains wechselst du ganz einfach zum entsprechenden Kunden, gehst in die Domainübersicht und klickst bei der entsprechenden Domain rechts aufs SSL-Icon (Schloss)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...