Jump to content
Froxlor Forum
  • 0
MGmeiner

postfix Konfiguration - Debian Jessie (8.x)

Question

 

Hallo.

Ich habe meinen Server soweit wie in den Configs beschrieben eingerichtet.
Wenn ich jetzt über eine Webseite, ein Kontaktformular versende kommt nichts an.

Auch über das Terminal erhalte ich keine Mails.

echo testing | mail -s foobar meine@mailadresse.com

/var/log/mail.log

Apr  9 15:18:43 v22018025830361712 postfix/master[25543]: reload -- version 2.11.3, configuration /etc/postfix
Apr  9 15:19:13 v22018025830361712 postfix/pickup[25982]: 69CD46040A: uid=10000 from=<MAIL@DOMAIN.com>
Apr  9 15:19:13 v22018025830361712 postfix/cleanup[25990]: 69CD46040A: message-id=<316cdfdd2d34482988c3cad2dea22d33@www.DOMAIN.com>
Apr  9 15:19:13 v22018025830361712 postfix/qmgr[25983]: 69CD46040A: from=<MAIL@DOMAIN.com>, size=715, nrcpt=1 (queue active)
Apr  9 15:19:13 v22018025830361712 dovecot: lda(MAIL@DOMAIN.com): msgid=<316cdfdd2d34482988c3cad2dea22d33@www.DOMAIN.com>: saved mail to INBOX
Apr  9 15:19:13 v22018025830361712 postfix/pipe[25994]: 69CD46040A: to=<MAIL@DOMAIN.com>, relay=dovecot, delay=0.08, delays=0.03/0.01/0/0.05, dsn=2.0.0, status=sent (delivered via dovecot service)
Apr  9 15:19:13 v22018025830361712 postfix/qmgr[25983]: 69CD46040A: removed

/var/log/mail.err 

Ist leer.

/var/customers/logs/KUNDE-error.log

Ist leer.

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

bisschen mehr info bitte, sendest du via smtp? unsere standard configerlaubt nur das senden wenn du eingeloggt bist. die zeilen die du da postest zeigen allerdings eine erfolgreiche zustellung an mail@domain.com

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, d00p said:

unsere standard config erlaubt nur das senden wenn du eingeloggt bist.

Dennoch solltest du irgendwas in einer log haben, wie gesagt, das was du ursprünglich gepostet hast lässt keinen fehler erkennen

Share this post


Link to post
Share on other sites
  • 0

Dann schaue ich nochmals genauer. Ja ich weiß in der Log sieht alles gut aus. Hast du eventuell noch einen Tipp wo ich nachsehen sollte?

Share this post


Link to post
Share on other sites
  • 0

Hallo,

ich kann dir nur empfehlen statt wp_mail folgendes Plugin zu verwenden: WP Mail SMTP.
Die meisten Mailserver blockieren inzwischen Mails die über die einfache PHP Mail-Funktion versendet werden.
In dem Plugin kannst du ganz einfach die Daten für einen SMTP-Server angeben und fertig. Macht viel weniger Probleme als die standard Mail-Funktion von WordPress.

Gruss cardman

Share this post


Link to post
Share on other sites
  • 0

cardman, danke für den Hinweis :) Das ist eine Lösung aber für mich wäre es noch interessant wo der Fehler liegt. 

Ich bekomme auch von apticron keine Mails über ServerUpdates.

Share this post


Link to post
Share on other sites
  • 0

Hallo,

ich kann mir vorstellen, das hier ein ähnliches Problem besteht, wie bei deinem WordPress.
Die Mails könnten vom Empfängerserver abgelehnt werden, weil dieser keine Mails ohne entsprechende Authorisierung beim sendenden Server akzeptiert.
Eventuell könnte es helfen die Absendeadresse, mit der Apticron sendet, auf Empfängerseite auf die Whitelist zu setzen.
Allernativ musst du mal schauen, ob du Apticron dazu bringen kannst sich vor dem senden von Mails ordnungsgemäß am SMTP-Server anzumelden.

Gruss cardman
 

Share this post


Link to post
Share on other sites
  • 0

Hallo das könnte ich noch versuchen, wollte nur ausschließen, dass ich etwas bei den Settings falsch gemacht habe :) Habe es auf einem anderen Server genau gleich und hier klappt es.
Dachte es sei etwas mit den Einstellungen, wenn ich über das Terminal keine Mail senden kann oder von Apticron keine durchkommen. 
Wo sollte den der Versand von Apticron gelogt werden? Oder wie kann ich am besten einen Mail Versand über das Terminal testen mit am besten wäre dann ein -trail damit ich genau verfolgen kann.

Share this post


Link to post
Share on other sites
  • 0

Hatte nochmals Zeit um mir die Log anzusehen. Denke es hat doch etwas mit dem eingeloggt Theme zu tun?

Am 9.4.2018 um 17:27 schrieb d00p:

unsere standard configerlaubt nur das senden wenn du eingeloggt bist.

Jul 10 11:14:44 v22018xxxxx postfix/smtpd[29566]: connect from unknown[103.100.0.000]
Jul 10 11:14:47 v22018xxxxx postfix/smtpd[29566]: warning: unknown[103.100.0.000]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Jul 10 11:14:47 v22018xxxxx postfix/smtpd[29566]: disconnect from unknown[103.100.0.0]
Jul 10 11:14:52 v22018xxxxx postfix/pickup[29106]: 06B3F60313: uid=10000 from=<my@mail.com>
Jul 10 11:14:52 v22018xxxxx postfix/cleanup[29578]: 06B3F60313: message-id=<20180710091452.06B3F60313@myserver.de>
Jul 10 11:14:52 v22018xxxxx postfix/qmgr[1129]: 06B3F60313: from=<my@mail.com>, size=425, nrcpt=1 (queue active)
Jul 10 11:14:52 v22018xxxxx dovecot: lda(my@mail.com): msgid=<20180710091452.06B3F60313@v22018025830361712.happysrv.de>: saved mail to INBOX
Jul 10 11:14:52 v22018xxxxx postfix/pipe[29582]: 06B3F60313: to=<my@myil.com>, relay=dovecot, delay=0.1, delays=0.07/0.01/0/0.03, dsn=2.0.0, status=sent (delivered via dovecot service)
Jul 10 11:14:52 v22018xxxxx postfix/qmgr[1129]: 06B3F60313: removed

Wie und wo wird das genau definiert? Oder welche Werte sollte ich kontrollieren?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×