Jump to content
Froxlor Forum
  • 0
Pagefreak

Nach FCGID installation Rechte für einzelne Verzichnisse nicht richtig

Question

Guten Tag,

da in Wordpress Installationen bisher das bearbeiten von Datein nicht möglich war, entschied ich mich FCGID zu installieren. Dies scheint soweit auch geklappt zu haben. Das Problem ist folgendes: Ich hatte Froxlor und ein paar andere Panel in ein Kundenverzeichnis verschoben. Damit diese dort ordnungsgemäß arbeiten konnten, hatte ich diesen die Gruppe www-data zugewiesen. Leider wird diesen nun nicht die eigentliche Gruppe zugewisen bzw. sie erhalten nach den Cron die Gruppe www-data zurück.

Kann mir da jemand weiterhelfen?

 

Vielen Dank im Voraus und einen schönen Tag
Pagefreak

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

Einstellungen -> Froxlor vhost Einstellungen -> 

Lokaler Benutzer für FCGID (Froxlor Vhost)

Lokale Gruppe für FCGID (Froxlor Vhost)

Share this post


Link to post
Share on other sites
  • 0

Froxlor ist nicht dazu gedacht in einem Kunden-Verzeichnis zu liegen...Bitte korrekt installieren wie hier beschrieben: https://github.com/Froxlor/Froxlor/wiki

Froxlor verwaltet sich selbst, d.h. es korrigiert auch seinen owner/group auf dateisystemebene, alles eine Sache der Einstellungen. Aber wie gesagt, Froxlor hat nix in einem Kundenverzeichnis eines anderen panels verloren, dafür ist es nicht gedacht

Share this post


Link to post
Share on other sites
  • 0
vor 13 Minuten schrieb d00p:

Froxlor ist nicht dazu gedacht in einem Kunden-Verzeichnis zu liegen...Bitte korrekt installieren wie hier beschrieben: https://github.com/Froxlor/Froxlor/wiki

Froxlor verwaltet sich selbst, d.h. es korrigiert auch seinen owner/group auf dateisystemebene, alles eine Sache der Einstellungen. Aber wie gesagt, Froxlor hat nix in einem Kundenverzeichnis eines anderen panels verloren, dafür ist es nicht gedacht

Froxlor ist nicht im Kundenverzeichnis eines anderen Panels. Froxlor liegt bei uns unter /var/customers/webs/User/froxlor.domain.de/. Das ganze dient nur der Subdomain für Froxlor. Funktionierte nun auch jahrelang ohne jegliche Probleme, nur in Kombination mit FCGID klappt es nicht mehr.

Share this post


Link to post
Share on other sites
  • 0

Naja, dann stimmen einfach deine Einstellungen nicht, setz halt den korrekten User für fcgid in den entsprechenden settings.

Share this post


Link to post
Share on other sites
  • 0
vor 16 Minuten schrieb d00p:

Naja, dann stimmen einfach deine Einstellungen nicht, setz halt den korrekten User für fcgid in den entsprechenden settings.

Welche sind die entsprechenden Settings? Konnte nichts entsprechendes finden.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×