Jump to content
Froxlor Forum
  • 0
fork

.htaccess: RewriteEngine On -> HTTP 500 Internal Server error

Question

Hi,

I'm quite new to froxlor. 

I did the following:

  1. I cloned & upgraded an existing server(Ubuntu 12.04 -> 16.04; Froxlor 0.93 -> 0.98.8)
  2. The webserver is starting correctly
  3. On all sites, where a "Rewrite Engine On" Directive is in the DocRoot, I get an HTTP 500 - Internal Server Error
  4. The fix would be to get a Line "AllowOverride FileInfo" into the root-directory directive of every  apache-vhost config
  5. As a workaround I put into SYSTEM/Settings/Webserver in default VHOST-Settings: 
  6. <Location />
    AllowOverride FileInfo
    </Location>

    ---

Well it works. But I'm sure that's not a good way to do it and I assume Rewriting should work right out of the box.

Any hints, how to do this in a better way?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

By default, apache 2.4 (which i assume 16,04 is using) does NOT allow execution of .htaccess at all (AllowOverride None !!!) - Froxlor whatsoever does generate corresponding entries in the customers vhosts (Require all granted + AllowOverride All). If you only get errors with people using rewrites, maybe mod_rewrite is not enabled?

Share this post


Link to post
Share on other sites
  • 0

Thanks for your answer d00p.

I made sure before mod_rewrite is enabled:

root@myserver:~# ls -tlra /etc/apache2/mods-enabled/*rewrite*
lrwxrwxrwx 1 root root 30 Mär  2  2012 /etc/apache2/mods-enabled/rewrite.load -> ../mods-available/rewrite.load

When I manually enter "AllowOverride FileInfo" in a generated vhost, and reload apache it works for this vhost. (and the directive is wiped away of course in the next configuration generation run.)

---

Yes. I'm using apache 2.4. I also selected config generation for apache 2.4 in the froxlor webserver settings.

Share this post


Link to post
Share on other sites
  • 0

As said, froxlor does generate corresponding entries, please nopaste the generated vhost of a domain where the rewrite is not working and/or try to see if there are any entries in apaches/customers error log regarding the 500 error

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By lively
      Hallo Forum :-)
      Versuche erfolglos eine .htaccess im Froxlor-Ordner {/var/www/froxlor] zu aktivieren.
      Meine IP wird auf https://froxlor.Domain.foo weitergeleitet.
      Habe eine .htaccess und .htpasswd in /var/www/froxlor angelegt, aber ohne Effekt. Was mache ich falsch?
      In Froxlor selbst kann ich den Pfad nicht schützen, da das Froxlor-Verzeichnis keinem "Kunden" zugeordnet ist.
      Bin für jeden Tipp dankbar.
      Gruß
      Lively
       
×
×
  • Create New...