Jump to content
Froxlor Forum
  • 0

Datenbank Problem


Question

hallo. habe probleme mit dem einspielen der datenbank . erhielt direkt nach dem eingeben der datenbank daten - obwohl vorher "ok" kam - ein fehler dass eine Tabelle fehlt . habe jetzt einfach mal testweise den alten froxlor-ordner hochgeladen , erhalte jetzt :

 

SQLSTATE[28000] [1045] Access denied for user 'froxlor'@'localhost' (using password: YES)

 

 

Was tun ? kann ich irgendwo das passwort ändern in froxlor das er für die DB nutzt ? komme ja nirgends hin ... zur not neu installieren - mit neuer datenbank - doch wie tu ich das ?

Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Was hast du denn da genau vor? In einem anderen Thread erzählst du was von neuer Installation, jetzt spielst du irgendeine alte Datenbank wieder ein...sorry, wenn du nur rumspielst und nicht weisst was du tust, bist du selbst schuld. Die Fehlermeldung sagt doch alles - das Passwort des froxlor-Datenbankbenutzers stimmt nicht.

  • Like 1
Link to post
Share on other sites
  • 0

die wiki nützt wir aber auch nix ... erstelle wie gehabt bei phpmyadmin einen user , name froxlor , mit datenbank , PW sagen wir mal 1234 , in der userdata.inc.php sieht es dann so aus :

 

<?php
//automatically generated userdata.inc.php for Froxlor
$sql['host']='127.0.0.1';
$sql['user']='froxlor';
$sql['password']='1234';
$sql['db']='froxlor';
$sql_root[0]['caption']='Default';
$sql_root[0]['host']='127.0.0.1';
$sql_root[0]['user']='root';
$sql_root[0]['password']='****';
?>

beim aufrufen von froxlor kommt dann immer:

 

A database error occurred

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'froxlor.panel_settings' doesn't exist

 
 
oder mache ich einen denkfehler ??
Link to post
Share on other sites
  • 0

also du weisst offensichtlich nicht wirklich was du tust bzw was du überhaupt erreichen willst. Entweder installierst du froxlor neu oder du migrierst eine vorherige Datenbank - bei deinen Fehlermeldungen und Problemen tippe ich auf Mischmasch der beiden, daher: sorry, werd dir erstmal klar was genau du willst, dann helfen wir gern weiter, aber nicht mit so einem Hickhack

Link to post
Share on other sites
  • 0

habe ich nun ^^ bin auch alle konfigurationen durch , webs Ordner und alles ist da . jetzt ist nur noch das problem , dass wenn ich auf meine Seite ich immer noch den inhalt von /var/www/ sehe - aber wieso ? :/

 

r5qa4XS.png

 

 

außerdem kann ich mich nicht in FTP anmelden :

 

NNYz9CP.png

Link to post
Share on other sites
  • 0

dann hast du etwas falsch gemacht. Prüfe doch einfach mal die erstellten vhost configs. Zwecks ftp: config prüfen, logs anschauen...komm schon, ein paar basics solltest du aber wissen als Serveradmin

Link to post
Share on other sites
  • 0
[Fri Sep 09 14:12:12.872116 2016] [authz_core:error] [pid 26900] [client 162.158.**.***:30338] AH01630: client denied by server configuration: /var/customers/webs/website/

aber warum ? und meinst du Punkt 4.1 in der wiki ? in der 000-default config habe ich es bereits zu /var/www/ anstatt /var/www/froxlor/ geändert. vhost config :

 

# 35_froxlor_normal_vhost_DOMAIN.de.conf
# Created 08.09.2016 23:05
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.


# Domain ID: 2 - CustomerID: 1 - CustomerLogin: website
<VirtualHost 178.***.***.**:80>
  ServerName DOMAIN.de
  ServerAlias *.DOMAIN.de
  ServerAdmin DOMAIN@gmail.com
  DocumentRoot "/var/customers/webs/website/"
  php_admin_value open_basedir "/var/customers/webs/website:/tmp"
  ErrorLog "/var/customers/logs/website-error.log"
  CustomLog "/var/customers/logs/website-access.log" combined
</VirtualHost>

 

nachdem ich nun noch den hostname geändert habe erhalte ich nun "forbidden" ...

 

 

EDIT: oh man , der Haken dass ich apache 2.4 nutze war nicht gesetzt ... jetzt gehts . habe eine 2. eingetragen aber da sehe ich jetzt "index of" und also alles in /var/www/ , doch wieso ? :/

Link to post
Share on other sites
  • 0

Sarius,

möchtest du dir den Server nicht lieber von einem professionellem Administrator einrichten lassen?
Klar kostet ein paar Euro's, aber die sind gut investiert.

Also ich würde meine Website & Mails nicht bei dir speichern.
Das System wird sicherlich offen wie ein Scheunentor sein, da es bei dir schon an sämtlichen Basics harpert.

Nimm das nicht persönlich, aber auf weitere Spambomben / Spamschleudern im WWW, da hat keiner Interesse dran.

 

Gruß
IAM

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...