Jump to content
Froxlor Forum
  • 0

Webserver-Interface: APACHE2HANDLER


Question

Hallo, nach einer Neuinstallation von froxlor über das deb Paket wird automatisch der APACHE2HANDLER im Dashboard angezeigt. 
Auch wenn ich nun FCGID aktiviere, bleibt es dabei. Die Konfiguration Einstellungen für FCGID habe ich gemacht.

 

Wie kann ich feststellen ob auch wirklich FCGID am laufen ist?

 

Besten Dank für Hilfe

Christian

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Ich hatte libapache2-mod-php auf dem System. Nach dem löschen zeigt er aber immer noch apache2handler an.
In  Einstellungen -> FCGID  habe ich noch  Verwende FCGID im Froxlor-Vhost aktiviert.

 

Froxlor läuft, aber php info zeigt  Apache2Handler 

 

Als Konfiguration habe ich das alles unter  Debian Jessie (8.x) »  Sonstige (System) »  FCGID (alternative to mod_php) gemacht.

 

Christian

Link to post
Share on other sites
  • 0

Hallo, ich habe mir die ganze Sache noch mal angeschaut und komme nicht drauf was da nicht passt.

 

Ich habe jetzt Froxlor noch mal als Source installiert und nicht aus den .deb Paket. Soweit läuft das ganze jetzt und ich hatte Zeitweise auch schon mal im Dashboard die FCGID Meldung. Aber nur kurzzeitig bis das nächste cron durchläuft und die Config Dateien wieder neu schreibt.

 

Kurz noch mal meine Aufgabenstellung:

Ich brauche 2 PHP Versionen die ich bestimmten Domain zuweisen kann (PHP 5.6 und 7). Das ganze läuft auf einem Debian 8.5 mit Apache2.4, MySQL 5.7 und Postfix mit Dovecot (managedsieve)

 

Also ich liege doch richtig wenn ich sage:

 

Ich brauche dazu Froxlor das auf apache mit fcgid läuft.

fcgid bedeutet das ich nur php_cgi installiere und nicht libapache2-mod-php?

Dann kann ich "Verwende FCGID im Froxlor-Vhost" aktivieren damit Froxlor auch über php_cgi abgearbeitet wird. Aber wenn ich das tue wird PHP nicht verarbeitet und ich sehe den html Quellcode beim aufrufen von Froxlor. Also funktioniert das mit FCGID nicht.

 

Sollte ich das ganze mit php-fpm machen? Kann ich damit auch PHP Versionen den Domains zuweisen?

 

Was mache ich da noch falsch?

Besten Dank für Hilfe und Tipps

 

Christian

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...