Jump to content
Froxlor Forum
  • 0
Afox

Froxlor & php7-fpm (Jessie)

Question

Hallo,

 

ich habe ein System mit Froxlor und php5 (FPM) und würde gerne auf php7 umsteigen. Soweit ich das bisher verstanden habe muss ich zu diesem Zweck php5 deinstallieren und php7 installieren.

 

Frage: was gibt es dabei zu beachten in Bezug auf Froxlor?  Im Webinterface hat FPM einen eigenen Einstellungspunkt in dem die Pfade angegeben werden können etc. Sollte ich die vor der Deinstallation ändern?

 

Kann ich mich bei der Installation an die Anleitung aus dem wiki halten?

 

Macht es überhaupt Sinn so zu verfahren oder wäre es besser alles neu aufzusetzen? Hat das zufällig schonmal jemand getestet?

 

Gibt es sonst noch etwas zu beachten?

 

Für jeden Tipp bin ich sehr dankbar.

 

Gruß,

 

Afox

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Cronjob ausmachen, Einstellungen anpassen, php7 installieren, Cronjob wieder an und/oder am besten manuell mit --force ausführen zum Neuerstellen der Configs. Fertig. Unsere demo unter demo.froxlor.org nutzt auch schon php7, funktioniert wunderbar.

Share this post


Link to post
Share on other sites
  • 0

ob du das deinstallierst oder nicht ist dir überlassen, wichtig ist ja am ende was "aktiv" ist (symlink /usr/bin/php oder so, je nach Distro).

 

Und für die globalen PEAR Verzeichnisse schauste einfach mal was da bei php7 standard ist, das hängt auch von der distro ab

Share this post


Link to post
Share on other sites
  • 0

hm. ok, also im Dashboard steht zwar immernoch die alte Version aber in meiner Software die ich als Kunde betreibe ist schon php7 eingetragen. Gibt aber noch ein paar Fehler. vllt. hab ich was falsch gemacht.

 

Folgende Dinge habe ich installiert:

apt-get install php7.0-fpm php7.0-mysql php7.0-json php7.0-gd libapache2-mod-php7.0

Vielleicht fehlt da etwas? benötigt man curl?
 

Share this post


Link to post
Share on other sites
  • 0

jetzt läuft zumindest die Kunden-Software. Aber im Dashboard steht weiterhin die alte Version. Wie bringe ich Froxlor bei einen php7 socket zu verwenden?

 

fehlt da nicht eine Einstellungsmöglichkeit in der Weboberfläche?

Share this post


Link to post
Share on other sites
  • 0

hi, sorry für tripple-Antwort aber habe es noch nicht hinbekommen dass Froxlor selbst auf einen php7-FPM-Socket hört :(

Share this post


Link to post
Share on other sites
  • 0

Dann lösch doch mal alle pool-configs aus dem fpm-php5 ordner (außer die www.conf, das ist die default) und stoppe den 5er fpm-dienst. Dann starte den Cronjob nochmal manuell:

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Und dann sehen wir mal weiter :)

Share this post


Link to post
Share on other sites
  • 0

hi, danke für Deine Mühen. Der FPM-Socket steht ja auch in den Apache-configs von Froxlor. Beim Durchführen des Cronjobs wird keine neue config für die Froxlor Sockets angelegt.

 

Ich lasse es glaube ich einfach so. Ist vielleicht auch noch ein bisschen sicherer wenn man zwei unterschiedliche FPM-Manager für Kunde und Froxlor hat?!

Share this post


Link to post
Share on other sites
  • 0

was das mit sicherer zu tun haben soll....naja, wenn es für dich so passt...

Share this post


Link to post
Share on other sites
  • 0

hallo, ich habe es jetzt hinbekommen, dass auch im Froxlor das 7er PHP-FPM angezeigt wird. Allerdings habe ich ein Problem, bei dem ich nicht mehr weiter weiß. Und zwar kann ich den Punkt "Konfigurationen" nicht mehr aufrufen, es kommt nur eine weiße Seite.

 

was ich gemacht habe: eigene Froxlor-apache-config angelegt, die auf den Froxlor Ordner zeigt. Soweit so gut. Es stand "ApacheHandler".

Nach der Installation und Einrichtung von PHP7.0-FPM für die Kunden (Änderung auf PHP7-Parameter) hakte ich "Verwende PHP-FPM im Froxlor-Vhost" an und fügte folgenden Schnipsel zu der Frolxor-apache-config hinzu:

    <IfModule mod_proxy_fcgi.c>
        <Directory "/var/www/froxlor/">
	    <FilesMatch \.php$>
		SetHandler proxy:unix:/Pfad/zu.socket|fcgi://localhost
            </FilesMatch>
	    Require all granted
        </Directory>
    </IfModule>

Das führte dazu dass im Froxlor PHP 7.0 angezeigt wurde.

 

Nur jetzt weiß ich nicht mehr weiter und hoffe ggf. auf einen Hinweis/eine Hilfestellung. Ansonsten muss ich es wieder rückgängig machen, zumindest für Froxlor. Mich interessiert auch woran es liegt/hängt.

 

Gruß,

 

Afox

Share this post


Link to post
Share on other sites
  • 0

Wieso legst du denn nen eigenen vhost an, lass doch froxlor den vhost für sich selbst erstellen. Php7 auch im Panel funktioniert super bei mehreren Installationen bei mir.

 

Ansonsten: Weiße Seite -> php fehler, schau in die error log

Share this post


Link to post
Share on other sites
  • 0

arg, danke für den Hinweis mit dem error.log. Es fehlte die xml-Erweiterung -_-

 

bezüglich vhost konnte ich bisher keine Einstellung dafür finden. Standardmäßig wurde bei mir nichts angelegt, nur für den Kunden, nicht aber für Froxlor selbst, also den Host.

 

Wenn du einen Tipp hast wo ich das einstellen kann, gerne :)

 

Hatte auch eine eigene config angelegt weil ich SSL-Verschlüsselung haben wollte. weiß nicht ob das über den vhost geht...

 

Gruß,

 

Afox

Share this post


Link to post
Share on other sites
  • 0

Einstellen kannst du das natürlich in den Einstellungen..."froxlor direkt über den Hostname erreichbar machen" oder so

Share this post


Link to post
Share on other sites
  • 0

hi, das ist bei mir angehakt. Aber die Dateien verraten nichts über einen eigenen vhost für den host, z.B. die "ipandport"-Dateien sind komplett leer. kA ob das evtl. ein Bug ist oder ich einfach nur blind bin. danke trotzdem für deine Hilfe!

 

Edit: ich sehe gerade dass man unter der IP selbst noch einen vhost erstellen lassen kann. ich probiere :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...