Skip to content
View in the app

A better way to browse. Learn more.

Froxlor Forum

A full-screen app on your home screen with push notifications, badges and more.

To install this app on iOS and iPadOS
  1. Tap the Share icon in Safari
  2. Scroll the menu and tap Add to Home Screen.
  3. Tap Add in the top-right corner.
To install this app on Android
  1. Tap the 3-dot menu (⋮) in the top-right corner of the browser.
  2. Tap Add to Home screen or Install app.
  3. Confirm by tapping Install.

HELP: 500 Internal server error

Featured Replies

Hey guys,

 

i got a huge problem with a single user. After cron tasks I often got a 500 Internal Server Error

to all domain poining to a user directory. I use php5-fpm.

 

The logs say:

[Mon Jun 22 16:03:34 2015] [error] [client 137.224.252.19] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external"
[Mon Jun 22 16:03:57 2015] [error] [client 77.3.79.65] (13)Permission denied: FastCGI: failed to connect to server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external": connect() failed
[Mon Jun 22 16:04:00 2015] [error] [client 77.3.79.65] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external"
[Mon Jun 22 16:04:03 2015] [error] [client 146.60.197.9] (13)Permission denied: FastCGI: failed to connect to server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external": connect() failed
[Mon Jun 22 16:04:03 2015] [error] [client 146.60.197.9] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external"
[Mon Jun 22 16:04:06 2015] [error] [client 137.224.252.19] (13)Permission denied: FastCGI: failed to connect to server "/var/www/php-fpm/fullname/nilsbussmann.de/ssl-fpm.external": connect() failed

But the user fullname should have access to /var/www/php-fpm/fullname/*

la /var/www/php-fpm/fullname/
insgesamt 16K
drwxr-xr-x  4 root     root     4,0K Jun 22 15:35 .
drwxr-xr-x 10 root     root     4,0K Jun 22 15:35 ..
drwxr-xr-x  2 fullname fullname 4,0K Jun 22 15:35 fullname.h**3528.stratoserver.net
drwxr-xr-x  2 fullname fullname 4,0K Jun 22 15:35 nilsbussmann.de

I can fix the problem by give choown the complete folder to the user. 

chown fullname:fullname -R /var/www/php-fpm/fullname/
service nscd restart 
service apache2 restart

But this is a dirty workaround. Though i have to fix i manually evertime ...

 

Can anyone help me width this problem? That would be awesome! 

Cheers Nils 

Normally, our cronjob sets correct permissions...be sure you have the correct users entered in the froxlor settings and that libnss-mysql is set up correctly and working

Archived

This topic is now archived and is closed to further replies.

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.