Jump to content
Froxlor Forum
  • 0
Sign in to follow this  
laser

Verzeichnisschutz geht nicht

Question

Hi,

 

hat jemand von euch auch Probleme mit dem Verzeichnisschutz unter Debian Jessie?

Froxlor scheint alles korrekt anzulegen. 

 

/etc/apache2/sites-enabled

# 40_froxlor_diroption_2e27956a4beddf27e277fab3330a49df.conf
# Created 15.06.2015 10:40
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<Directory "/var/customers/webs/stromfresser/admin/">
  AuthType Basic
  AuthName "Admin"
  AuthUserFile /etc/apache2/htpasswd/1-2e27956a4beddf27e277fab3330a49df.htpasswd
  require valid-user
</Directory>

Das kuriose ist, das der Webalizer-Schutz funktioniert:

# 40_froxlor_diroption_c0ae1d0652a952211ad84a7435865d53.conf
# Created 15.06.2015 10:40
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<Directory "/var/customers/webs/stromfresser/webalizer/">
  AuthType Basic
  AuthName "Restricted Area"
  AuthUserFile /etc/apache2/htpasswd/1-c0ae1d0652a952211ad84a7435865d53.htpasswd
  require valid-user
</Directory>

Hat jemand irgend eine Idee woran das liegen k?nnte?

 

Apache l?uft 2.4.10, Froxlor ist entsprechend konfiguriert.

PHP Version 5.6.9-0+deb8u1

 

Danke!

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hast du eine Domain/Subdomain auf /var/customers/webs/stromfresser/admin/ gelegt?

 

Kannst du ggf. mal die vHost davon Posten?

Share this post


Link to post
Share on other sites
  • 0

Jo hab ich ... du meinst das dieser vHost priorisiert wird ... ich glaube ich hatte schon mal so ein ?hnliches Problem ... peinlich.

<VirtualHost xy:80>
  ServerName sub.domain.de
  ServerAlias *.sub.domain.de
  ServerAdmin info@asddssa.dasd
  DocumentRoot "/var/customers/webs/stromfresser/admin/"
  FcgidIdleTimeout 30
  SuexecUserGroup "stromfresser" "stromfresser"
  <Directory "/var/customers/webs/stromfresser/admin/">
    <FilesMatch "\.(php)$">
      SetHandler fcgid-script
      FcgidWrapper /var/www/php-fcgi-scripts/stromfresser/be.stromfresser.info/php-fcgi-starter .php
      Options +ExecCGI
    </FilesMatch>
    Require all granted
  </Directory>
  Alias /webalizer "/var/customers/webs/stromfresser/webalizer"
  ErrorLog "/var/customers/logs/stromfresser-error.log"
  CustomLog "/var/customers/logs/stromfresser-access.log" combined
</VirtualHost>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By stolly82
      Hallo zusammen, 
      ich bin immer sehr aktiv in Fehler selber lösen, aber aktuell bin ich an einem Punkt angekommen wo ich mittlerweile wirklich alle Beiträge im gesamten WorldWideWeb durchsucht habe und einfach nicht weiter komme :-( 
       
      Ich habe einen Debaian Jessie Server mit ein paar Kunde & Froxlor seit Jahren aktiv am laufen.
      Durch php7 und der Inkompatibilität einiger älterer Anwendungen benötige ich leider FCGID um auf einigen domänen noch die 5.x Version laufen zu lassen.
      Bei der Installation (mittlerweile nach knappen 15 Stunden mit google und Versuchen) scheitert es bereits an dem Punkt in der Anleitung:

       
      Das hatte ich vorher total übersehen, dass der Server dort anstatt 10001 etc. den Usernamen finde sollte. Demnach hatte ich bei der Installation weiter gemacht und bin immer bei dem Punkt hängen geblieben wo ich diese wunderschöne Fehlermeldung AH00543: apache2: bad user name **** bekommen habe.
      Ich habe bei Froxlor mittlerweile wirklich alle configs neu / plane aufgespielt und nscd will einfach die User nicht den ID´s zuordnen. 
      Was habe ich gemacht:

      Bei der Installation gibt es für mich auch keine erkennbaren Fehler. 
      Ich habe die MySQL Passwörter die ich bei Froxlor in die Config eingegeben habe selbstverständlich auch geprüft und testweise auch den root user / pw genommen. 
      Ebenfalls habe ich die Anleitung von hier genommen:
      https://github.com/Froxlor/Froxlor/wiki/apache2-with-fcgid
      Dort stimmte allerdings der Punkt mit dem 
      apt-get install libnss-mysql nicht mehr, da es mittlerweile libnss-mysql-bg ist. Demnach passten da auch die obersten beiden Config files nicht mehr.
       
      /etc/nss-mysql-root.conf /etc/nss-mysql.conf /etc/nsswitch.conf
       
      Hier mal das LOG File vom nscd.
       
      Vielleicht hat ja einer von euch eine Idee was das Problem sein könnte. 
       
      Danke und LG
       
      Jan 
       
      DAS WAR BEIM ERSTEM PLANE START: Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/passwd for database passwd Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/hosts for database hosts Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/resolv.conf for database hosts Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/services for database services Fri 19 Jan 2018 06:51:51 PM CET - 17748: register trace file /etc/netgroup for database netgroup Fri 19 Jan 2018 06:51:51 PM CET - 17748: cannot stat() file `/etc/netgroup': No such file or directory Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17749 Fri 19 Jan 2018 06:51:51 PM CET - 17748: INVALIDATE (passwd) Fri 19 Jan 2018 06:51:51 PM CET - 17748: pruning passwd cache; time 9223372036854775807 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "0", timeout 1516384654 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "nobody", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "root", timeout 1516384654 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "vmail", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "65534", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "postfix", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "115", timeout 1516384745 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "2000", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYUID entry "116", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETPWBYNAME entry "debian-spamd", timeout 1516384746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "0" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "nobody" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "root" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "vmail" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "65534" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "postfix" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "115" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "2000" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYUID entry "116" Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETPWBYNAME entry "debian-spamd" Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17758 Fri 19 Jan 2018 06:51:51 PM CET - 17748: INVALIDATE (group) Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17759 Fri 19 Jan 2018 06:51:51 PM CET - 17748: handle_request: request received (Version = 2) from PID 17759 Fri 19 Jan 2018 06:51:51 PM CET - 17748: INVALIDATE (hosts) Fri 19 Jan 2018 06:51:51 PM CET - 17748: pruning hosts cache; time 9223372036854775807 Fri 19 Jan 2018 06:51:51 PM CET - 17748: considering GETHOSTBYADDR entry "127.0.0.1", timeout 1516387746 Fri 19 Jan 2018 06:51:51 PM CET - 17748: remove GETHOSTBYADDR entry "127.0.0.1" Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17778 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETFDGR Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17778 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETGRBYNAME (vmail) Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17779 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETFDGR Fri 19 Jan 2018 06:51:52 PM CET - 17748: handle_request: request received (Version = 2) from PID 17779 Fri 19 Jan 2018 06:51:52 PM CET - 17748: GETGRBYNAME (vmail) Fri 19 Jan 2018 06:51:53 PM CET - 17748: handle_request: request received (Version = 2) from PID 17780 Fri 19 Jan 2018 06:51:53 PM CET - 17748: GETFDGR Fri 19 Jan 2018 06:51:53 PM CET - 17748: handle_request: request received (Version = 2) from PID 17780 Fri 19 Jan 2018 06:51:53 PM CET - 17748: GETGRBYNAME (vmail) Fri 19 Jan 2018 06:51:53 PM CET - 17748: handle_request: request received (Version = 2) from PID 17781 Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (1) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "1" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "1" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "daemon" of type GETPWBYNAME for passwd to cache Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (102) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "102" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "102" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "messagebus" of type GETPWBYNAME for passwd to cache Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (115) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "115" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "115" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "postfix" of type GETPWBYNAME for passwd to cache Fri 19 Jan 2018 06:51:57 PM CET - 17748: handle_request: request received (Version = 2) from PID 17793 Fri 19 Jan 2018 06:51:57 PM CET - 17748: GETPWBYUID (2000) Fri 19 Jan 2018 06:51:57 PM CET - 17748: Haven't found "2000" in password cache! Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "2000" of type GETPWBYUID for passwd to cache (first) Fri 19 Jan 2018 06:51:57 PM CET - 17748: add new entry "vmail" of type GETPWBYNAME for passwd to cache MITTLERWEILE BEKOMME ICH NUR NOCH DAS HIER: Fri 19 Jan 2018 07:47:02 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:02 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:02 PM CET - 31374: handle_request: request received (Version = 2) from PID 31496 Fri 19 Jan 2018 07:47:02 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:02 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:03 PM CET - 31374: handle_request: request received (Version = 2) from PID 31497 Fri 19 Jan 2018 07:47:03 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:03 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:03 PM CET - 31374: handle_request: request received (Version = 2) from PID 31498 Fri 19 Jan 2018 07:47:03 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:03 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:04 PM CET - 31374: handle_request: request received (Version = 2) from PID 31499 Fri 19 Jan 2018 07:47:04 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:04 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:04 PM CET - 31374: handle_request: request received (Version = 2) from PID 31500 Fri 19 Jan 2018 07:47:04 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:04 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:05 PM CET - 31374: handle_request: request received (Version = 2) from PID 31501 Fri 19 Jan 2018 07:47:05 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:05 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:05 PM CET - 31374: handle_request: request received (Version = 2) from PID 31502 Fri 19 Jan 2018 07:47:05 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:05 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:06 PM CET - 31374: handle_request: request received (Version = 2) from PID 31503 Fri 19 Jan 2018 07:47:06 PM CET - 31374: GETFDGR Fri 19 Jan 2018 07:47:06 PM CET - 31374: provide access to FD 8, for group Fri 19 Jan 2018 07:47:06 PM CET - 31374: handle_request: request received (Version = 2) from PID 31504 Fri 19 Jan 2018 07:47:06 PM CET - 31374: GETFDGR  
    • By nurtext
      Moin,
      anscheinend schlägt Let's Encrypt bei Subdomains fehl, weil es gerne auch eine weitere "www"-Subdomain an die bestehende hängen würde. Siehe Log:
      root@meine-tolle-domain:/root# /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating hilfe.meine-tolle-domain.de [information] Adding SAN entry: hilfe.meine-tolle-domain.de [information] Adding SAN entry: www.hilfe.meine-tolle-domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Creating new account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf [information] letsencrypt Sending signed request to /acme/reg/18369331 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for hilfe.meine-tolle-domain.de [information] letsencrypt Token for hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY and should be available at http://hilfe.meine-tolle-domain.de/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/ZXmZ4SU2Oy0__ipk-ihaPtDq39OyNfBKAEHzfMvmO5U/1478709781 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.hilfe.meine-tolle-domain.de [information] letsencrypt Token for www.hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE and should be available at http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE [error] letsencrypt Please check http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA/1478709934 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for hilfe.meine-tolle-domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"www.hilfe.meine-tolle-domain.de"},"status":"invalid","expires":"2017-07-11T15:20:54Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:connection","detail":"DNS problem: NXDOMAIN looking up A for www.hilfe.meine-tolle-domain.de","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709934","token":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","keyAuthorization":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE.lzkNGm6yCkkELPqgqQ8h9v-MfPi-5gRkb9yf76fy86s","validationRecord":[{"url":"http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","hostname":"www.hilfe.meine-tolle-domain.de","port":"80","addressesResolved":[],"addressUsed":"","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709935","token":"S1kgT_jIG8reMxRvGEf9niDf4WIiPyr5XslKbIFQ6eY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709936","token":"mp8J-ChoyV2gMPQyuJQoZaRlH2ePfcBYcb0v-cZ1zmU"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@meine-tolle-domain:/root/ Irgendwie sieht das für mich nicht gewollt aus, oder? ?
    • By MGmeiner
      Hallo.
      Ich habe gerade gesehen, dass es hier das Forum auch in Deutsch gibt
      Habe die Frage zwar im englischen schon gestellt, aber in Deutsch wär mi das ganze doch lieber  (Admin du kannst gerne meine Post im EN Forum löschen).
      Ich habe seit dem Update auf Debian 8 das Problem, dass ich einen 404 Error erhalte.
      Ich habe (wie in Froxlor beschrieben) die acme.conf erstellt und den Dienst "apache2" neugestartet.

      Weiters habe ich auch noch 
      Could not get Let's Encrypt certificate for cloudservice.DOMAIN.com: Verification ended with error: {"identifier":{"type":"dns","value":"cloudservice.DOMAIN.com"},"status":"invalid","expires":"2017-06-07T20:05:14Z","challenges":[{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196287","token":"IRK9FHJuWGV9l3qnCnoHuh7XGudY4bWd5Sx1JerSkSU"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196288","token":"ufnSkvFtYYIXOWhqBGuv1QZF_iaOkrZ5USKYE0U52QM"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8: \"<html>\r\n<head><title>404 Not Found<\/title><\/head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404 Not Found<\/h1><\/center>\r\n<hr><center>\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196289","token":"KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8","keyAuthorization":"KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8.smiCkvGETnwE6QlOocMBuKikIIKHHcPhTBjXZgHYBt4","validationRecord":[{"url":"http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8","hostname":"cloudservice.DOMAIN.com","port":"80","addressesResolved":["188.68.55.173","2001:1a50:11:0:5f:8f:acfa:7c"],"addressUsed":"2001:1a50:11:0:5f:8f:acfa:7c","addressesTried":[]}]}],"combinations":[[2],[0],[1]]} nano /etc/apache2/conf-enabled/acme.conf Alias "/.well-known/acme-challenge" "/var/www/froxlor/.well-known/acme-challenge" <Directory "/var/www/froxlor/.well-known/acme-challenge"> Require all granted </Directory> Weiters habe ich mir dann noch gedacht ich checke die apache Einstellungen die Floxlor angeben hat.
      mkdir -p /etc/apache2/sites-enabled/ chown root:0 /etc/apache2/sites-enabled/ chmod 0600 /etc/apache2/sites-enabled/ mkdir -p /etc/apache2/sites-enabled/ chown root:0 /etc/apache2/sites-enabled/ chmod 0600 /etc/apache2/sites-enabled/ mkdir -p /var/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp a2dismod userdir a2enmod headers apt-get install libapache2-mod-fastcgi Ich habe alles außer mkdir nochmals durchgeführt. Da die Folder sind ja schon vorhanden.
      Kann ich sonst noch irgendwo was einstellen oder kontrollieren?
       




      Liebe Grüße
      Matthias
       
    • By hoschi
      Die  libnss-mysql-bg liefert für den Fall, das der mysqld nicht antwortet, einen segfault statt eines "keine Antwort". Im Ergbnis killt das die ssh bzw. loginshell, sobald die lib angesprochen wird. Auch ein root login ist nicht mehr stabil möglich :-(
       
      So ausprobiert mit jessie, mysql-5.6 aus jessie-backports und libnss-mysql-bg_1.5-3+frx1 auf amd64 mit sysv-init. Der mysqld blieb nach Neustart hängen wegen zu vielen geöffneten Dateien durch viele Datenbanken (fix in /etc/security/limits.conf), daraufhin war kein login für shadow-accounts über die Konsole oder ssh mehr möglich, oder wenn der login erfolgreich ist wird die shell nach kurzer Zeit gekillt.
       
      Läuft bzw. startet der mysqld scheint alles in Ordnung zu sein, bei Abschaltung geht es wegen nscd noch etwas weiter.
       
      Siehe https://packages.qa.debian.org/libn/libnss-mysql-bg.html, der Bug ist wohl bei ubuntu gefixt worden:
      https://bugs.launchpad.net/ubuntu/+source/libnss-mysql-bg/+bug/727192
       
      Einen Maintainer gibts bei Debian seid 3 Jahren nicht mehr, deswegen ist das wohl aus jessie rausgeflogen (keiner hat die bugs gefixt). In der aktuellen Testing ist die lib als 1.5-4 drin, es wurde aber nur der Maintainer auf die QA gesetzt, das Paket entspricht der 1.5-3.
       
      Will und könnte jemand aus dem Froxlor Team nicht Maintainer für das Paket in Debian machen? Oder die lib rauswerfen und die Kunden in Froxlor per shadow-account anlegen (email/htaccess/ftp usw. gehen ja direkt auf die DB, ohne die lib)? Mir mangelt es leider an dem nötigen Wissen in C.
      Im Moment kann ich nicht empfehlen Froxlor mit der lib unter Debian 8 Jessie einzusetzen, das kann böse ausgehen :-(
       
    • By Gamerboy59
      Hello,
      I wanted to use froxlor with PHP7-FPM but there seem to be some problems. The first is froxlor doesn't generate a user for itself (in sides-enabled config) though checking the box in config-menu. Additionally, there's still a php5 flag in the generated apache2 sites-enabled file in this line:

      AddHandler php5-fastcgi .php Action php5-fastcgi /fastcgiphp Maybe you can correct it and help me getting it work with fpm. I tried to used fcgid instead and the thing with the user is working fine.
×
×
  • Create New...