Jump to content
Froxlor Forum
  • 0

Admin-Passwort nach Update ung?ltig


creo

Question

Guten Abend,

 

seit dem letzten Update heute funktioniert mein Admin-Passwort nicht mehr.

 

W?hrend des Update-Vorgangs wurde die Integrit?t einiger Tabellen bem?ngelt, was ich auf einen Server-Absturz meines VPS-Anbieters zur?ckf?hre. Dieser riss auch mein System in den Abgrund.

 

Im Changelog lese ich, dass zugleich an der Passwort-Funktion von Froxlor gearbeitet wurde:

+ #1289: use password-hash from froxlor-settings for admin/customer accounts

http://forum.froxlor.org/index.php/topic/12887-release-0933-enhanced-powers/

 

Bei mir scheint etwas schiefgegangen zu sein.

 

Ich habe jedenfalls Zugriff auf die Datenbank und k?nnte nun den Passwort-Hash des Admins ersetzen, aber wie erzeuge ich einen f?r Froxlor akzeptablen Hash? 

 

Vielen Dank f?r Unterst?tzung!

 

creo

 

Edit: Die "Passwort vergessen"-Funktion klappt leider auch nicht. Bei mir kommt die Fehlermeldung: "Das Zur?cksetzen des Passworts ist deaktiviert."

Wo kann man diese Funktion in der Datenbank vor?bergehend aktivieren? Das w?rde ja auch schon helfen, denke ich.

Link to post
Share on other sites

8 answers to this question

Recommended Posts

Allen voran: dein Server Absturz hat absolut gar nichts mit unserem Integrit?ts-Check zu tun, es werden lediglich INTERNE Abh?ngigkeiten gepr?ft, wie z.b. die Verkn?pfungen zwischen Domains und IP/Ports. 

 

Hast du dich nach dem Update ausgeloggt und dann wieder eingeloggt und das ging dann nicht?

 

Aktualisieren kannst du das Passwort wie folgt:

UPDATE `panel_admins` SET `password`= MD5('mein password') WHERE `loginname` = 'admin';

Das speichert ein MD5-gehashtes Passwort. Froxlor sollte dann nach dem ersten erfolgreichen Login auf den von dir angegebenen Hash aktualisieren (so wie eigentlich beim Update)

Link to post
Share on other sites

Hallo d00p!

 

Dein Tipp hat funktioniert. Vielen Dank!

 

Der Hash, der in der Datenbank stand, als ich mich nicht einloggen konnte, war kein MD5-Hash... Er bestand aus 50 Zeichen inkl. Sonderzeichen wie z. B. $ und .

 

Nach dem Wiedereinstellen meines Passworts mit der MD5-Funktion und dem Einloggen, ?nderte Froxlor den MD5-String zu einem neuen String mit 106 Zeichen.

 

Beide Hashes begannen mit $6, was CRYPT_SHA512 repr?sentieren soll, oder?

http://php.net/manual/de/function.crypt.php

 

Aber der erste Hash nach dem Update war eben viel k?rzer als der jetzige.

Link to post
Share on other sites

Ja die ge-hash-ten Passw?rter bestehen aus $id$salt$hash. Und ja, nach erfolgreichem Login aktualisiert Froxlor dein md5 Passwort (wenn noch eins genutzt wird) in ein Passwort mit dem gew?hlten Hash.

 

Und wenn deine Einstellung SHA512 ist, dann ja, $6$... sind SHA512 passw?rter. Froxlor-default w?re SHA256, das hast du wohl angepasst. SHA256 w?re ?brigens nat?rlich auch k?rzer als SHA512

Link to post
Share on other sites

War mir nicht bewusst, dass ich das aktiv irgendwo umgestellt habe. Es kann nat?rlich sein, aber ich habe es dann vielleicht vergessen.

 

Jedenfalls hast Du mir den Abend gerettet. :-) Tausend Dank.

 

Nochmals kurz zu meinem "Edit" aus #1... Kann man die Passwort-Wiederherstellung ?ber die Datenbank steuern? Ist da ein Flag, welches ich nicht gefunden habe?

Link to post
Share on other sites

Ich kann das Problem best?tigen. Nach Update von .32 auf .33 ging auch mein Admin-Kennwort nichtmehr. Leider hab ich keine Anhaltspunkte wieso das genau passiert sein k?nnte zumal es bei mir ein paar seltsamere Umst?nde zu der Zeit gab ;-) M?ssen das mal weiter beobachten

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...