Jump to content
Froxlor Forum
  • 0

Froxlor leitet nicht auf Kundendomain


Pagefreak

Question

Hallo liebe Froxloraner,

 

ich habe leider das Problem, dass ich wenn ich auf meine Domain (BenderNetwork.de) gehe automatisch auf www.BenderNetwork.de weitergeleitet werde. An sich habe ich da nichts gegen, doch die Subdomain www. leitet auch auf den Server weshalb ich imm WWW Verzeichnis von Apache lande. Btw. den Alis f?r die Domain hatte ich auf "Kein Alias" gestellt. K?nnt ihr mir helfen?

 

LG Jakob

Link to comment
Share on other sites

24 answers to this question

Recommended Posts

Pr?fe, ob du nicht vllt einen redirect in deinem Docroot hast, sei es via .htaccess oder PHP o.?.

 

Wenn du in Froxlor den Domain-Alias auf "Kein Alias" stellst, dann greift der Vhost auch wirklich nur f?r "BenderNetwork.de" und nicht f?r "*.BenderNetwork.de" btw. "www.BenderNetwork.de"...das ist ja Sinn der Sache.

Link to comment
Share on other sites

Pr?fe, ob du nicht vllt einen redirect in deinem Docroot hast, sei es via .htaccess oder PHP o.?.

 

Wenn du in Froxlor den Domain-Alias auf "Kein Alias" stellst, dann greift der Vhost auch wirklich nur f?r "BenderNetwork.de" und nicht f?r "*.BenderNetwork.de" btw. "www.BenderNetwork.de"...das ist ja Sinn der Sache.

Ich habe mal nachgeguckt, es ist nirgends ein Redirect drin! Und wenn ich es ?ber einen Proxy schaffe auf nur BenderNetwork.de zu kommen dann habe ich ganz normal meine Seite, so wie es sein soll!

Link to comment
Share on other sites

Scheint alles zu passen.

 

?brigens: ich werde nicht von bendernetwork.de auf www.bendernetwork.de geleitet, muss was bei dir kaputt sein.

 

 

Moin,

 

tatsache! Einmal Cache gecleart und ich sehe die Seite! :D Doch wie bekomme ich es jetz hin, dass ich auch unter www.BenderNetwork.de auf die Seite komme?

 

LG Jakob

Link to comment
Share on other sites

Wenn du in Froxlor den Domain-Alias auf "Kein Alias" stellst, dann greift der Vhost auch wirklich nur f?r "BenderNetwork.de" und nicht f?r "*.BenderNetwork.de" btw. "www.BenderNetwork.de"...das ist ja Sinn der Sache.

 

Stell die Domain auf "Wildcard-Alias (*)"

Link to comment
Share on other sites

Hier ist mal der Inhalt aus der 22_froxlor_normal_vhost_BenderNetwork.de.conf :

<VirtualHost 89.163.227.23:80>
  ServerName BenderNetwork.de
  ServerAlias *.BenderNetwork.de
  ServerAlias www.BenderNetwork.de
  ServerAlias *.BenderNetwork.de *.*.BenderNetwork.de
  ServerAdmin kontakt@webdesign-jh.de
  DocumentRoot "/var/customers/webs/bn/BenderNetwork.de/"
  FastCgiExternalServer /var/www/php-fpm/bn/BenderNetwork.de/fpm.external -socket /var/lib/apache2/fastcgi/bn-BenderNetwork.de-php-fpm.socket -idle-timeout 30
  <Directory "/var/customers/webs/bn/BenderNetwork.de/">
    <FilesMatch "\.php$">
      SetHandler php5-fastcgi
      Action php5-fastcgi /fastcgiphp
      Options +ExecCGI
    </FilesMatch>
    Order allow,deny
    allow from all
  </Directory>
  Alias /fastcgiphp /var/www/php-fpm/bn/BenderNetwork.de/fpm.external
  Alias /webalizer "/var/customers/webs/bn/webalizer/BenderNetwork.de"
  ErrorLog "/var/customers/logs/bn-BenderNetwork.de-error.log"
  CustomLog "/var/customers/logs/bn-BenderNetwork.de-access.log" combined
</VirtualHost>

Link to comment
Share on other sites

Du wirst doch wohl wissen, was du da gemacht hast? Also "normal" ist das bei dir jedenfalls nicht was da als Vhost rauskommt, daher kann ich dir nicht wirklich sagen was falsch ist ohne Zugang zum Server/Froxlor zu haben.

Link to comment
Share on other sites

Peter88, ?ffne bitte lieber ein eigenes konkretes Thema mit deiner Problemstellung, Jakobus2000 hat einige Probleme, auch mit anderen Services die nicht immer zwingend mit froxlor zu tun haben. Bei dir ist es vielleicht leichter zu l?sen.

Link to comment
Share on other sites

 

 

OFFtopic

d00p ja werde ich machen, aber diesbez?glich habe ich kein Problem. :)
wollte nur mal hier im Forum aktiver sein.
:)
 
wollte nur helfen wenn da noch Hilfe bedarf ist.
und f?r andere die das selbe Problem haben w?re ein Abschluss nicht schlecht.
 
ich hoffe das war keine schlechte idee

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...