Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
lhans

bind9: Server nicht gefunden

Question

Hallo,

ich habe via Froxlor eigene Nameserver erstellt. Diese werden bei meinem Provider erfolgreich geupdatet. Jedoch meinen alle Browser, dass der Server nicht gefunden wurde. Ich habe auch mehr als 24 Stunden nach dem update gewartet. Die Log's von bind habe ich keine (/var/log/).

Gr??e,
lhans

PS: Das Aufrufen der Seite ?ber die Nameserver hatte mal funktioniert. Ein Aufruf der Seite klappt derzeit nur via A-Record.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

Da das ja offensichtlich auch passiert ist, als die froxlor_bind.conf noch nicht inkludiert war, w?rde ich den Fehler mal in deiner bind-config suchen. Die default configs der Distributionen funktionieren eigentlich immer problemlos.

 

Befasse dich doch bitte auch mal mit bind und debugging/logging, siehe z.B. https://help.ubuntu.com/community/BIND9ServerHowto (unten bei Logging).

 

Und lass auch mal den Config-Pr?fer laufen: 

#> named-checkconf /etc/bind/named.conf

etc.etc.etc. das alles findest du auch selbst ?ber google wenn du deine Fehlermeldung googlest.

Share this post


Link to post
Share on other sites

Ne. Meldung: "Ping-Anforderung konnte Host "domain.tld" nicht finden. ?berpr?fen Sie den Namen, und versuchen Sie es erneut."

 

domain.tld wurde durch die Webseite ersetzt.

Share this post


Link to post
Share on other sites

Joa dann l?st die domain wohl nicht auf die IP auf. Sprich dein Nameserver tut nicht das was er soll.

 

Du sagst die Eintr?ge werden bei deinem Provider aktualisiert? Wie machst du das denn genau? Froxlor erstellt ja nur lokale configs f?r ein lokal installierten Bind-Dienst. Sind denn hier die entsprechenden Zonen erstellt worden?

Share this post


Link to post
Share on other sites

Jap, die Eintr?ge werden bei meinem Provider aktualisiert. Ich gebe meinem Provider die Nameserver also "ns1.nsdomain.tld" & "ns2.nsdomain.tld". Die Zone der Domain wurde erstellt.

Zone:

$TTL 86400
@ IN SOA ns1.nsdomain.tld. noreply.domain.tld. (
        2014073100 ; serial
        8H ; refresh
        2H ; retry
        1W ; expiry
        11h) ; minimum
@    IN    NS    ns1.nsdomain.tld.
@    IN    NS    ns2.nsdomain.tld.
@    IN    MX    10 mail.nsdomain.tld.
mail    IN      A               xx.xx.xxx.xxx
@       IN      A               xx.xx.xxx.xxx
www     IN      A               xx.xx.xxx.xxx
*       IN      A               xx.xx.xxx.xxx

 

Share this post


Link to post
Share on other sites

So kommen wir nur schwer weiter, bitte PM mir doch mal eine betroffene (echte) Domain und die IP. Mit diesen Platzhalter-Domains bringt das nix. und auch bitte auch ein nopaste der bind.config wo die zonen definiert werden

Share this post


Link to post
Share on other sites

Nicht PMen - einfach hier schreiben. Es ist doch nichts geheimes oder sch?mst du dich f?r die Webseite? Wenn du sie hier schreibst k?nnen wir alle helfen.

Share this post


Link to post
Share on other sites

Warum benutzt du einen zweiten Nick hier im Forum? Du bist doch schon als "bumskoeter" hier...

 

Zu deinem Problem: deine Domain l?st schlichtweg nicht auf die IP auf.

 

Deine config:

 

named.conf:

// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";

 

zeigt, dass du die Konfiguration nicht gelesen hast, es fehlt n?mlich das include der froxlor_bind.conf Datei

Share this post


Link to post
Share on other sites

Glaub' ich nicht. Du inkludierst die froxlor_bind.conf ?berhaupt nicht in deiner bind-config - das kann nie funktioniert haben.

Share this post


Link to post
Share on other sites

Es hatte funktioniert. Nach einem update der Datei. Habe "include "/etc/bind/froxlor_bind.conf";"      hinzugef?gt. Jetzt startet der DNS Server nichtmehr.

Share this post


Link to post
Share on other sites

Bitte nicht nur "geht nicht mehr"....LOGS LOGS LOGS. Wenn das so schleppend weitergeht und wir dir jede Info einzeln aus der Nase ziehen m?ssen mache ich den Thread hier zu....Und bitte entscheide dich f?r EINEN User, sonst l?sche ich einfach beide.

Share this post


Link to post
Share on other sites

Okay, den hier (lhans) kannst Du bitte l?schen, nachdem das Problem behoben wurde. Habe keine bind9-Logs. Laut dem Befehl "rndc querylog", kann bind9 sich nicht mit 127.0.0.1#953 verbinden. "rndc: connect failed: 127.0.0.1#953: connection refused" Es l?uft auch keinen Dienst mit dem Port von bind9.

Share this post


Link to post
Share on other sites

...was sagt denn z.B. ein "/etc/init.d/bind9 restart" (oder wie auch immer der dienst bei dir heisst). wie schon mal gesagt, lass dir doch bitte nicht alles einzeln aus der Nase ziehen...

Share this post


Link to post
Share on other sites

Eigentlich das selbe.

[....] Stopping domain name service...: bind9rndc: connect failed: 127.0.0.1#953: connection refused
. ok
[FAIL] Starting domain name service...: bind9 failed!

Share this post


Link to post
Share on other sites

Danke Dir. Mit dem Befehl, konnte ich den Fehler aufsp?ren und beseitigen. Fehler war, dass die Froxlor-Kontroldomain Domain bei einem Kunden  zugeteilt war.

Share this post


Link to post
Share on other sites





×
×
  • Create New...