Jump to content
Froxlor Forum
  • 0

[solved] Kein FastCGI Wrapper bei PHP-FPM


Netsurfer

Question

Hallo zusammen!

 

Ich habe auf meinem Server folgende Konstellation:

- Debian Wheezy

- Apache 2.2.22 (mpm-worker)

- PHP-FPM

- Froxlor 0.9.29-1

 

Soweit so gut ...!

Einziger Punkt, der mich zumindest etwas st?rt ist, dass das Server-Log mit der Meldung:"FastCGI: there is no fastcgi wrapper set, user/group options are ignored" quasi zugem?llt wird.

 

Wenn ich das richtig sehe, liegt das ja daran, dass Froxlor f?r die user/group Verwaltung auf suexec zur?ckgreift, und deshalb in den VirtualHost Eintr?gen kein FCGIWrapper angegeben wird.

Dieser wird ja im Prinzip bei der Konstellation auch nicht ben?tigt (im Gegensatz zu der FCGID Variante).

Nur diese ewigen Warnings sind halt l?stig ...!

 

Kann man nicht so etwas wie einen "Dummy" Eintrag erzeugen, um die Warnungen weg zu kriegen?

 

Gru?

Gunther

Link to post
Share on other sites

20 answers to this question

Recommended Posts

Ich habe die vorgestern per apt installiert, also das Debian Paket.

Unterscheidet sich das irgendwie von der GIT Version?

 

Dasselbe Problem beschreibt ?brigens auch http://ma.juii.net/blog/php-fpm-with-froxlor

mit der simplen Aussage:"These can be ignored because Froxlor uses suexec to adapt the user and group of the server process, not the php-fpm internal mechanisms.", die ich eben nicht als so ganz "optimal" erachte.

Link to post
Share on other sites

das unterscheidet sich z.Z. sehr extrem :) Aber das soll jetzt mal nicht dein Problem sein.

 

Also:

1) Halte dich bitte wenn an die Froxlor-handb?cher, sonst kann ich nur sagen: machs bitte erst so wie es bei uns steht

2) In der kommenden version gibt es dazu ne Reihe an ?nderungen, f?r FPM z.B. ist kein SuExec notwendig

3) Wenn du der Froxlor Konfiguration (die du erst machen solltest, NACHDEM du alle Einstellungen angepasst hast f?r FPM) gefolgt bist, solltest du diese Meldungen nicht erhalten.

Link to post
Share on other sites

zu 1. Ich bin genau nach http://redmine.froxlor.org/projects/froxlor/wiki/FPM_-_handbook vorgegangen!

zu 2: Das ist sch?n, hilft mir aber im Moment nicht weiter ... ;-)

zu 3. Sch?n, ich bin aber der Meinung, das genau so gemacht zu haben und erhalte die Meldung trotzdem.

Au?erdem steht im Apache Error-Log:

(2)No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/froxlor.panel/[host name]/fpm.external": connect() failed

FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/froxlor.panel/[host name]/fpm.external"

 

Und jetzt ist mir auch noch die Conf-Datei in /etc/php5/fpm/pool.d im Nirvana verschwunden ..., arghhh! (gibt es einen Weg, an die Datei wieder dran zu kommen, also aus anderer Quelle?)

 

K?nntest du bitte mal einen Beispiel VHost Eintrag posten, damit ich mal vergleichen kann - danke!

Link to post
Share on other sites

Der wird dir ja nicht viel nutzen. Es kommt doch auf die Pfade an die du da in den Einstellungen hinterlegt hast. Froxlor erstellt ?berall die gleichen Configs. Vielleicht postest du einfach mal deinen 10_* er Vhost und einen 22_* (von einem Kunden) - vielleicht sieht man da gleich ob du etwas falsch konfiguriert oder angegeben hast,

Link to post
Share on other sites

Ich will PHP-FPM aktivieren und wenn ich den sed befehl ausf?hre, erhalte ich folgendes

root@Debian-70-wheezy-64-minimal ~ # sed -i.bak 's/^;include=\/etc\/php5\/fpm/*.conf/include=include=\/etc\/php5\/fpm\/pool.d\/*.conf/' /etc/php5/fpm/php-fpm.conf
sed: -e expression #1, char 38: unknown option to `s'

Link to post
Share on other sites

Also ich habe das Ganze jetzt nochmal Schritt f?r Schritt bei einer "jungfr?ulichen" Installation gemacht => selbes Ergebnis!

 

Sobald ich diese Schritte ausf?hre:

# Log in to Froxlor and click on ''Rebuild Configuration Files''.
# Run Froxlor's global cron job once to immediately produce fastcgi configurations for all VirtualHosts:
/usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

kommt die Meldung:

 

[warn] FastCGI: there is no fastcgi wrapper set, user/group options are ignored

 

Meine 10_* er Vhost sieht so aus:

# 10_froxlor_ipandport_[IP-2].80.conf
# Created 12.10.2013 12:27
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

NameVirtualHost [IP-2]:80
<VirtualHost [IP-2]:80>
DocumentRoot "/var/www/"
 ServerName vs1.example.net
  SuexecUserGroup "froxlorlocal" "froxlorlocal"
  FastCgiExternalServer /var/www/php-fpm/froxlor.panel/vs1.example.net/fpm.external -socket /var/run/apache2/froxlor.panel-vs1.example.net-php-fpm.socket -user froxlorlocal -group froxlorlocal -idle-timeout 30
  <Directory "/var/www/">
    AddHandler php5-fastcgi .php
    Action php5-fastcgi /fastcgiphp
    Options +ExecCGI
    Order allow,deny
    allow from all
  </Directory>
  Alias /fastcgiphp /var/www/php-fpm/froxlor.panel/vs1.example.net/fpm.external
</VirtualHost>

Ich habe auch den richtigen sed Befehl verwendet und alles genau nach Anleitung gemacht.

Alle Pfade und Dateien sind auch soweit vorhanden.

 

Wo steckt der "Fehler"?

 

Dank & Gru?

Gunther

Link to post
Share on other sites

Wie sieht deine /etc/apache2/mods-enabled/fastcgi.conf aus?

So wie auch im Handbuch angegeben:

<IfModule mod_fastcgi.c>
 FastCgiIpcDir /var/lib/apache2/fastcgi 

 <Location "/fastcgiphp">
	 Order Deny,Allow
	 Deny from All
	 # Prevent accessing this path directly
	 Allow from env=REDIRECT_STATUS
 </Location>
</IfModule>
Link to post
Share on other sites

Das ist nicht die f?r 0.9.29 von Froxlor ausgelieferte Konfigurations-Datei. F?ge da nach der ersten Zeile (und ?ber FastCgiIpcDir...) folgendes ein:
 

FastCgiWrapper /usr/lib/apache2/suexec
Link to post
Share on other sites

 

Das ist nicht die f?r 0.9.29 von Froxlor ausgelieferte Konfigurations-Datei. F?ge da nach der ersten Zeile (und ?ber FastCgiIpcDir...) folgendes ein:

 

FastCgiWrapper /usr/lib/apache2/suexec

Dann stimmt die Anleitung an der Stelle schon mal nicht - siehe 4. http://redmine.froxlor.org/projects/froxlor/wiki/FPM_-_handbook

 

Aber selbst wenn ich die Zeile einf?ge, meckert er nicht mehr ?ber "[warn] FastCGI: there is no fastcgi wrapper set, user/group options are ignored", daf?r aber "FastCgiWrapper /usr/lib/apache2/suexec

-bash: FastCgiWrapper: Kommando nicht gefunden."

 

Was fehlt ihm jetzt noch?

Die Datei sieht aktuell so aus:

<IfModule mod_fastcgi.c>
 FastCgiWrapper /usr/lib/apache2/suexec
 FastCgiIpcDir /var/lib/apache2/fastcgi 

 <Location "/fastcgiphp">
	 Order Deny,Allow
	 Deny from All
	 # Prevent accessing this path directly
	 Allow from env=REDIRECT_STATUS
 </Location>
</IfModule>
Link to post
Share on other sites

Die Doku ist schon vorbereitet f?r die kommende Version. Au?erdem hast du Konfigurations-Vorlagen in Froxlor selbst. Das Handbuch dient nur zur Orientierung. Gerade was fcgid/php-fpm angeht sollte man doch ein wenig Verst?dnis f?r die Materie aufbringen und sich nicht blind hineinst?rtzen.

Was deine n?chste Fehlermeldung angeht kann ich nur sagen, folge bitte den Konfigurations-Anweisungen im Froxlor, was du anscheinend nicht gemacht hast.

FastCgiWrapper kommt vom mod_fastcgi:

apt-get install libapache2-mod-fastcgi
Edit: und nat?rlich auch aktiveren via "a2enmod fastcgi actions"
Link to post
Share on other sites

Die Doku ist schon vorbereitet f?r die kommende Version. Au?erdem hast du Konfigurations-Vorlagen in Froxlor selbst. Das Handbuch dient nur zur Orientierung. Gerade was fcgid/php-fpm angeht sollte man doch ein wenig Verst?dnis f?r die Materie aufbringen und sich nicht blind hineinst?rtzen.

Was deine n?chste Fehlermeldung angeht kann ich nur sagen, folge bitte den Konfigurations-Anweisungen im Froxlor, was du anscheinend nicht gemacht hast.

FastCgiWrapper kommt vom mod_fastcgi:

apt-get install libapache2-mod-fastcgi
Edit: und nat?rlich auch aktiveren via "a2enmod fastcgi actions"

 

Die waren definitiv schon aktiviert

Module fastcgi already enabled
Module actions already enabled

Ich war eben scheinbar auch nur zu schnell, denn jetzt restartet er ohne "Probleme" und ohne Warnung!

 

Und ich gebe dir Recht, dass man "ein wenig Verst?dnis f?r die Materie aufbringen und sich nicht blind hineinst?rtzen" sollte. Das tue ich auch nicht! ;-)

Nur wenn in einer Anleitung etwas steht, dann gehe ich davon aus, dass das eben so richtig ist!

 

Ein kleiner Hinweis an der Stelle h?tte ja auch nicht geschadet, oder?

Immerhin wird ja auch zwischen Squeeze und Wheezy unterschieden ...! :-P

 

Und nur f?r's Protokoll:

Die Konfigurations-Vorlage in Froxlor f?r PHP-FPM sieht so aus:

# add "non-free" after all occurances of "main" in /etc/apt/sources.list
# this is needed for libapache2-mod-fastcgi to install
apt-get install apache2-suexec libapache2-mod-fastcgi php5-fpm
# change fpm-configuration directory to "/etc/php5/fpm/pool.d/" in froxlor
sed -i.bak 's/^;include=\/etc\/php5\/fpm/*.conf/include=include=\/etc\/php5\/fpm\/pool.d\/*.conf/' /etc/php5/fpm/php-fpm.conf
rm /etc/php5/fpm/pool.d/www.conf
a2enmod suexec fastcgi actions
groupadd -f froxlorlocal
useradd -s /bin/false -g froxlorlocal froxlorlocal
chown -R froxlorlocal:froxlorlocal /var/www/froxlor
a2dismod php5

Also nichts dar?ber, wie die "/etc/apache2/mods-enabled/fastcgi.conf" aussehen muss!

 

Ich danke dir aber wie immer f?r deine schnelle und kompetente Hilfe!

 

Der Thread hier hilft bestimmt dem einen oder anderen auch noch, der sich "genau" an die Anleitung gehalten hat! ;-)

 

Dank & Gru?

Gunther

 

PS: Kann man eigentlich schon irgendwo nachlesen/ sehen, was sich bez?glich PHP-FPM in der kommenden Version (Nr.?) ?ndert, und wann voraussichtlich mit deren Erscheinen zu rechnen ist?

Link to post
Share on other sites

Also nichts dar?ber, wie die "/etc/apache2/mods-enabled/fastcgi.conf" aussehen muss!

Ganz einfach, weil das zur Webserver-Konfiguration geh?rt und daher nicht in Sonstiges::PHP-FPM sondern unter Webserver::Apache2 zu finden ist (wenn FPM aktiviert ist). Daher sage ich immer: ERST alle Einstellungen vornehmen, DANN konfigurieren.

 

PS: Kann man eigentlich schon irgendwo nachlesen/ sehen, was sich bez?glich PHP-FPM in der kommenden Version (Nr.?) ?ndert, und wann voraussichtlich mit deren Erscheinen zu rechnen ist?

Na klar, im Wiki -> http://redmine.froxlor.org/projects/froxlor/roadmap

ein ETA gibt es der Zeit nicht. Ich mache so viel und so schnell ich kann, aber will mich aus zeitlichen Gr?nden nicht auf ein Datum festlegen.

Link to post
Share on other sites

Ganz einfach, weil das zur Webserver-Konfiguration geh?rt und daher nicht in Sonstiges::PHP-FPM sondern unter Webserver::Apache2 zu finden ist (wenn FPM aktiviert ist). Daher sage ich immer: ERST alle Einstellungen vornehmen, DANN konfigurieren.

Das ist aber so ein "Henne - Ei" Problem. ;-)

Und ?ndert im ?brigen nichts daran, dass wenn man "genau nach Anleitung" vorgeht, der Eintrag in der Datei fehlt ...! :-P

 

Na klar, im Wiki -> http://redmine.froxlor.org/projects/froxlor/roadmap

ein ETA gibt es der Zeit nicht. Ich mache so viel und so schnell ich kann, aber will mich aus zeitlichen Gr?nden nicht auf ein Datum festlegen.

Danke f?r den Link - h?tte ich ja auch selber drauf kommen k?nnen.

Soweit ich das sehe, gibt es da aktuell noch die beiden Features '915 und #1051.

 

Letzteres kann ich gut nachvollziehen. ;-)

Link to post
Share on other sites

Nett gemeint mit der ?nderung im Handbuch, allerdings ist das ab der n?chsten Version obsolet und ich muss wieder dran denken das zu aktualisieren, daher w?rde ich dich bitten, die ?nderungen r?ckg?ngig zu machen. Die korrekten Konfigurations-Template sind IMMER in Froxlor selbst. Im Wiki steht halt das was z.Z. am AKTUELLSTEN g?ltig ist, und das ist nun mal gerade 0.9.29.1-dev3 und nicht mehr 0.9.29

Link to post
Share on other sites

Nett gemeint mit der ?nderung im Handbuch,

Ja, so war es auch gemeint. ;-)

Nat?rlich mache ich das gerne auch wieder r?ckg?ngig, wenn du das m?chtest.

Der Gedanke war halt der, dass jeder, der wie ich z.B. nicht ?ber GIT, sondern bspw. ?ber APT installiert und die Anleitung befolgt, genau dasselbe Problem wie ich haben d?rfte.

 

... allerdings ist das ab der n?chsten Version obsolet und ich muss wieder dran denken das zu aktualisieren, daher w?rde ich dich bitten, die ?nderungen r?ckg?ngig zu machen. Die korrekten Konfigurations-Template sind IMMER in Froxlor selbst. Im Wiki steht halt das was z.Z. am AKTUELLSTEN g?ltig ist, und das ist nun mal gerade 0.9.29.1-dev3 und nicht mehr 0.9.29

Ich erkl?re mich auch gerne bereit, f?r dich daran zu denken, und das, sobald es nicht mehr notwendig ist, wieder zu l?schen.

 

Sag' an, wie du es gerne h?ttest. ;-)

 

Gru?

Gunther

Link to post
Share on other sites

Die Sache ist halt, du weisst ja nicht wann die n?chste Version kommt, dann muss doch ich wieder dran denken etc.etc.etc. mir w?re es am liebsten es bleibt bitte so wie es vorher war.

Link to post
Share on other sites

OK, kein Problem - schon wieder ge?ndert.

 

Wenn ich noch einen Vorschlag machen d?rfte:

Ein simpler Hinweis darauf, dass man *nach* Ende der Prozedur einfach noch(mal) die Froxlor Webserver (Apache2) Konfiguration durchf?hren muss/ sollte, h?tte mein Problem gar nicht erst entstehen lassen - auch wenn das f?r Experten wie dich vielleicht selbstverst?ndlich erscheinen mag, f?r viele weniger Bewanderte w?re es aber sicherlich eine Hilfe ...! ;-)

 

Dank & Gru?

Gunther

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...