Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
cardman

[solved] Problem: PHP Mail() funktioniert nicht mehr

Question

Hallo,

 

seit einigen Tagen kann ich keine Mails mehr mit dem PHP-Befehl Mail() versenden.

 

PHP-Version: 5.2.6-1+lenny13

OS: Debian Lenny

 

Aufgefallen ist der Fehler durch Froxlor selber. Beim anlegen / beantworten eines Tickets kam es immer zu einer Fehlermeldung. Froxlor verwendet zwar die PHPMailer-Klasse, allerdings wird der Befehl Mail benutzt.

Damit das Froxlor wieder funktioniert habe ich das System so angepasst, das die Klasse die Mails per SMTP versendet. Was problemlos funktioniert.

Nichts desto trotz w?re es sch?n, wenn der Befehl wieder funktioniert.

 

Wenn R?ckfragen sind, k?nnt ihr diese gerne stellen. Ich werde versuchen diese so schnell wie m?glich zu beantworten.

 

Hier das Script, mit dem ich den Befehl teste:

 

$to      = "mail@mail.de"; 
$betreff = "betreff";
$xtra    = "From: mail@mail.de \n"; 
$xtra   .= "Content-Type: text/html\nContent-Transfer-Encoding:8bit\n";
$xtra   .= "X-Mailer: PHP ". phpversion();

if (mail($to, $betreff, "TEST", $xtra)) {
echo "geht";
} else {
echo "geht nicht";
}

 

Hier noch die PHP.ini dazu:

 

short_open_tag = On
asp_tags = Off
precision = 14
output_buffering = 4096
allow_call_time_pass_reference = On
safe_mode = On
safe_mode_gid = Off
safe_mode_include_dir = "/usr/share/php/:/usr/share/php5/"
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
;open_basedir = none
disable_functions = passthru,shell_exec,system,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate
disable_classes =
expose_php = Off
max_execution_time = 30
max_input_time = 60
memory_limit = 64M
post_max_size = 64M
error_reporting = E_ALL & ~E_NOTICE
display_errors = On
display_startup_errors = Off
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
html_errors = Off
variables_order = "GPCS"
register_globals = On
register_argc_argv = Off
gpc_order = "GPC"
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
include_path = ".:/usr/share/php/:/usr/share/php5/"
enable_dl = Off
file_uploads = On
upload_tmp_dir = "/var/kunden/tmp/kunden/"
upload_max_filesize = 64M
allow_url_fopen = On
sendmail_from = "mail@mail.de"
sendmail_path = "/usr/sbin/sendmail -t -i"
session.save_handler = files
session.save_path = "/var/kunden/tmp/kunden/"
session.use_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor = 1000
session.gc_maxlifetime = 14400
session.bug_compat_42 = 0
session.bug_compat_warn = 1
session.referer_check =
session.entropy_length = 16
session.entropy_file = /dev/urandom
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
suhosin.simulation = Off
suhosin.mail.protect = 1
; Defines the default timezone used by the date functions
date.timezone = "Europe/Berlin"


[Zend]
zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so
;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3
;zend_optimizer.version=3.3.3
;zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
;zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
zend_optimizer.optimization_level=15
zend_extension="/usr/local/Zend/ZendOptimizer.so"


;[eAccelerator]
;extension="eaccelerator.so"
;eaccelerator.shm_size="16"
;eaccelerator.cache_dir="/var/kunden/tmp/kunden/"
;eaccelerator.enable="1"
;eaccelerator.optimizer="1"
;eaccelerator.check_mtime="1"
;eaccelerator.debug="0"
;eaccelerator.filter=""
;eaccelerator.shm_max="0"
;eaccelerator.shm_ttl="0"
;eaccelerator.shm_prune_period="0"
;eaccelerator.shm_only="0"
;eaccelerator.compress="1"
;eaccelerator.compress_level="9"

 

In den Log-Dateien vom Apache sind keine Fehler zu finden.

 

Ich hoffe ihr k?nnt mir helfen.

 

Gruss

Cardman

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

Normalerweise reicht es das script auszuf?hren w?hrend man in der console auf die syslog ein auge hat, dort kommen alle fehler, falls so konfiguriert, zusammen ;)

 

Beispiel: tail -f /var/log/syslog

Share this post


Link to post
Share on other sites

Hallo,

 

ich hab mir die Syslog genau angeschaut und bekomme beim versuch eine Mail zu versenden folgende Fehlermeldung:

 

Aug 12 11:06:03 Server1 nss-mysql[21544]: fatal: no login name found for user ID 10073

 

Ich hab es auch unter anderen Benutzern getestet, das Ergebnis ist immer das selbe:

 

Aug 12 11:09:10 Server1 nss-mysql[22534]: fatal: no login name found for user ID 10012

 

Nur die Benutzer-ID ?ndert sich.

 

Was ich per Google herausgefunden habe ist, das ich den Parameter:

 

-f eMail-Adresse

 

hier:

 

sendmail_path = "/usr/sbin/sendmail -t -i"

 

mit Anh?ngen muss.

 

Hat sich an der Stelle was ge?ndert? Bisher ging das doch auch ohne den Parameter Problemlos.

 

Gruss

cardman

Share this post


Link to post
Share on other sites

Wenn du FCGID nutzt, wird f?r jede Domain ein eigene php.ini angelegt und die zeile entsprechend gef?llt:

 

sendmail_path = "/usr/sbin/sendmail -t -f {CUSTOMER_EMAIL}"

Share this post


Link to post
Share on other sites

Nur zur Vollst?ndiger zugute: Wenn ich es korrekt verstanden habe, ist dieser Parameter n?tig, wenn sich der Mailclient am SMTP authentifizieren muss (was von Froxlor in der suggerierten Postfix-Konfiguration auch per default gesetzt ist).

Share this post


Link to post
Share on other sites

Ich frag mich nur, warum es dann die ganze Zeit ging und erst seit kurzem nicht mehr.

Aber es ist ja im endeffekt egal. Hauptsache es funktioniert wieder.

 

Gruss

cardman

Share this post


Link to post
Share on other sites

Ich frag mich nur, warum es dann die ganze Zeit ging und erst seit kurzem nicht mehr.

Falls du dazu mal mehr erf?hrst, kannst du dein Wissen hier gerne teilen. W?rde mich auch interessieren. ;)

Share this post


Link to post
Share on other sites





×
×
  • Create New...