Jump to content
Froxlor Forum
  • 0
peperoni

E-Mail weiterleitung wird doppelt verschickt...

Question

Hi Zusammen,

 

habe eben ein komischen Fehler bemerkt.

Wenn ich ein Konto anlege "info@example.de" diese Konto bekommt EINE weiterleitung "v.name@example.de" dann bekommt "v.name@example.de" die weitergeleiteten E-maisl doppelt.

 

Also ich schicke eine E-Mail an : info@example.de diese wird ins Postfach gelegt und zweimal an v.name@example.de geschickt...

 

Dovecote/Spamassassin/Postfix

 

/var/log/mail.log

Jun 21 22:29:15 srv postfix/smtpd[16792]: connect from mailout-de.gmx.net[213.165.64.23]
Jun 21 22:29:15 srv postfix/smtpd[16792]: 138202A6C13A: client=mailout-de.gmx.net[213.165.64.23]
Jun 21 22:29:15 srv postfix/cleanup[16800]: 138202A6C13A: message-id=<4E00FF19.1040706@gmx.de>
Jun 21 22:29:20 srv postfix/qmgr[31411]: 138202A6C13A: from=<externemail@gmx.de>, size=937, nrcpt=2 (queue active)
Jun 21 22:29:20 srv postfix/smtpd[16792]: disconnect from mailout-de.gmx.net[213.165.64.23]
Jun 21 22:29:22 srv postfix/pickup[14592]: 455522A6C558: uid=65534 from=<externemail@gmx.de>
Jun 21 22:29:22 srv postfix/pipe[16804]: 138202A6C13A: to=<info@example.de>, relay=spamassassin, delay=7.2, delays=2/3.6/0/1.6, dsn=2.0.0, status=sent (delivered via spamassassin service)
Jun 21 22:29:22 srv postfix/pipe[16804]: 138202A6C13A: to=<v.name@example.de>, orig_to=<info@example.de>, relay=spamassassin, delay=7.2, delays=2/3.6/0/1.6, dsn=2.0.0, status=sent (delivered via spamassassin service)
Jun 21 22:29:22 srv postfix/qmgr[31411]: 138202A6C13A: removed
Jun 21 22:29:22 srv postfix/cleanup[16800]: 455522A6C558: message-id=<4E00FF19.1040706@gmx.de>
Jun 21 22:29:22 srv postfix/qmgr[31411]: 455522A6C558: from=<externemail@gmx.de>, size=1274, nrcpt=3 (queue active)
Jun 21 22:29:22 srv postfix/pipe[16813]: 455522A6C558: to=<v.name@example.de>, orig_to=<info@example.de>, relay=dovecot, delay=0.07, delays=0.02/0.01/0/0.04, dsn=2.0.0, status=sent (delivered via dovecot service)
Jun 21 22:29:22 srv postfix/pipe[16812]: 455522A6C558: to=<info@example.de>, relay=dovecot, delay=0.08, delays=0.02/0.01/0/0.05, dsn=2.0.0, status=sent (delivered via dovecot service)
Jun 21 22:29:22 srv postfix/pipe[16815]: 455522A6C558: to=<v.name@example.de>, relay=dovecot, delay=0.21, delays=0.02/0.02/0/0.17, dsn=2.0.0, status=sent (delivered via dovecot service)
Jun 21 22:29:22 srv postfix/qmgr[31411]: 455522A6C558: removed

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0
## General Postfix configuration
# should be the default domain from your provider eg. "server100.provider.tld"
mydomain = host.example.com

# should be different from $mydomain eg. "mail.$mydomain"
myhostname = host.example.com

mydestination = $myhostname,
$mydomain,
localhost.$myhostname,
localhost.$mydomain,
localhost
mynetworks = 127.0.0.0/8
inet_interfaces = all
append_dot_mydomain = no
biff = no

# Postfix performance settings
default_destination_concurrency_limit = 20
local_destination_concurrency_limit = 2

# SMTPD Settings
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_helo_required = yes
smtpd_recipient_restrictions = permit_mynetworks,
permit_sasl_authenticated,
reject_unauth_destination,
reject_unauth_pipelining,
reject_non_fqdn_recipient,
check_recipient_mx_access cidr:/etc/postfix/mx_access


smtpd_sender_restrictions = permit_mynetworks,
reject_sender_login_mismatch,
permit_sasl_authenticated, 
reject_unknown_helo_hostname, 
reject_unknown_recipient_domain, 
reject_unknown_sender_domain
smtpd_client_restrictions = permit_mynetworks,
permit_sasl_authenticated
#reject_unknown_client_hostname
# Maximum size of Message in bytes (50MB)
message_size_limit = 52428800

## SASL Auth Settings
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes
## Dovecot Settings for deliver, SASL Auth and virtual transport
smtpd_sasl_type = dovecot
mailbox_command = /usr/lib/dovecot/deliver
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1
smtpd_sasl_path = private/auth

# Virtual delivery settings
virtual_mailbox_base = /var/customers/mail/
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf
smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cf
virtual_uid_maps = static:2000
virtual_gid_maps = static:2000

# Local delivery settings
local_transport = local
alias_maps = $alias_database

# Default Mailbox size, is set to 0 which means unlimited!
mailbox_size_limit = 0
virtual_mailbox_limit = 0

### TLS settings
###
## TLS for outgoing mails from the server to another server
#smtp_tls_security_level = may
#smtp_tls_note_starttls_offer = yes
## TLS for email client
#smtpd_tls_security_level = may
#smtpd_tls_cert_file = /etc/ssl/server/web1.moviebank.eu.pem
#smtpd_tls_key_file = $smtpd_tls_cert_file
#smtpd_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
#smtpd_tls_loglevel = 1
#smtpd_tls_received_header = yes

debugger_command =
        PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
        ddd $daemon_directory/$process_name $process_id & sleep 5


Share this post


Link to post
Share on other sites
  • 0

Hi,

 

selbes Problem bei mir... mit dem Unterschied, dass die Mails 3fach bei der Weiterleitung ankommen, zus?tzlich zur ersten Empf?ngeradresse.

 

Hat die Empf?ngeradresse aber kein Konto, sondern nur eine Weiterleitung, geht es problemlos.

Share this post


Link to post
Share on other sites
  • 0

Ich hab den Fehler gefunden, in meinem Fall an 2 Stellen:

 

master.cf erweitert um "-o receive_override_options=no_address_mappings" auf:

 

smtp      inet  n       -       n       -       -       smtpd
   -o <irgendwas>
   -o receive_override_options=no_address_mappings

 

UND

 

127.0.0.1:10025 inet    n   -   n   -   20  smtpd
   -o <irgendwas>
   -o receive_override_options=no_address_mappings

 

Ich hoffe das hat schon geholfen :)

Share this post


Link to post
Share on other sites
  • 0

Ist die beschriebene Methode sicher und/oder wird das im n?chsten Update eingearbeitet? Ich habe gerade eine Mailadresse mit Postfach und einer Weiterleitung eingerichtet und bin prompt auf dieses Problem gesto?en.

 

Es scheint dabei ?brigens keine Rolle zu spielen, ob auf eine interne Adresse auf dem gleichen Server oder eine externe weitergeleitet wird.

Share this post


Link to post
Share on other sites
  • 0

habe die L?sung von Donar nie wirklich getestet, habe mich mit dem problem abgefunden, bzw. mein "Kunde"

W?re schon wenn es mal von Offizieller Seite nen Statement geben w?rde...

Share this post


Link to post
Share on other sites
  • 0

Gleiches Problem, gleiche L?sung. Vielen Dank f?r den Hinweis :)

Habe auch die receive_override_options f?r 127.0.0.1:10025 (amavis R?ckf?hrung hier) um no_address_mappings erg?nzen m?ssen.

Share this post


Link to post
Share on other sites
  • 0

http://www.postfix.o...verride_options

no_address_mappings

Disable canonical address mapping, virtual alias map expansion, address masquerading, and automatic BCC (blind carbon-copy) recipients. This is typically specified BEFORE an external content filter.

 

Sehe kein Problem das zu benutzen.

 

Beispiel im Einsatz: http://redmine.froxl...En-SpamAssassin

Share this post


Link to post
Share on other sites
  • 0

Problem habe ich auch und bisher keine funktionierende L?sung gefunden, der Eintrag mit no_address_mappings hat bei mir nur dazu gef?hrt, dass garkeine Mails mehr ankamen

Share this post


Link to post
Share on other sites
  • 0

smtp	 inet n	 -	 -	 -	 -	 smtpd
 -o receive_override_options=no_address_mappings
 -o content_filter=spamassassin

 

Ich hab damit keine Probleme [mehr].

 

Disable canonical address mapping, virtual alias map expansion, address masquerading, and automatic BCC (blind carbon-copy) recipients. This is typically specified BEFORE an external content filter.

Share this post


Link to post
Share on other sites
  • 0

wie gesagt, bei mir gings nich, is mir auch wurscht, die leute werden es ?berleben, wenn sie eine mail doppelt kriegen

Share this post


Link to post
Share on other sites
  • 0

Hallo,

 

muss das Problem leider auch mal aufgreifen. Bei mir habe ich das gleiche Problem. Eine Anpassung der master.cf bringt keine Besserung. Wodurch kann die doppelt Weiterleitung noch hervorgerufen werden? Catch-All kann ausgeschlossen werden.

Share this post


Link to post
Share on other sites
  • 0

Gab es schon 1000x das Thema, es ist def. amavis und der entsprechende eintrag mit receive_override_options=no_address_mappings in der master.cf

Share this post


Link to post
Share on other sites
  • 0

Mh... hab die master.cf jetzt entsprechend angepasst und postfix restartet. Leider kommen die Mails immer noch doppelt.

# Amavisd-new
amavisfeed     unix  -       -      n       -        2        lmtp
    -o lmtp_data_done_timeout=1200
    -o lmtp_send_xforward_command=yes
    -o smtp_tls_note_starttls_offer=no
    -o receive_override_options=no_address_mappings
amavisfeed    unix  -       -       n       -        2        smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    -o smtp_tls_note_starttls_offer=no
    -o receive_override_options=no_address_mappings

Hab ich was vergessen?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...