Jump to content
Froxlor Forum

All Activity

This stream auto-updates

  1. Last week
  2. Well, I have started to create websites in 1998 and since then used almost all CMS. I am an open source expert, currently working for an open source CMS editor. I have been a product owner at the Eclipse Foundation, working on web apps and modules. I even cofounded Ubuntu Studio. So, yes, I am certainly not what you would call a highly skilled sysadmin. But I have some experience about managing webservers and installing software on them. I can tell that I am a bit disapointed by the way you install your tables. Never seen that... Again, thank you very much for your time. And really, feature request, check if the database is already used, and add a confirmation message. This is what I ask developers to do in this kind of case (risk of deleting something), when I write specs or do product management.
  3. well that's why we dump the database if it exists...sorry, first time i've heard someone doing that. froxlor is meant to be a system-tool for sys-admins with at least a bit of basic understanding of linux and the used services. Sorry you have such a bad expierence with it
  4. well, then you have created the only web software I ever installed that do that. all other software I ever installed before froxlor actually just added tables, with a keyword like wp_ at the beginning of the table names. I was expecting to find tables with froxlor_, btw. so maybe this can be a feature request, that would make it safer for future users? because this behavior with the database is not at all explained in the documentation, and is not even explained during the installation and configuration process. at least adding a explicit disclaimer or a warning with a confirmation somewhere if the database is already used for something else would be great
  5. why in the world would you do that? froxlor does not share its database...it removes the one you give it at installation-time if it exists (a mysql-dump should have been created in /tmp if mysqldump was found)
  6. I don't think that mysql has been removed when I uninstalled the froxlor package with apt, as I didn't had to re-install it. But you are right, I should have created a dedicated database for froxlor. Instead I actually shared the same database as the one I use for wordpress: usually, applications just add tables, they do not empty the database. Very weird, first time something like that happens.
  7. well when removing the debian/ubuntu package, even if mysql get removed too, the data stays there, so...very unlikely that the froxlor installation removed/deleted your databases....and i doubt your productive database was called "froxlor"
  8. It is not a problem of browser cache, as I tried with many browsers on many devices. The redirection is for all visitors. From the Apache logs it seems that there is a big issue with the mysql database. I checked, and actually it seems that during install of Froxlor, my database content has been flushed (or deleted/recreated empty), and I lost all the data of my website. So I am currently cleaning what's left of Froxlor data in mysql, should be quick. It is the first time ever something like that happens to me while installing a web software, that's why I didn't checked before. And then I will get a backup and will import it again to mysql, hoping that this will solve the problem.
  9. Well you need to try to trace the error where the redirect originates, also try cleaning your browser cache etc. try to check whether something comes up in /var/log/apache2/error.log etc.
  10. vhost: <VirtualHost *:80> ServerAdmin webmaster@localhost DocumentRoot /var/www/html ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined </VirtualHost> all the files of the wordpress multisite is in /var/www/html, that is the only website on this server. I use this simple configuration so that all the domains pointing to the server goes to the same folder, and then wordpress map the domains to the sites owner of the files is www-data:www-data files in the folder are recursively set to 755 just let me know what log you want to see and I will add them.
  11. well that's how apt works...nothing we can do about it Well if you'd just nopaste your current vhost-config you are using for your website along with some logs and information about location and permissions and ownership, we might even be able to help you find the issue
  12. I actually didn't paste anything blindly, as it was possible to use a command line tool to do the configuration, whithin I chose what I needed with keywords It also installed many packages as dependencies. Oh, and btw, I used the Ubuntu package for installation, not the tar file. So maybe when I uninstalled it using apt, it removed a dependancy that should not have been uninstalled? (eg: I had to re-install some apache modules, not just re-enable them) Anyway. I would like to thank you very much for your time and your answers, I guess that I broke something in the server configuration while trying to clean after uninstalling. I hope that I will be able to find why I can't make my website to run again without this 302 redirection loop
  13. no no and no. If you'd read what you were pasting blindly you'd know it's about the CUSTOMERS basedir (e.g. /var/customers/webs and /var/customers/tmp) and again: nothing touches the default apache config
  14. oh but maybe this is a permission or ownership problem? does your installation script changes the default users for the web server, or something like that?
  15. You mean creating directories, setting ownership and permissions to these directories etc.? nothing there changes the default apache config
  16. I did that already, actually. But when I ran the configuration script (the first step to do at first login in to the backoffice), I saw that a lot of tasks and configuration are done in the terminal, it tooks some time. That's why I was expecting that something else has to be done to clean the installation.
  17. assume you are using apache as webserver: # rm /etc/apache2/sites-enabled/*froxlor*.conf # service apache2 restart there just is not more to it regarding webserver configs...
  18. yes, but I checked the .htaccess file and it's the default one for a multisite with subdomain, nothing special here. I didn"t changed anything in the website files. It's just since I tried to install Froxlor that it broke into the endless redirection loop. So, maybe I missed some Froxlor config file that I should remove ?
  19. so you've (re-)enabled the default vhost - then best check your wordpress installation for any .htaccess files and possible redirects, because that's what your error states - an endless redirection loop
  20. well, then tell me the config file you would like to see and I'll provide them. currently, Apache is configured so serve all domain (*) to var/www/html. that's what was configured before trying to install Froxlor, and I as able to re-enable it, after deleting froxlor .conf files. I don't blame anybody, actually. I am just looking for help, to just have my WordPress websites working again without this too many redirect error.
  21. regarding webserver....I'm 100% certain it's only the auto-generated vhost configs (basically everything with *froxlor* in its name). You get an error with no froxlor related configs in place and blame froxlor for it? Without even showing us your currently active vhost config or anything? And sorry no, you do not have to reinstall apache and re-enable php only because you have removed froxlor...total bullshit. Sorry, you don't seem to know what you're doing really...
  22. That's what I did, but after that, nothing was working anymore. It seems that the configuration step is actually changing more things that you think. That's why I had to reinstall Apache, enable PHP, etc.
  23. Well that has absolutely nothing to do with froxlor...especially when you get the problem AFTER you have removed froxlor and all its generated config files... Uninstall tutorial? What more then "rm -rf /var/www/froxlor/" and possibly the auto-generated vhost-configs in the corresponding directory do you need? Froxlor does not bind itself deep to the system like others...there's not more to it then just remove our files (and database if you like, doesnt matter).
  24. Hello, I tried to install Froxlor on my server but this was far more complicated than I expected. I actually had a website already on this server, before the installation, and everything was broken. Well I was expecting that, but I was thinking it would be easy to reconfigure everything to make it to work again. Fact: I was not able to make it, and the "configuration" step of Froxlor, once in the backoffice, is creating a looooooot of things. And, there is no documentation about how to do a clean uninstall, that's my problem. Anyway, I removed Froxlor and reinstalled Apache on my server, then cleaned Froxlor config files that I could find in /etc/apache2/sites-enabled/, etc. After a some work, I was able to restart my server with the domains pointing to the right path., with PHP, and mod rewrite enabled. However, I have a real problem: now I have the error "ERR_TOO_MANY_REDIRECTS" when I try to access my websites. I can't find a way to fix that. On the server, there is a WordPress multisite and I never had such an issue. You can try with libre-factory.com (main domain), or ttoine.net for an other site managed by the WordPress multisite with multidomains. I would really appreciate any help, and would be glad to help to write an uninstall tutorial if I get the resource. ttoine
  25. Earlier
  26. Ich bin es jetzt noch einmal durchgegangen. Du hast Recht, bei 2 Vhosts waren keine Zeilenumbrüche im Eingabefeld. Warum, weiß ich nicht, bisher hatte es so funktioniert und geändert hatte ich auch nichts. Jetzt sollte es aber erst einmal wieder ohne Probleme laufen.
  1. Load more activity
×
×
  • Create New...