Jump to content
Froxlor Forum

All Activity

This stream auto-updates

  1. Last week
  2. Problem behoben, libnss-extrausers vergessen, danach liefs einwandfrei
  3. Hallo! Nun habe ich meinen Server noch mal komplett platt gemacht und neu aufgesetzt und nach dem Video alles 1:1 gemacht. Zum testen habe ich dann einen Kunden angelegt. Auch die eMail wurde versendet. Sah also alles sehr gut aus. Dann dachte ich mir rufst Du mal die Subdomain von dem angelegt User auf. Nun geht gar nichts mehr: Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. Apache/2.4.54 (Debian) Server at v2202111160680168774.goodsrv.de Port 80 Den Apache habe ich einfach mal neu gestartet, aber keine Änderung. Ich vermute das Froxlor mal eben den Server zerschossen hat. Gruß sven
  4. Earlier
  5. naja, deine grundeinstellung zu Linux hast du ja direkt klar gemacht...froxlor ist nunmal nicht für den end-benutzer gedacht, sondern als Erleichterung für Sys-Admins. Ein bisschen was musst du schon tun - und das ist alles nichts Wildes. Ein froxlor ist in 5 min aufgesetzt und fertig - es ist halt kein Wordpress das mit 2 klicks rennt - es konfiguriert system-relevante Dienste.
  6. Hallo! Danke! Ok, ich schaue beim Discord vorbei. Das wird aber morgen Abend werden, da ich noch weg muss. Es ist schon irgendwie schade, das nicht eine funktionierende Grundkonfiguration fertig in Froxlor enthalten ist. Gruß sven
  7. Ich würde schätzen du hast die docs nicht zu ende gelesen und weder einstellungen angepasst noch die dienste konfiguriert... Schau doch am besten bei uns im Discord vorbei, da kann man dir sicher effizienter und schneller helfen als wenn du jetzt für jeden einzelnen punkt einen foren-thread aufmachst
  8. Hallo! Nachdem Froxlor nun läuft habe ich einen Kunden angelegt und dem entsprechende Funktionen zugeordnet. Das ging auch Fehlerfrei. Allerdings habe ich folgende Probleme: a) FTP Zugriff nicht möglich, obwohl aktiviert. b) Für den User wurde lt Froxlor folgendes Verzeichnis angelegt: /var/customers/webs/dozent/ Leider gibt es dieses Verzeichnis gar nicht. Habe grade per SSH auf dem Server nachgesehen. Also hat Froxlor das nicht angelegt. Wir kann das sein? c) Wenn ich die Subdomain aufrufe, die Froxlor für den Kunden angelegt hat, kommt das Verzeichnis und ich kann Froxlor oder HTM anklicken. Was läuft da schief? Danke! Gruß sven
  9. Hallo! Jetzt lief es durch. DIe Installationsanleitung legt den SQL Root User mit Namen froxroot an. Bem Webinstall steht aber nur root in dem Feld. Das habe ich dann in froxroot geändert und dann geht es auch. Entweder sollte das in der Anleitung korrigiert werden, oder die Vorgabe im WebIf sollte auf froxroot geändert werden. Gruß sven
  10. Hallo! Das ist alles sauber durchgelaufen. Habe die Befehle alle kopiert und dann in SSH eingefügt. Das Passwort vom unprivigelierten User wird da ja angelegt. Aber was ist mit dem MySQL root Passwort? SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost' Kommt immer. Egal ob ich das Root-Passwort vom Server nehme, oder das vom unprivigeliertem. Gruß sven
  11. https://docs.froxlor.org/latest/general/installation/apt-package.html#_4-setup-mysql
  12. Hallo! Komme aber jetzt noch nicht durch die Installation durch. Ich soll das Passwort für den unprivilegierten MySQL user angeben und für den Root-MySQL User. Da ich davon aus ginge, das ich da eines festlegen soll, habe ich mir eines ausgedacht und das eingetragen. Beim Klick auf Installation durchführen erhalten ich dann die Fehlermeldung das das Passwort falsch ist. Woher bekommen ich denn das richtige? Es wurden bei der Installation ja nie nach Passwörtern gefragt. Danke! Gruß sven
  13. Hallo! Danke! Uh, das ist interessant, das es auf einmal geht. Vorhin ging ging rein gar nichts. Vielleicht brauchte der Server eine ganze Weile. Gruß sven
  14. (Weiss zwar nicht was bei dir "Nichts geht mehr" bedeutet, aber schau doch mal auf deine eigene Seite: http://89.58.0.26/froxlor/ - geht wunderbar)
  15. Was soll ich dazu sagen? Dann ist wohl das Betreiben eines Linux-Servers nichts für dich.
  16. Hallo! Ich habe das gemacht und jetzt geht gar nichts mehr. Ich kann auch nicht via /www die apache Standard-Seite anzeigen lassen. Habe den Server sogar schon komplett neu gebootet Da ist wie immer die typische Linx-Frickerlei. Rumgewurschtel in irgendwelchen Config-Dateien und am Ende geht nichts mehr. Schade! Warum kann die Froxlor Installation das nicht alles gleich vollautomatisch anpassen? Denke mal das ist es jetzt gewesen. Gruß sven
  17. Wie in der Anleitung als Notiz geschrieben steht: Prüfe, dass dein Webserver auch auf das korrekte Verzeichnis zeigt. Bearbeite hierfür die /etc/apache2/sites-enabled/000-default.conf und korrigiere ggfls. den Wert der DocumentRoot Anweisung. In den meisten Fällen steht dort /var/www/html, und wenn deine froxlor Dateien in /var/www/froxlor liegen, änderst du es in /var/www um, startest den webserver neu und dann kannst du das auch korrekt aufrufen im Browser.
  18. Hallo! Ich komme leider bei der Installation nicht weiter. An diesem Punkt gehts nicht mehr weiter: 5. Proceed with installation and configuration Now follow the general installation documentation starting with step 3: Install froxlor from tarball http://{your-ip-address}/froxlor Bei mir also http://89.58.0.26/froxlor Das müsste ich ja aufrufen, aber da kommt dann nur: Not Found The requested URL was not found on this server. Apache/2.4.54 (Debian) Server at 89.58.0.26 Port 80 Bis dahin lief die Installation sauber und ohne irgendeinen Fehler durch. Mit https://89.58.0.26/froxlor geht es auch nicht. Mit http://89.58.0.26 bekomme ich die Apache Default Page. Was kann ich tun? Leider kenne ich mich mit Linux noch nicht so gut aus. Vielen Dank!!! Gruß sven
  19. The question literally is "[...] I could install without apache, only using NGINX. Is that still possible [...]" and my answer clearly states the answer to that.
  20. I think its not about NGINX or Apace, its all about Package that you are using with both of them. And if we talk about performance then NGINX is much better than Apache. Thanks
  21. ja ist doch klar, da steht ja auch: # FQDN from Froxlor mydomain = meine-domain.tld Mach doch einfach Folgendes: myhostname = $mydomain mydomain = mx.meine-domain.tld und ab gehts
  22. Dachte ich mir ja auch, nun kam dort ein Fehler. Hab ich jetzt gemacht, ein Konto erstellt. Anmeldung hat geklappt, jedoch kommt im Mail-Log warning: do not list domain meine-domain.tld in BOTH mydestination and virtual_mailbox_domains Postfix myhostname = mx.$mydomain #myhostname = virtual.domain.tld # The mydomain parameter specifies the local internet domain name. # The default is to use $myhostname minus the first component. # $mydomain is used as a default value for many other configuration # parameters. # # Froxlor Note: We are using a default here but that may or may not make sense, # depending on your dns configuration, please check yourself. # FQDN from Froxlor mydomain = meine-domain.tld #mydestination = $myhostname, localhost.$mydomain, localhost mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain Bis auf, dass ich mydomain von vie.meine-domain.tld auf meine-domain.tld geändert habe und oben statt mail mx geschrieben habe, sind alle Einstellungen gleichbleibend wie von Froxlor voreingestellt.
  23. Aber warum setz du denn dann "meine-domain.tld" nicht einfach als "Ist E-Mail Domain": ja Genau so ist es doch gedacht...wenn froxlor mittels "vie.meine-domain.tld" eingerichtet ist als system-hostname und für postfix "mx.meine-domain.tld" verwendet wird, hast du doch garkein problem mit "mydomain/myhostname darf nicht auch in den virtual-domains sein". So machen das 99% der froxlor user soweit ich das in den letzten Jahren gesehen habe und auch selbst mache. Null Probleme.
  24. System-Hostname ist vie.meine-domain.tld Domain-Aliase für Froxlor Vhost : mx.meine-domain.tld Kunden-Domain meine-domain.tld jedoch mit dem Haken entfernt bei E-Mail-Domain Ja Das angegebene Zertifikat in Postfix ist das, des Hostnamen vie.meine-domain.tld (mit Alias mx...) Aliases # /etc/aliases mailer-daemon: postmaster postmaster: root nobody: root hostmaster: root usenet: root news: root webmaster: root www: root ftp: root abuse: root noc: root security: root clamav: root # change this to a valid e-mail address you can access root: root@meine-domain.tld Jedoch z.B. der SNDS von Microsoft für IPs zeigt als Auswahlmöglichkeit nur ein Postfach mit @meine-domain.tld an, eine externe Aliasdomain wurde nicht angezeigt.
  25. gar nicht, das ist ja sinn dieser Einstellung. Bitte unterscheide auch "Froxlor System Hostname" und "Kunden Domain". Für weitere Hilfe ist notwendig zu wissen, was nun "meine-domain.tld" aus deinen Beispielen ist! ja erneut vorhanden, doch muss die Inhaberschaft ja irgendwie bestätigt werden. Gibt es da einen Lösungsansatz? ja, recht simpel, sofern "meine-domain.tld" dein System-Hostname ist, editiere die Datei /etc/aliases und ergänze sie um folgende Einträge (sofern nicht vorhanden): abuse: root postmaster: root Stelle ebenso sicher, dass der Eintrag root: auf eine gültige, abrufbare E-Mail Adresse zeigt (kann auch extern sein)
  26. Hallo nochmal, mit dem alternativen Namen im Froxlor vHost gab es keine weiteren Probleme. Nun das Problem, wie kann ich mir ein E-Mail Konto erstellen, wenn die Domain meine-domain.tld als "Nicht E-Mail Domain" deklariert ist. Viele Anbieter wollen die Inhaberschaft des Mailservers überprüfen und senden dann an abuse@meine-domain.tld oder postmaster@meine-domain.tld. Somit ist das Problem ja erneut vorhanden, doch muss die Inhaberschaft ja irgendwie bestätigt werden. Gibt es da einen Lösungsansatz?
  1. Load more activity


×
×
  • Create New...