Jump to content
Froxlor Forum

All Activity

This stream auto-updates     

  1. Yesterday
  2. as said, the initial setup should've filled that already. Port is of course 80 or 443 (ssl). The other settings are self-explaining
  3. Last week
  4. I have added this to the file /etc/my.cnf in mysql configuration, to get rid off strict mode. [mysqld] sql_mode="TRADITIONAL,NO_AUTO_CREATE_USER" What should I put in to the Froxlor IP and Ports now (it's empty and needs something)? Yes, the IP I know since it should be the server IP, but which port and what about the other settings in it? Is there any sample screenshot of a working installation?
  5. Redirect Schleife

    # 35_froxlor_ssl_vhost_fslubu.de.conf # Created 19.11.2017 13:50 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 176.95.26.116:443 ssl http2; server_name fslubu.de www.fslubu.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/fslubu.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/fslubu.de.key; add_header Strict-Transport-Security "max-age=31536000; includeSubDomains"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/fslubu.de.crt; include /etc/nginx/acme.conf; access_log /var/customers/logs/fslubu-access.log combined; error_log /var/customers/logs/fslubu-error.log error; root /var/customers/webs/fslubu/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/fslubu/webalizer/fslubu.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/froxlor-htpasswd/1-1ad75d199e8bb75a3be5c0e329e1e62c.htpasswd; } location ~ ^(.+?\.php)(/.*)?$ { try_files /238d1a353f03f784db25c044036ad58a.htm @php; } location @php { try_files $1 = 404; } location /webalizer { alias /var/customers/webs/fslubu/webalizer/fslubu.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/froxlor-htpasswd/1-1ad75d199e8bb75a3be5c0e329e1e62c.htpasswd; } location ~ ^(.+?\.php)(/.*)?$ { try_files /238d1a353f03f784db25c044036ad58a.htm @php; } location @php { try_files $1 = 404; include /etc/nginx/fastcgi_params; fastcgi_split_path_info ^(.+\.php)(/.+)\$; fastcgi_param SCRIPT_FILENAME $document_root$1; fastcgi_param PATH_INFO $2; fastcgi_param HTTPS on; fastcgi_pass unix:/var/run/fslubu-fslubu.de-php-fpm.socket; fastcgi_index index.php; } } # 35_froxlor_normal_vhost_fslubu.de.conf # Created 19.11.2017 13:50 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 176.95.26.116:80; server_name fslubu.de www.fslubu.de; include /etc/nginx/acme.conf; if ($request_uri !~ ^/.well-known/acme-challenge/\w+$) { return 301 https://$host$request_uri; } } wget www.fslubu.de URL transformed to HTTPS due to an HSTS policy --2017-11-19 13:59:03-- https://www.fslubu.de/ Auflösen des Hostnamens www.fslubu.de (www.fslubu.de)… 176.95.26.116 Verbindungsaufbau zu www.fslubu.de (www.fslubu.de)|176.95.26.116|:443 … verbunden. HTTP-Anforderung gesendet, auf Antwort wird gewartet … 301 Moved Permanently Platz: https://fslubu.de/ [folgend] --2017-11-19 13:59:03-- https://fslubu.de/ Auflösen des Hostnamens fslubu.de (fslubu.de)… 176.95.26.116 Verbindungsaufbau zu fslubu.de (fslubu.de)|176.95.26.116|:443 … verbunden. HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK Länge: nicht spezifiziert [text/html] Wird in »index.html.5« gespeichert. Ich habe jetzt noch mal die Weiterleitung der Domain www.fslubu.de auf dem Nameserver deaktiviert. https://fslubu.de funktioniert korrekt. Wenn ich www.fslubu.de eingebe, wird wieder zurück auf fslubu.de umgeleitet. Warum? EDIT: Die Ursache war in Wordpress zu finden. Dort habe ich noch das www ergänzt.
  6. Redirect Schleife

    Zeig mal pls deine vhost conf und liste mal auf wie du deine certs erstellt hast.
  7. Ich habe das gleiche auf einem anderen Server getestet. Bis auf Hardware, Kernel und MPM-ITK anstatt PHP-FPM sind die Pakete/USE-Flags identisch, es wurden auch die selben Pakete geupdated. Dort klappt alles einwandfrei. Auf diesem hier habe ich jetzt mysql aus der nsswitch.conf rausgenommen, damit startet der MySQL wieder. Allerdings kann ich es danach auch nicht mehr aktivieren Edit: hmmm das Problem tritt nur bei mysql restart auf. Mit stop und start klappts auch mit richtiger nsswitch.conf
  8. Redirect Schleife

    Hallo, ich habe die Domain fslubu.de extern gehostet und per 301 auf http://www.fslubu.de umgeleitet. Im Froxlor habe ich als Domain mit https & letsencrypt www.fslubu.de angelegt. 1. http://fslubu.de wird auf http://www.fslubu.de -> funktioniert korrekt 2. dann wird auf https://www.fslubu.de umgeleitet -> auch korrekt, da dies so eingestellt ist 3. dann wird auf https://fslubu.de umgeleitet -> da keine Domain fslubu.de in froxlor definiert ist, kommt es zu der Fehlermeldung. Wer kann mir sagen, warum wieder zurück auf fslubu.de umgeleitet wird? Falls Infos fehlen, kann ich die gerne nachliefern. wget fslubu.de --2017-11-18 12:04:41-- http://fslubu.de/ Auflösen des Hostnamens fslubu.de (fslubu.de)… 85.114.133.20 Verbindungsaufbau zu fslubu.de (fslubu.de)|85.114.133.20|:80 … verbunden. HTTP-Anforderung gesendet, auf Antwort wird gewartet … 301 Moved Permanently Platz: http://www.fslubu.de [folgend] --2017-11-18 12:04:41-- http://www.fslubu.de/ Auflösen des Hostnamens www.fslubu.de (www.fslubu.de)… 176.95.26.116 Verbindungsaufbau zu www.fslubu.de (www.fslubu.de)|176.95.26.116|:80 … verbunden. HTTP-Anforderung gesendet, auf Antwort wird gewartet … 301 Moved Permanently Platz: https://www.fslubu.de/ [folgend] --2017-11-18 12:04:41-- https://www.fslubu.de/ Verbindungsaufbau zu www.fslubu.de (www.fslubu.de)|176.95.26.116|:443 … verbunden. HTTP-Anforderung gesendet, auf Antwort wird gewartet … 301 Moved Permanently Platz: https://fslubu.de/ [folgend] --2017-11-18 12:04:42-- https://fslubu.de/ Verbindungsaufbau zu fslubu.de (fslubu.de)|85.114.133.20|:443 … verbunden. FEHLER: Dem Zertifikat von »fslubu.de« wird nicht vertraut. FEHLER: Das Zertifikat von »»fslubu.de«« wurde von einem unbekannten Austeller herausgegeben. FEHLER: Das Zertifikat von »»fslubu.de«« wurde mit einem unsicheren Algorithmus signiert. FEHLER: Das Zertifikat von »fslubu.de« ist abgelaufen. Das ausgestellte Zertifikat ist nicht mehr gültig. Der Zertifikat-Eigentümer passt nicht zum Hostname »fslubu.de«. Vielen Dank und viele Grüße Christian
  9. Wenn du es zu 100% nach dem Howto gemacht hast, sollte dies nicht auftreten mit MariaDB, da bei der Ubu Anleitung die 10.2 drin ist. Das mit dem error 502 passiert eigentlich nur, wenn man vergisst den Froxlor ordner die rechte vorher von www-data zu geben, dann passiert dies. Habe die zwei anmerkungen ins Howto aufgenommen, danke.
  10. Guten Abend, mal wieder ein Problem welches nichts mit froxlor zu tun hat. Ich habe vorhin das System geupdated. Es wurde nichts an den confs verändert, nur einige updates emerged. Mysql wurde von 5.3.36 auf 5.3.38 geupdated, glibc und gcc wurden nur automatisch reemerged. Problem: MySQL lässt sich nicht mehr restarten und wirft diese Meldung aus: MySQL Meldung nsswitch.conf hier auch noch mal Der Server wurde erst gestern vor dem update komplett ohne Probleme restartet. Das downgrade auf die ursprungliche Version 5.3.36 hat das selbe Problem. Der ursprüngliche MySQL läuft allerdings noch und wurde nicht durch das restart-script beendet Hat jemand eine Idee wie ich das beheben kann oder warum das passiert? System ist Gentoo Base System release 2.4.1 Grüße, kutte128
  11. @irisdina: Danke für deine TOP Anleitung. Ich habe das Howto unter Ubuntu 17.10 (Artful) installiert. Ich habe noch folgende Anmerkungen: 2a. MariaDB 10.1 Workround (Optional) sollte nicht nur Debian, sondern auch Ubuntu 17.10 stehen, da ich dies auch brauchte. PHP-FPM activate 2. libnss-extrausers install (hier fehlt apt) sudo install nscd libnss-extrausers Nach der Konfiguration von PHP-FPM nach der Anleitung kam immer der Gateway Fehler 502. Das konnte ich mit folgendem Befehl lösen: usermod -a -G www-data froxlorlocal
  12. lighttpd mod_openssl warnung

    ist gefixt: https://git.io/vFSmA
  13. lighttpd mod_openssl warnung

    vielen lieben Dank für die schnelle Antwort und Lösung, funktioniert super.
  14. lighttpd mod_openssl warnung

    ich nehme an, da hat wohl lighttpd sein verhalten geändert. Versuch mal folgenden Patch und sag mir obs damit klappt: diff --git a/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php b/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php index d1ba5d0..a2d5258 100644 --- a/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php +++ b/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php @@ -535,7 +535,8 @@ class lighttpd extends HttpConfigBase if ($domain['ssl_cert_file'] != '') { - $ssl_settings .= 'ssl.engine = "enable"' . "\n"; + // ssl.engine only necessary once in the ip/port vhost (SERVER['socket'] condition) + //$ssl_settings .= 'ssl.engine = "enable"' . "\n"; $ssl_settings .= 'ssl.use-compression = "disable"' . "\n"; $ssl_settings .= 'ssl.use-sslv2 = "disable"' . "\n"; $ssl_settings .= 'ssl.use-sslv3 = "disable"' . "\n";
  15. lighttpd mod_openssl warnung

    Hallo, ich verwende froxlor 0.9.38.7 mit lighttpd 1.4.48-1 und mod_openssl. In den vhost (/etc/lighttpd/conf-enabled/vhosts/) configs schreibt froxlor bei aktiviertem SSL: $HTTP["host"] =~ "^domain\.de$" { server.document-root = "/var/customers/webs/test/" $HTTP["url"] =~ "^/webalizer/" { auth.backend = "htpasswd" auth.backend.htpasswd.userfile = "/etc/lighttpd/froxlor-htpasswd/1-476459152e5e9e538d6324fe3ede113b.htpasswd" auth.require = ( "/webalizer/" => ( "method" => "basic", "realm" => "Restricted Area", "require" => "valid-user" ) ) } ssl.engine = "enable" ssl.use-compression = "disable" ssl.use-sslv2 = "disable" ssl.use-sslv3 = "disable" ssl.cipher-list = "ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128" ssl.honor-cipher-order = "enable" ssl.pemfile = "/etc/ssl/froxlor-custom/domain.de.crt" ssl.ca-file = "/etc/ssl/froxlor-custom/domain.de_CA.pem" $HTTP["scheme"] == "https" { setenv.add-response-header = ( "Strict-Transport-Security" => "max-age=0") } accesslog.filename = "/var/customers/logs/test-access.log" } Das scheint soweit auch zu funktionieren. Beim Starten von lighttpd kommt aber folgenden Meldung: lighttpd-angel[28248]: 2017-11-17 12:56:44: (mod_openssl.c.1064) ssl.engine is valid only in global scope or $SERVER["socket"] condition entferne ich die Zeile ssl.engine = "enable" kommt die Meldung nicht mehr. Aber froxlor schreibt die Zeile natürlich wieder rein. Die Frage, mach ich da was falsch oder ist das ein Fehler von froxlor?
  16. Mailsettings autodiscover

    Danke, funktioniert!
  17. Mailsettings autodiscover

    Alias "/.well-known/autoconfig/mail/" "/var/www/autoconfig/" Alias "/.mz-autoconf/" "/var/www/autoconfig/" Alias "/autodiscover/" "/var/www/autoconfig/" und dann neben der config-v1.1.xml noch eine autodiscover.xml: <?xml version="1.0" encoding="UTF-8"?> <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006"> <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a"> <Account> <AccountType>email</AccountType> <Action>settings</Action> <Protocol> <Type>POP3</Type> <Server>dein.mail.fqdn</Server> <Port>995</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> </Protocol> <Protocol> <Type>IMAP</Type> <Server>dein.mail.fqdn</Server> <Port>993</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> </Protocol> <Protocol> <Type>SMTP</Type> <Server>dein.mail.fqdn</Server> <Port>587</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> <UsePOPAuth>off</UsePOPAuth> <SMTPLast>off</SMTPLast> </Protocol> </Account> </Response> </Autodiscover>
  18. Mailsettings autodiscover

    Morgen, ja, genau so läuft autoconfig schon seit nem halben Jahr. Nur leider intressieren sich MS-Clients und viele andere Apps nicht dafür, sondern setzen autodiscover mit SSL voraus. Autodiscover funktioniert im Prinzip genauso, nur passt dann das Zert nicht zu den Sub-Domains. Weiterleitung auf die richtige SSL Domain machen auch nicht alle Apps mit. Soweit ich verstanden habe, wird autodiscover.domain.tld verlangt und domain.tld/autodiscover funktioniert nicht. Mit SRV Eintrag funktioniert schon mal Outlook, Windows 10 Mail und eM Client einwandfrei. Wenn der Apfel auch mit macht, sollte das doch eine schöne Lösung sein, oder? Grüße, kutte128
  19. Mailsettings autodiscover

    erstell doch einfach nen globalen alias (wie für let's encrypt). Für thunderbird z.B. und in /var/www/autconfig/ dann die config-v1.1.xml mit entsprechendem inhalt, z.B.
  20. Mailsettings autodiscover

    Hi, nutzt irgendwer autodiscover für die Mail-Settings? Autoconfig läuft schon seit ner ganzen Weile, ich würde auch gern autodiscovery anbieten. Grundsätzlich klappt das einwandfrei. Problem ist nur, dass SSL vorrausgesetzt wird und einige Clients dann eine hässliche Fehlermeldung rauswerfen bevor (falls) noch unter http:// gesucht wird. Meine Lösung ist jetzt, dass ich eine autodiscover-Subdomain mit LetsEncrypt erstelle die immer auf den gleichen DocRoot mit der xml zeigt. Gibt es noch eine elegantere Lösung ohne jedesmal eine extra subdomain mit LE-Zert anlegen zu müssen? Edit: mit SRV Eintrag scheint es zu klappen. Gibt es Erfahrungen mit den verschiedenen Clients? Grüße, kutte128
  21. Mal die Fehlermeldung/Nummer gegooglet? Das ist eine andere als der Thread-Ersteller nennt...siehe: https://askubuntu.com/questions/763336/cannot-enter-phpmyadmin-as-root-mysql-5-7/763359#763359
  22. proftpd -> debug -> logs, sonst kann man schwer was sagen
  23. Wiki = vielen Dank... aber leider nicht so umfangreich, wie ich mir das erhofft hätte ;-) Pfade = LOL.. Danke... ok... da "dachte" ich Froxlor macht das... Asche auf mein Haupt ;-) ... FTP = hmmm.. Ich hab die Konfiguration unter admin - system - konfiguration - Debian Jessie - FTP-Server - ProFTPd nochmals komplett durchgegangen. Bei der /etc/proftpd/sql.conf ist mir aufgefallen, das in der Mitte der Einstellungen noch das MYSQL-PASSWORD eingegeben werden muss. # Connection SQLConnectInfo froxlor@127.0.0.1 froxlor MYSQL_PASSWORD Dies hatte ich bei der ersten Installation vermutlich nicht gemacht. Doch leider hat dies nichts geändert. Ich habe einen neuen FTP-User angelegt, dieser wurde auch in die Datenbank eingetragen - ABER - der user wird wegen Premission Denied abgelehnt. Wo könnte den noch mein Fehler liegen? Vielen Dank Boergi
  24. Ich habe gerade das gleiche Problem nur ist bei mir die Lösung nicht "localhost". A database error occurred SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost' Gibt es sonst noch Lösungsansätze? Passwort stimmt natürlich und über die Konsole kann ich auf die DB als root damit zugreifen. <?php //automatically generated userdata.inc.php for Froxlor $sql['host']='127.0.0.1'; $sql['user']='froxlor'; $sql['password']='xxxxx1'; $sql['db']='froxlor'; $sql_root[0]['caption']='Default'; $sql_root[0]['host']='localhost'; $sql_root[0]['user']='root'; $sql_root[0]['password']='xxxx2'; ?> Danke
  25. https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball Da erstellt froxlor auch nix...du hinterlegst da nur die URL zu der App die DU selbst irgendwo installiert/konfiguriert hast Permissions sind korrekt so. FTP Dienst korrekt konfiguriert (mysql verbindung!)? Wüsste da von keinem Problem das Kunden ihre Daten nicht per FTP bearbeiten können...
  26. Leider hab ich jetzt noch weitere Probleme. Sicherlich habe ich irgendwo falsche Einstellungen gemacht. (Ich hab diese zwar mit einer funktionierenden Froxlor installation verglichen... der der Fehler liegt vermutlich an den Tomaten auf meinen Augen). Leider hab ich auch die Wikis für die Einstellungen nicht gefunden. Die alten Urls sind ja nicht mehr gültig https://redmine.froxlor.org/projects/froxlor/wiki/InstallationTarball#4-Settings-before-configuration https://redmine.froxlor.org/projects/froxlor/wiki/InstallationTarball#5-Configuration-of-services und auf github finde ich diese Wikis nicht. So - nun zu meinen Problem. 1. die im Admin - System - Einstellungen - Panel Einstellungen angegebenen Pfade werden nicht erstellt / sind nicht vorhanden. Auch die jeweiligen Apps sind nicht erreichbar. PhpMyAdmin: http://meinserver.de/phpmyadmin/ Webmail: http://meinserver.de/webmail WebFTP: http://meinserver.de/filemanager 2. die jeweiligen Domain-Verzeichnisse werden richtig angelegt /var/customers/webs/KUNDE/DOMAIN Diese sind aber nicht per FTP von dem Kunden erreichbar = Premission denied !!! Diese Verzeichnisse haben immer nur den Besitzer 10003 und die Gruppe 10003 Könnt Ihr mir auf die Sprünge helfen? Vielen Dank Boergi
  27. Probleme mit Let's Encrypt

    Bitte zunächst mit der aktullen git-version testen
  1. Load more activity


×