Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Exploit

Nach Update l?uft nichts mehr

Question

Hallo,

 

Nachdem ich "apt-get update" und apt-get upgrade" gemacht habe bekam ich erst mal die Meldung:

W: GPG error: http://debian.froxlor.org lenny Release: The following were invalid: KEYEXPIRED 1296511029

Soweit ein bekanntes Problem, aber nach dem Upgrade von Froxler funktionierte erst eine Seite nicht mehr und gab nur noch eine 500. Ein paar Stunden sp?ter gaben Alle Seiten eine 500.

 

Im Error Log steht seitdem:

[Mon Mar 14 02:39:33 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Mon Mar 14 02:39:33 2011] [error] [client xx.xx.xx.xx] Premature end of script headers: index.php

 

Apache neu starten endete so:

server3201:~# /etc/init.d/apache2 start
Starting web server: apache2Syntax error on line 13 of /etc/apache2/sites-enabled/10_froxlor_ipandport_xx.xx.xx.xx.8443.conf:
can't get fastcgi file info: /var/www/php-fcgi-scripts/froxlor.panel/xxxxx.net/php-fcgi-starter(/var/www/php-fcgi-scripts/froxlor.panel/xxxxx.net/php-fcgi-starter), errno: 2

 

In der "" ist kein Fehler zu sehen, ausser: "FCGIWrapper /var/www/php-fcgi-scripts/froxlor.panel/..." (indertat line 13) Der Ordner: "/var/www/php-fcgi-scripts" ist volkommen leer!!! Das kan doch nicht richtig sein, oder? Wie kriege ich das wieder hin?

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

Nur Froxlor aktualisieren macht deine Configs nicht kaputt. Was wurde noch aktualisiert bzw. was hast du umgestellt?

Share this post


Link to post
Share on other sites

Exim4 habe ich neu installiert, aber da sehe ich keinerlei Zusammenhang. Das Update habe ich nat?rlich als root gemacht, kann es sein das dabei irgendwelche Rechte auf Root gestellt wurden, wodurch der Webserver den Zugriff verloren hat? Die ganzen Webseiten stehen noch unter den entsprechenden FTP-Usern und Froxlor l?uft unter froxlorlocal.

 

Beim ersten Aufruf der Froxlorseite wurde ich gefragt ob ich irgenwas neues mit FastCGI verwenden wollte, keine Ahnung was das sollte. Habe dann mal ja gew?hlt, war das ein Fehler?

Share this post


Link to post
Share on other sites

warum schreiben wir eigentlich gro? dran "bitte unbedingt lesen" wenn es keiner macht?

 

Kurz: JA, das war der Fehler

Share this post


Link to post
Share on other sites

Was sollte ich unbedingt lesen? Habs dann wohl leider ?bersehen. Wo stand es denn, im Installer?

 

Was mus ich dazu lesen und wie kann ich den Fehler beheben?

Share this post


Link to post
Share on other sites
Beim ersten Aufruf der Froxlorseite wurde ich gefragt ob ich irgenwas neues mit FastCGI verwenden wollte, keine Ahnung was das sollte. Habe dann mal ja gew?hlt, war das ein Fehler?

 

Auf der Seite auf der du die Aktualisierung startest sind Hinweise nicht umsonst fett, rot und sonst wie eindeutig markiert. Unten ist sogar eine Checkbox eingebaut.

 

Nicht mal mit viel Phantasie kann ich mir vorstellen dass du den Text nicht gesehen hast. In der Froxlor Demo kannst du dir die Seite nochmal ansehen.

 

M.W. n. musst du die gemachten Einstellungen in der DB r?ckg?ngig machen.

Share this post


Link to post
Share on other sites

Mysql-Verbindung auf der Shell ?ffnen

 

# mysql -u root -p[passwort] [datenbankname]

 

und folgende Query ausf?hren:

 

mysql> UPDATE `panel_settings` SET `value`='0' WHERE `settinggroup`='phpfpm' AND `varname`='enabled';

Share this post


Link to post
Share on other sites

Danke, aber kann mir mal einer sagen welcher Text mit bitte lesen gemeint ist?

 

Es war nachts 2 Uhr als ich das Upgrade gemacht habe. Eigentlich eine unkomplizierte und einfache angelegenheit, war da wohl nicht mehr ganz wach und wurde dann ?berfallen mit diesen Einstellungen.

Share this post


Link to post
Share on other sites

Danke, aber kann mir mal einer sagen welcher Text mit bitte lesen gemeint ist?

 

Es war nachts 2 Uhr als ich das Upgrade gemacht habe. Eigentlich eine unkomplizierte und einfache angelegenheit, war da wohl nicht mehr ganz wach und wurde dann ?berfallen mit diesen Einstellungen.

 

1) dir wurde 2x gesagt wo der text stand, also nein, ich sags nicht nochmal

2) mach halt keine updates um 2 uhr nachts wenn du dir dadurch die kiste zerschie?t

3) die standard-einstellung, auch beim update, f?r die Nutzung von PHP-FPM ist 'Nein', also hast du wohl in Trance 'Ja' ausgew?hlt

 

(wenn es denn die PHP-FPM einstellung war, denn du nennst ja nichtmal Froxlor versionen, von welcher auf welche Aktualisiert wurde etc.

Share this post


Link to post
Share on other sites

Vielen Dank f?r die superschnelle Hilfe,

 

Habe die query ausgef?hrt mit folgendem Ergebnis:

Query OK, 1 row affected (0.00 sec)
Rows matched: 1  Changed: 1  Warnings: 0

 

Nun mus ich den Apache server noch neu starten. Am einfachsten w?re es wohl den FastCGI-Starter f?r Froxlor wieder her zu stellen.

Wo kriege ich den jetzt so schnel wieder her, mit ln?

 

Die anderen Eintr?ge aus "sites-enabled" habe ich entfernt, da diese ja wieder von Froxlor wiederhergestellt werden.

Share this post


Link to post
Share on other sites

Nun mus ich den Apache server noch neu starten.

 

Nein, macht der Cronjob f?r dich

 

Am einfachsten w?re es wohl den FastCGI-Starter f?r Froxlor wieder her zu stellen.

Wo kriege ich den jetzt so schnel wieder her, mit ln?

 

Macht der Cronjob f?r dich

 

Die anderen Eintr?ge aus "sites-enabled" habe ich entfernt, da diese ja wieder von Froxlor wiederhergestellt werden.

 

Richtig, macht der Cronjob f?r dich.

Share this post


Link to post
Share on other sites

1) dir wurde 2x gesagt wo der text stand, also nein, ich sags nicht nochmal

2) mach halt keine updates um 2 uhr nachts wenn du dir dadurch die kiste zerschie?t

3) die standard-einstellung, auch beim update, f?r die Nutzung von PHP-FPM ist 'Nein', also hast du wohl in Trance 'Ja' ausgew?hlt

 

(wenn es denn die PHP-FPM einstellung war, denn du nennst ja nichtmal Froxlor versionen, von welcher auf welche Aktualisiert wurde etc.

Zu 1:

Toll das ich beim updaten darauf hingewiesen wurde, aber das habe ich nicht mehr zur Hand und ich weis immernoch nicht welchen Text ich bitte lesen soll.

 

Zu 2:

Naja bisher hatte ich nie Probleme damit und ging alles automatisch, aber sicherlich hast Du recht das mann sich nicht darauf verlassen sollte.

 

Zu 3:

Wie gesagt habe ich indertat Ja gew?hlt. Dachte das Froxlor die notwendigen Anpassungen schon machen w?rde.

 

B) Weis ich nicht mehr genau, die vorherige Version war etwa 2-3 Monate alt.

Share this post


Link to post
Share on other sites
Macht der Cronjob f?r dich
Ok, dann m?sste ja gleich alles wieder laufen. Jetzt mus ich erst mal weg. Nachher sage ich euch bescheid ob es geklappt hat.

 

Vielen Dank f?r die schnelle Hilfe.

Share this post


Link to post
Share on other sites

Komisch da passiert garnichts "/etc/apache2/sites-enabled" und "/var/www/php-fcgi-scripts" Bleiben leer, auch nach einem: "/usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php" ?ndert sich nihts.

Share this post


Link to post
Share on other sites

Mysql-Verbindung auf der Shell ?ffnen

 

# mysql -u root -p[passwort] [datenbankname]

 

und folgende Query ausf?hren:

 

mysql> INSERT INTO `panel_tasks` SET `type`='1';

 

Dann Cronjob nochmal starten

Share this post


Link to post
Share on other sites

Ok nochmals danke, das hat funktioniert, Die Dateien wurden alle wieder angelegt. Apache musste ich dan aber noch manuell starten, der dann aber sofort lief.

 

Seit dem Update nervt mich allerdings mein Browser, bei jedem Seitenaufruf innerhalb des Froxlor-Admins mit https, mit der Frage ob auch unsichere elemente ?bertragen werden sollen.

 

Mich wundert auch der Inhalt einiger .conf dateien in "/etc/apache2/sites-enabled"

 

Diese sehen so aus:

# 10_froxlor_ipandport_xx.xx.xx.xx.443.conf
# Created 15.03.2011 17:30
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

Listen xx.xx.xx.xx:443
NameVirtualHost xx.xx.xx.xx:443
<VirtualHost xx.xx.xx.xx:443>
DocumentRoot "/var/customers/webs/salma/www/admin/"
ServerName xxxxx.net
 SuexecUserGroup "froxlorlocal" "froxlorlocal"
 <Directory "/var/customers/webs/salma/www/admin/">
   AddHandler fcgid-script .php
   FCGIWrapper /var/www/php-fcgi-scripts/froxlor.panel/xxxxx.net/php-fcgi-starter .php
   Options +ExecCGI
   Order allow,deny
   allow from all
 </Directory>
SSLEngine On
SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
</VirtualHost>

In diesem Beispiel sollten aufrufe unter dieser IP dem User salma zugewiesen werden dessen Ordner ich auch eingestellt habe und nicht froxlorlocal. Domains kann ich einem User zuweisen, IP's aber nicht. Im Admin scheint diese Einstellung zu fehlen.

Share this post


Link to post
Share on other sites

In diesem Beispiel sollten aufrufe unter dieser IP dem User salma zugewiesen werden dessen Ordner ich auch eingestellt habe und nicht froxlorlocal. Domains kann ich einem User zuweisen, IP's aber nicht. Im Admin scheint diese Einstellung zu fehlen.

 

AFAIK kannst du einer Domain eine IP-Adresse (die du auf der Seite "IPs und Ports" eingetragen hast) zuweisen.

 

 

Hast du die oben genannte IP als Standard-IP f?r das Froxlor Panel gesetzt [Einstellungen => Systemeinstellungen]?

Share this post


Link to post
Share on other sites

AFAIK kannst du einer Domain eine IP-Adresse (die du auf der Seite "IPs und Ports" eingetragen hast) zuweisen.

Das ist zwar richtig und funktioniert auch, aber beim Aufruf der IP soll der user zum Backend seiner Seiten gelangen (nicht Froxlor), was ich auch sicher ?ndern k?nnte.

 

Der Server hat mehrere IP's und nun soll der aufruf der IP im Browser zur Seite des Users f?hren. Auch das funktioniert, aber eben nur unter froxlorlocal. Der IP-Eintrag mus ja schliesslich gemacht werden, bevor ich die IP f?r eine Domain ausw?hlen kann. Somit kann ich aber keine direkte IP einem User Zuweisen.

 

Wenn ich etwas Zeit habe werde ich mal testen inwiefern es auch ein SicherheitsProblem darstellt das froxlorlocal offensichtlich auf die Dateien eines anderen Users Zugreifen kann. Theoretisch kann ein User dann doch auch den PHP-Source eines anderen Users aufrufen, oder? Die Rechte stellt doch keiner auf 600. Aber das ist wieder ein komplett anderes Thema.

Share this post


Link to post
Share on other sites

Das ist zwar richtig und funktioniert auch, aber beim Aufruf der IP soll der user zum Backend seiner Seiten gelangen (nicht Froxlor), was ich auch sicher ?ndern k?nnte.

 

Ja, wenn du lesen w?rdest, h?ttest du das schon l?ngst gefunden. Besch?ftigst du dich eigentlich auch mit den Scripts die du nutzt? Oder hoffst du einfach darauf, dass alle hier im Forum dir das schon machen werden?

 

Admin-Panel -> IPs und Ports -> Neu/Bearbeiten -> Custom docroot (empty = point to Froxlor)

 

Der Server hat mehrere IP's und nun soll der aufruf der IP im Browser zur Seite des Users f?hren. Auch das funktioniert, aber eben nur unter froxlorlocal. Der IP-Eintrag mus ja schliesslich gemacht werden, bevor ich die IP f?r eine Domain ausw?hlen kann. Somit kann ich aber keine direkte IP einem User Zuweisen.

 

Das ist korrekt, Froxlor sieht IP's halt nicht pro username an. Man verwendet im normalfall nicht die IP direkt.

 

Wenn ich etwas Zeit habe werde ich mal testen inwiefern es auch ein SicherheitsProblem darstellt das froxlorlocal offensichtlich auf die Dateien eines anderen Users Zugreifen kann. Theoretisch kann ein User dann doch auch den PHP-Source eines anderen Users aufrufen, oder? Die Rechte stellt doch keiner auf 600. Aber das ist wieder ein komplett anderes Thema.

 

...stell bitte nicht so vermutungen hier in den Raum von wegen "Sicherheitsproblem" bevor du das nicht nachweisen kannst. Ich gehe jetzt lieber nicht weiter darauf ein

Share this post


Link to post
Share on other sites

×
×
  • Create New...