Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Raymond

Awstats problem

Question

I noticed that since my install the user root was receiving a lot of mail, when i took a look at it, i noticed that the amails were generated by cron and involved awstats.

 

Subject: Cron <www-data@darktower> [ -x /usr/share/awstats/tools/update.sh ] && /usr/share/awstats/tools/update.sh

and they are filled with the following:

 

Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.

Setup ('/etc/awstats/awstats.model.conf' file, web server or permissions) may be wrong.

Check config file, permissions and AWStats documentation (in 'docs' directory).

Error: Couldn't open config file "awstats.awstats.conf" nor "awstats.conf" after searching in path "/usr/lib/cgi-bin,/etc/awstats,/usr/local/etc/awstats,/etc,/etc/opt/awstats": No such file or directory

 

- Did you use correct config parameter ?

Example: If your config file is awstats.mysite.conf, use -config=mysite

- Did you create your config file 'awstats.awstats.conf' ?

If not, you can run "awstats_configure.pl"

from command line, or create it manually.

 

Check config file, permissions and AWStats documentation (in 'docs' directory).

 

Can someone help me with this? I tryed to change the permissions but noting helped.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

Can someone help me with this? I tryed to change the permissions but noting helped.

 

1) did you change the settings in 'Statistics' according to your system? (Paths, configfile-names, etc.)

2) did you setup awstats like Froxlor shows in the 'Configuration' wizard for your system?

Share this post


Link to post
Share on other sites

1) did you change the settings in 'Statistics' according to your system? (Paths, configfile-names, etc.)

2) did you setup awstats like Froxlor shows in the 'Configuration' wizard for your system?

 

Yes i did both, just checked it, but still the mails arrive every 10 minutes :S

Anny other solution, or the need for some extra info (If so, what do you need to know?

Share this post


Link to post
Share on other sites

ehm, every 10 minutes? Awstats is only called once a day, maybe you have some other cron for awstats that runs besides froxlor's cronjob?

Share this post


Link to post
Share on other sites

ehm, every 10 minutes? Awstats is only called once a day, maybe you have some other cron for awstats that runs besides froxlor's cronjob?

 

Thanks, i looked into it, and the problem was the default cronjob from awstats (wich installed with the apt-get install awstats) in /etc/cron.d/

maybe add an entry in the settings for Debian to remove it.

Share this post


Link to post
Share on other sites

Thanks, i looked into it, and the problem was the default cronjob from awstats (wich installed with the apt-get install awstats) in /etc/cron.d/

maybe add an entry in the settings for Debian to remove it.

 

Yes, debian has a default awstats cronjob which should be disabled in most installs of froxlor. The whole awstats setup is a bit critical. Anything can break it, even if everything is set up correctly logrotate could break everything (but this covered in the wiki).

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.





×
×
  • Create New...