Jump to content
Froxlor Forum
  • 0

SOLVED: Installation script, "hangs".


Knight

Question

Board,

 

I can't seem to get Froxlor, or SysCP to install. For some reason every time I attempt to install, I go the root, http://<ip address>/froxlor/ and get the message saying I need to configure froxlor, when I go to this page, I get the configuration page, however, the configuration page doesn't completely load? Here is the HTML for it:

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type" />
<link rel="stylesheet" href="../templates/main.css" type="text/css" />
<title>Froxlor</title>
</head>
<body style="margin: 0; padding: 0;" onload="document.loginform.loginname.focus()">
	<!--
		We request you retain the full copyright notice below including the link to www.froxlor.org.
		This not only gives respect to the large amount of time given freely by the developers
		but also helps build interest, traffic and use of Froxlor. If you refuse
		to include even this then support on our forums may be affected.
		The Froxlor Team : 2009-2010
	// -->
	<!--
		Templates based on work by Luca Piona (info@havanastudio.ch) and Luca Longinotti (chtekk@gentoo.org)
	// -->

	<table cellspacing="0" cellpadding="0" border="0" width="100%">
		<tr>
			<td width="800"><img src="../images/header.gif" width="800" height="90" alt="" /></td>
			<td class="header">?</td>
		</tr>
	</table>
	<table cellspacing="0" cellpadding="0" border="0" width="100%">
		<tr>
			<td valign="top" bgcolor="#FFFFFF">

			<br />
			<br />
<form action="/froxlor/install/install.php" method="get">
	<table cellpadding="5" cellspacing="4" border="0" align="center" class="maintable_40">
		<tr>
			<td class="maintitle" colspan="2"><b><img src="../images/title.gif" alt="" />?Welcome to Froxlor Installation</b></td>
		</tr>
		<tr>

			<td class="main_field_name" colspan="2">Thank you for choosing Froxlor. Please fill out the following fields with the required information to start the installation.<br /><b>Attention:</b> If the database you chose for Froxlor already exists on your System, it will be erased with all containing data!</td>
		</tr>
		<tr>
			<td class="main_field_name">Installation - Language: </td>
			<td class="main_field_display" nowrap="nowrap">
				<select name="language" class="dropdown_noborder">

					<option value="german"  >Deutsch</option>
					<option value="english" selected="selected" >English</option>
					<option value="french"  >Francais</option>
				</select>
			</td>
		</tr>
		<tr>

			<td class="main_field_confirm" colspan="2">
				<input class="bottom" type="submit" name="chooselang" value="Go" />
			</td>
		</tr>
	</table>
</form>
<br />
<form action="/froxlor/install/install.php" method="post">
	<table cellpadding="5" cellspacing="4" border="0" align="center" class="maintable_40">

		<tr>
			<td class="maintitle" colspan="2"><b><img src="../images/title.gif" alt="" />?Database</b></td>
		</tr>
		<tr>
			<td class="main_field_name">MySQL-Hostname:</td>
			<td class="main_field_display"><input type="text" name="mysql_host" value="127.0.0.1"/></td>
		</tr>
		<tr>

			<td class="main_field_name">MySQL-Database:</td>
			<td class="main_field_display"><input type="text" name="mysql_database" value="froxlor"/></td>
		</tr>
		<tr>
			<td class="main_field_name">Username for the unprivileged MySQL-account:</td>
			<td class="main_field_display"><input type="text" name="mysql_unpriv_user" value="froxlor"/></td>
		</tr>
		<tr>

			<td class="main_field_name">Password for the unprivileged MySQL-account:</td>
			<td class="main_field_display"><input type="password" name="mysql_unpriv_pass" value=""/></td>
		</tr>
		<tr>
			<td class="main_field_name">Username for the MySQL-root-account:</td>
			<td class="main_field_display"><input type="text" name="mysql_root_user" value="root"/></td>
		</tr>
		<tr>

			<td class="main_field_name">Password for the MySQL-root-account:</td>
			<td class="main_field_display"><input type="password" name="mysql_root_pass" value=""/></td>
		</tr>
		<tr>
			<td class="maintitle" colspan="2"><b><img src="../images/title.gif" alt="" />?Administrator Account</b></td>
		</tr>
		<tr>
			<td class="main_field_name">Administrator Username:</td>

			<td class="main_field_display"><input type="text" name="admin_user" value="admin"/></td>
		</tr>
		<tr>
			<td class="main_field_name">Administrator Password:</td>
			<td class="main_field_display"><input type="password" name="admin_pass1" value=""/></td>
		</tr>
		<tr>
			<td class="main_field_name">Administrator-Password (confirm):</td>

			<td class="main_field_display"><input type="password" name="admin_pass2" value=""/></td>
		</tr>
		<tr>
			<td class="maintitle" colspan="2"><b><img src="../images/title.gif" alt="" />?Server settings</b></td>
		</tr>
		<tr>
			<td class="main_field_name">Server name (FQDN):</td>
			<td class="main_field_display"><input type="text" name="servername" value=""/></td>

		</tr>
		<tr>
			<td class="main_field_name">Server IP:</td>
			<td class="main_field_display"><input type="text" name="serverip" value="XXX.XXX.XXX.XXX"/></td>
		</tr>
		<tr>
			<td class="main_field_name">Webserver:</td>
			<td class="main_field_display"><input type="radio" name="webserver" value="apache2" checked="checked"/>Apache2?<br /><input type="radio" name="webserver" value="lighttpd" />Lighttpd</td>

		</tr>
		<tr>
			<td class="main_field_name">HTTP username:</td>
			<td class="main_field_display"><input type="text" name="httpuser" value="

 

 

It literally stops after the "httpuser" field, and doesn't complete the field! There is no "next" button generated.

 

Any ideas? (I've refreshed the page several times, restarted httpd, upgraded httpd, made sure php files are being parsed, used FireFox, and IE8.)

 

Knight.

Link to post
Share on other sites

6 answers to this question

Recommended Posts

you need the php-posix extension as the username for the webserver is being detected automatically calling posix_getpwuid(posix_getuid());

 

yum install php-posix

worked wonders.

 

Excellent! Thank you for the help.

 

Knight.

Link to post
Share on other sites

Patch for Froxlor 0.9.3 which adds check for php posix module in install.php:

 

435a436,445
>
>       if(!extension_loaded('posix'))
>       {
>           status_message('red', $lng['install']['notinstalled']);
>           $_die = true;
>       }
>       else
>       {
>           status_message('green', 'OK');
>       }

Link to post
Share on other sites

Patch for Froxlor 0.9.3 which adds check for php posix module in install.php:

 

435a436,445
>
>       if(!extension_loaded('posix'))
>       {
>           status_message('red', $lng['install']['notinstalled']);
>           $_die = true;
>       }
>       else
>       {
>           status_message('green', 'OK');
>       }

 

If you read the source code of "install.php" you would've seen that this is already in there (lines 414 to 424)

 

wonder why he didn't get the errormessage though

 

EDIT: i know why - the check comes after the first install form...*head => table*

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...