Jump to content
Froxlor Forum
  • 0

Froxlor deletes FCGI starters


DerSeppel

Question

Hi there,

 

I'm running Froxlor with FCGI support. The starter scripts are stored unter /var/www/php-fcgi-scripts. I also stored a few "hand-made" scripts for my manual configured vhosts. (i.e. the froxlor vhost)

I've been using this configuration for a while now and I never experienced any problems.

 

A few weeks apache would'nt start because all the fcgi scripts for my manual vhosts were missing. I re-created them and the problem was solved.

Yesterday they went missing again. It seems that froxlor deletes ALL scripts in the folder when it rewrites the configuration.

Is there a way to stop that?

IMHO that should be filed as a bug too.

 

Greets

 

Seppel

Link to post
Share on other sites

5 answers to this question

Recommended Posts

notabug.jpg

 

There is a note in the settings telling you that this folder is being managed by Froxlor and therefore clean once a while. If you need non-froxlor fcgi-starters, use a nother folder

Link to post
Share on other sites

There is a note in the settings telling you that this folder is being managed by Froxlor and therefore clean once a while. If you need non-froxlor fcgi-starters, use a nother folder

 

Okay, I agree. I havent noticed this note in the settings.

I even agree that I had the suspicion that this was a feature instead of a bug.

I just wonder why this just started happening a few weeks ago. Was this behavior changed recently?

 

Edit:

I'm using the german language pack with version 0.9.14.

I can't see such a note on the FCGI settings page.

 

The english version does indeed contain a warning:

NOTE: This folder's content gets deleted regulary so avoid storing data in there manually.

 

The german version DOESN'T. That might be the reason why I missed this.

So the bug is more of a translation bug.

 

Second Edit:

The placement of the warning seems to be wrong too:

 

German version:

translationbuggerman.jpg

 

English version:

translationbugenglish.jpg

 

I guess the warning in the english version should be displayed in description of the path setting.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...