Jump to content
Froxlor Forum
  • 0

Configuration problem (apache)


Ward

Question

Hello,

 

I have a problem with my froxlor apache configuration.

 

I use the domain e-volutions.be with some subdomains. I access froxlor trough froxlor.e-volutions.be. The problem is every time I change some configuration in apache using froxlor, all subdomains redirect to www.e-volutions.be. Most of the subdomains are vhost file manually created.

 

I found the following problem:

 

Every time I change something in my apache config the ServerAlias is changed to *.e-volutions.be. This causes every subdomain to redirect to www

<VirtualHost 88.*:80>

ServerName e-volutions.be

ServerAlias *.e-volutions.be

 

I fix this by changing it manually to

<VirtualHost 88.*:80>

ServerName e-volutions.be

ServerAlias www.e-volutions.be

 

Does somebody knows how I can fix this?

Link to post
Share on other sites

4 answers to this question

Recommended Posts

Please log in to the customer panel to the site:

 

(Domain)settings => 'edit' domain e-volutions.be => Create as wildcarddomain? => NO

 

Wait any minutes until the cronjob generated the config (vhost) files. Please notice: If you change anything in the vHost files manually, the cronjob reset them after any minutes (default 5) again.

 

You should read the third line in the file:

 

# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
Link to post
Share on other sites

Please log in to the customer panel to the site:

 

(Domain)settings => 'edit' domain e-volutions.be => Create as wildcarddomain? => NO

 

Wait any minutes until the cronjob generated the config (vhost) files. Please notice: If you change anything in the vHost files manually, the cronjob reset them after any minutes (default 5) again.

 

You should read the third line in the file:

 

Okay I found it. Works now! Maybe it would be better to also include this option in the admin edit domain screen?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...