Jump to content
Froxlor Forum

Ward

Members
  • Content Count

    29
  • Joined

  • Last visited

  • Days Won

    2

Ward last won the day on September 7 2011

Ward had the most liked content!

Community Reputation

-3 Poor

About Ward

  • Rank
    Froxie
  1. Okay, I think i found why it gave me the following message: bounced (mail for ***.be loops back to myself) I've seen that in my panel_domains table (mysql) the value of column isbinddomain was set to 1 while it wasn't managed by bind. This was causing all this trouble :-) Just setting it to 0 and rebuilding my config files (in froxlor) was doing the trick for me. d00p thanks for all the help, you've been really helping me out!
  2. Allright, I updated (was much easier than I tought! Nice work guys!). I also reconfigured the postfix server with the config files given in froxlor. I still have this problem: bounced (mail for v**orten.be loops back to myself)
  3. Allright going to do some updates :-) can it be found on the wiki? How to apply updates
  4. I'm using debian. And I think I installed it trough debian packages provided on the site, (some months ago)
  5. I added this additional_conditions = AND isemaildomain = 1 and now one domain is working. I still have an error on another domain --> status=bounced (mail for v*corten.be loops back to myself)
  6. user = * password = * dbname = froxlor table = panel_domains select_field = domain where_field = domain hosts = 127.0.0.1 This one was the one standard given while installing everything with froxlor.
  7. Below you can see the queries executed by a good call and a call that fails (since it is hosted on the server) 390 Query SELECT destination FROM mail_virtual WHERE email='testing123@l*kx.be' 390 Query SELECT destination FROM mail_virtual WHERE email='@l*x.be' 391 Connect froxlor@localhost on froxlor 391 Query SELECT destination FROM mail_virtual WHERE email='l*x.be' 393 Query SELECT domain FROM panel_domains WHERE domain='l*kx.be' ===> DELIVERED (not hosted on the server) 390 Query SELECT destination FROM mail_virtual WHERE email='info@v*corten.be' 390 Query SELECT destination FROM mail_virtual WHERE email='@v*corten.be' 391 Query SELECT destination FROM mail_virtual WHERE email='v*corten.be' 393 Query SELECT domain FROM panel_domains WHERE domain='v*corten.be' 394 Query SELECT maildir FROM mail_users WHERE email='info@v*corten.be' 394 Query SELECT maildir FROM mail_users WHERE email='@v*corten.be' ==> BOUNCED (domain/web is hosted @server but no mailboxes -> other server)
  8. I tried to put things in comment, but still the same problem. I'm using sendmail to deliver the emails (not SMTPD). But what I don't get is the following. When I try to send to a foreign email address it works perfectly. But if I send out an email to an domain that is hosted by froxlor he tries to deliver it locally. For some reason he triggers the lookup in the mysql table (and can't find any account)... But what triggers this. There needs to be somewhere defined that the domain also has local mailboxes, or am I not correct? Thanks, Ward
  9. My main.cf file ## General Postfix configuration # should be the default domain from your provider eg. "server100.provider.tld" mydomain = evolutions.**it.be # should be different from $mydomain eg. "mail.$mydomain" myhostname = evolutions.**it.be mydestination = $myhostname, $mydomain, localhost.$myhostname, localhost.$mydomain, localhost mynetworks = 127.0.0.0/8 inet_interfaces = all append_dot_mydomain = no biff = no # Postfix performance settings default_destination_concurrency_limit = 20 local_destination_concurrency_limit = 2 # SMTPD Settings smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) smtpd_helo_required = yes smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unauth_pipelining, reject_non_fqdn_recipient smtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated, reject_unknown_helo_hostname, reject_unknown_recipient_domain, reject_unknown_sender_domain smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unknown_client_hostname # Maximum size of Message in bytes (50MB) message_size_limit = 52428800 ## SASL Auth Settings smtpd_sasl_auth_enable = yes smtpd_sasl_local_domain = $myhostname broken_sasl_auth_clients = yes # Virtual delivery settings virtual_mailbox_base = /var/customers/mail/ virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cf virtual_uid_maps = static:2000 smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cf virtual_uid_maps = static:2000 virtual_gid_maps = static:2000 # Local delivery settings local_transport = local alias_maps = $alias_database # Default Mailbox size, is set to 0 which means unlimited! mailbox_size_limit = 0 virtual_mailbox_limit = 0 ### TLS settings ### ## TLS for outgoing mails from the server to another server #smtp_tls_security_level = may #smtp_tls_note_starttls_offer = yes ## TLS for email client #smtpd_tls_security_level = may #smtpd_tls_cert_file = /etc/ssl/server/evolutions.floo-it.be.pem #smtpd_tls_CAfile = /etc/ssl/certs/ca-certificates.crt #smtpd_tls_loglevel = 1 #smtpd_tls_received_header = yes debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
  10. This is the /etc/postfix/mysql-virtual_mailbox_domains.cf file. Maybe it helps user = ** password = ** dbname = froxlor table = panel_domains select_field = domain where_field = domain hosts = 127.0.0.1
  11. How can I check that? I think postfix wants to deliver it locally since the domain is hosted by the server. I have the problem with other domains also... When i send mail from PHP to a domain hosted by froxlor I get -> bounced When i send mail from PHP to a foreign hosted domain I get -> success
  12. I think because the domain is hosted by froxlor and I'm trying to send an email to that domain. The mailserver thinks it will be needed to deliver locally (but it isn't). I checked of the following feature from the domains panel, but still not working. Email domain -> No Only email? -> No Any suggestions?
  13. Okay I have my froxlor control panel back up and running. Now I have a site -> test1.com The mailboxes of the site aren't hosted or managed by froxlor (on other server). When I try to send an email from the website (from: info@test1.com), I get a bounced error in my mail.err log. Can somebody explain me how I can fix this, so I can send out email again trough my website. Here is the log message Feb 1 11:20:48 evolutions postfix/pickup[23025]: 7DF8B10E456: uid=33 from=<www-data> Feb 1 11:20:48 evolutions postfix/cleanup[23724]: 7DF8B10E456: message-id=<lfxoqo.5i6oxr@www.test1.com> Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 7DF8B10E456: from=<www-data@evolutions.floo-it.be>, size=2878, nrcpt=1 (queue active) Feb 1 11:20:48 evolutions postfix/pickup[23025]: 8B03510E454: uid=33 from=<www-data> Feb 1 11:20:48 evolutions postfix/cleanup[23724]: 8B03510E454: message-id=<lfxoqo.sb1fru@www.test1.com> Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 8B03510E454: from=<www-data@evolutions.floo-it.be>, size=2704, nrcpt=1 (queue active) Feb 1 11:20:48 evolutions postfix/virtual[23729]: 7DF8B10E456: to=<wardsstest@e-volutions.be>, relay=virtual, delay=0.15, delays=0.09/0.04/0/0.02, dsn=5.1.1, status=bounced (unknown user: "wardsstest@e-volutions.be") Feb 1 11:20:48 evolutions postfix/cleanup[23728]: 9776210E459: message-id=<20110201102048.9776210E459@evolutions.floo-it.be> Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 9776210E459: from=<>, size=4696, nrcpt=1 (queue active) Feb 1 11:20:48 evolutions postfix/bounce[23731]: 7DF8B10E456: sender non-delivery notification: 9776210E459 Feb 1 11:20:48 evolutions postfix/virtual[23730]: 8B03510E454: to=<info@test1.com>, relay=virtual, delay=0.11, delays=0.05/0.03/0/0.03, dsn=5.1.1, status=bounced (unknown user: "info@test1.com") Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 7DF8B10E456: removed Feb 1 11:20:48 evolutions postfix/cleanup[23724]: 9FE2A10E456: message-id=<20110201102048.9FE2A10E456@evolutions.floo-it.be> Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 9FE2A10E456: from=<>, size=4522, nrcpt=1 (queue active) Feb 1 11:20:48 evolutions postfix/bounce[23731]: 8B03510E454: sender non-delivery notification: 9FE2A10E456 Feb 1 11:20:48 evolutions postfix/local[23733]: 9776210E459: to=<www-data@evolutions.floo-it.be>, relay=local, delay=0.06, delays=0.03/0.02/0/0, dsn=2.0.0, status=sent (delivered to mailbox) Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 8B03510E454: removed Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 9776210E459: removed Feb 1 11:20:48 evolutions postfix/local[23733]: 9FE2A10E456: to=<www-data@evolutions.floo-it.be>, relay=local, delay=0.02, delays=0.01/0.01/0/0, dsn=2.0.0, status=sent (delivered to mailbox) Feb 1 11:20:48 evolutions postfix/qmgr[1853]: 9FE2A10E456: removed
  14. The mailbox isn't hosted on my server, but my website needs to send emails trough that email address... Do you know how I can do this? This is the domain within the panel_domains table id domain adminid customerid aliasdomain documentroot ipandport isbinddomain isemaildomain email_only iswildcarddomain subcanemaildomain caneditdomain zonefile dkim dkim_id dkim_privkey dkim_pubkey wwwserveralias parentdomainid openbasedir openbasedir_path safemode speciallogfile ssl ssl_redirect ssl_ipandport specialsettings deactivated bindserial add_date registration_date phpsettingid mod_fcgid_starter mod_fcgid_maxrequests ismainbutsubto 10 xxx.be 1 1 NULL /var/customers/webs/xxx/ 1 1 1 0 1 0 1 1 0 1 0 1 0 1 0 0 0 0 0 2010121900 1289320955 0000-00-00 1 -1 -1 0
×
×
  • Create New...