Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
OlliMe

SMTP-Auth klappt nicht

Question

Hallo,

ich habe Froxlor auf einem Lenny 64Bit neu eingerichtet und Probleme mit dem SMTP-Auth.

Ansonsten klappt alles hervoragend in Sachen Mail POP/IMAP, alles ok.

 

Im Mail.log kommt immer:

 

Mar  1 21:29:50 RT1636 postfix/smtpd[439]: warning:      SASL authentication failure: Password verification failed
Mar  1 21:29:50 RT1636 postfix/smtpd[439]: warning: ...: SASL PLAIN authentication failed: authentication failure
Mar  1 21:29:50 RT1636 postfix/smtpd[439]: warning: ...: SASL LOGIN authentication failed: authentication failure

 

Habe alles wie in der Konfiguration angegeben eingerichtet und schon reichlich im Internet gesucht.

 

Hat irgendwer einen goldenen Tipp?

 

Gruss

Olli

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

F?r diese Art der Authetifizierung m?ssen klartext Passw?rter in Froxlor aktiviert sein

Share this post


Link to post
Share on other sites

F?r diese Art der Authetifizierung m?ssen klartext Passw?rter in Froxlor aktiviert sein

 

Hm, ich glaube, das Problem liegt woanders.

Die auth.log sagt u.a.:

Mar  1 13:36:31 RT1636 postfix/smtpd[27801]: sql plugin try and connect to a host
Mar  1 13:36:31 RT1636 postfix/smtpd[27801]: sql plugin trying to open db 'froxlor' on host '127.0.0.1'
Mar  1 13:36:31 RT1636 postfix/smtpd[27801]: sql plugin could not connect to host 127.0.0.1
Mar  1 13:36:31 RT1636 postfix/smtpd[27801]: sql plugin couldn't connect to any host

 

Verstehe ich aber nicht, da "127.0.0.1" ja sonst ?berall funktioniert.

 

Plaintext-Kennw?rter SIND akriviert. Ist ja default.

Share this post


Link to post
Share on other sites

dann stimmen evtl. die konfigurationen von postfix nicht. Evtl. ein falsches Passwort angegeben?

Share this post


Link to post
Share on other sites

"Es gilt zwischen localhost und 127.0.0.1 zu unterscheiden. Die

MySQL-Client-Library, welche in fast allen Programmen zum Einsatz kommt, die

auf MySQL Server zugreifen (z.B. der MySQL Console, aber auch in PHP),

reagiert auf den Host localhost auf spezielle Weise. Soll eine Verbindung zum

Host localhost per TCP aufgebaut werden, erzwingt die Library automatisch den

Zugriff ?ber UNIX Domain Sockets."

 

 

Hast du mal probiert localhost/127.0.0.1 auszutauschen in der sasl config?

 

 

cheers

Share this post


Link to post
Share on other sites

Ich f?rchte, da ist alles ok. Welche Datei denn im Speziellen?

Bin echt am verzweifeln. :(

 

 

Schei**e, es war ein Leerzeichen hinter dem Kennwort in der smtpd.conf

Und deswegen suche ich den halben Tag nach dem Fehler.

 

Sorry und danke f?r die Unterst?tzung. Nun geht es! :)

Share this post


Link to post
Share on other sites

Siehe editierten Post ?ber dir! ;)

 

Nachtrag: interessanterweise hat dieser "Fehler" nur Auswirkungen in der smtpd.conf. In den anderen Postfix *.cf-Dateien war es egal. Dort war es n?mlich auch! ;)

Share this post


Link to post
Share on other sites

das hat damit zu tun, dass SASL und postfix nicht dasselbe sind. sie brauchen nicht die gleiche Art des Zugriffes auf MySQL. Dementsprechend werden auch die config files unterschiedlich interpretiert.

Share this post


Link to post
Share on other sites

Danke f?r die Info.

Ich merke schon, dass ihr hier wisst, was ihr mit dem Projekt tut! ;)

Vielen Dank f?r Euer Engagement Syscp weiter zu entwickeln, wobei der neue Name etwas gew?hnungsbed?rftig ist. :)

Share this post


Link to post
Share on other sites

×
×
  • Create New...