Jump to content
Froxlor Forum
  • 0

Perl does not work because suexec denies execution


monotek

Question

I just tried the new Perl/Cgi Feature in Froxlor 0.9.11 but i got an 500 Error when executing my test.cgi (hello world) script.

 

I looked into the error logs:

 

customer-error.log

[Thu Jul 29 11:06:32 2010] [error] [client 89.202.163.174] suexec policy violation: see suexec log for more details
[Thu Jul 29 11:06:32 2010] [error] [client 89.202.163.174] Premature end of script headers: test.cgi

 

suexec.log

[2010-07-29 11:06:32]: uid: (10001/web2) gid: (10001/10001) cmd: test.cgi
[2010-07-29 11:06:32]: command not in docroot (/var/customers/webs/web2/abauer/test.cgi)

 

Imho this means the script cant be executed in /var/customers/webs because its not in /var/www but suexec is compiled for this directory.

 

Does this mean in need to recompile suexec to get the new perl feature work?

Link to post
Share on other sites

5 answers to this question

Recommended Posts

I found another solution.

 

1.) create a directory /var/www/cgi-bin (owner root / chmod 0701)

2.) create a directory /var/www/cgi-bin/YOUR_CUSTOMER (owner YOUR_CUSTOMER / chmod 0701)

3.) add symlink /var/customers/webs/YOUR_CUSTOMER/cgi-bin which points to /var/www/cgi-bin/YOUR_CUSTOMER

4.) add path option in froxlor customer frontend which allows executing perl in /var/customers/webs/YOUR_CUSTOMER/cgi-bin

 

CGI will work.

 

Could you implement creating of this directories / symlinks into the cron job?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...