Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
svizzera

ProFTPD user werden nicht erstellt

Question

Hi Leute,

 

hab eben mal Testweise Froxlor auf Lenny installiert,

ging auch alles soweit cremig wie Butter aber wenn ich nen Kunden erstelle

und dann auf dem Kunden nen FTP User einrichte, kann ich mich net einloggen, da anscheinend der FTP User nicht erstellt wird.

 

Der proftpd log sagt folgendes:

 

FTP session opened.
no such user '*******'
USER *******: no such user found from ***************
FTP session closed.

 

 

Ich danke bereits im vorraus f?r eure Hilfe

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

Hast du dich direkt nach dem Anlegen des FTP-Users versucht einzuloggen?

 

Froxlor's Cronjob erstellt soweit ich wei?, die FTP-User wie vieles andere in einem bestimmten Zeitintervall. Hast du mal 5-10 Minuten sp?ter versucht, dich per FTP einzuloggen?

Share this post


Link to post
Share on other sites

monotek hat recht, die user werden sofort in der tabelle ftp_users angelegt. Hast du auch proftpd nach Vorgaben von Froxlor Konfiguriert? Sonst weiss der nicht das er in der Datenbank nach Benutzern suchen soll

Share this post


Link to post
Share on other sites

hab nat?rlich auch sp?ter versucht mich einzuloggen,

anscheinend funzt der cronjob nich...

 

[R] Connecting to ********* -> IP=********* PORT=21
[R] Connected to *********
[R] 220 ProFTPD 1.3.1 Server (Debian) [*********]
[R] USER *********
[R] 331 Password required for *********
[R] PASS (hidden)
[R] 530 Login incorrect.
[R] Connection failed

 

Ich hab Froxlor nach dieser Anleitung aufgesetzt:

http://www.debianroot.de/server/server-management-mit-froxlor-dem-syscp-fork-1190.html

 

und mir nat?rlich auch

http://faq.filoo.de/content/19/23/de/wie-installiere-ich-froxlor-auf-einem-rootserver-mit-debian.html

angeschaut

 

es funzt alles, bis auf das anlegen der ftp user =/

 

froxlorscrshot.png

Share this post


Link to post
Share on other sites

das hat nichts mit dem Cronjob zu tun...eher mit deiner ProFTPd Konfiguration

 

es funzt alles, bis auf das anlegen der ftp user =/

Das funzt garantiert, schau mal in die Tabelle "ftp_users" in der Froxlor Datenbank, ich wette da stehen welche drin

Share this post


Link to post
Share on other sites

Kann ich nicht best?tigen, funktioniert problemlos, bitte erl?utere mal dein genaues vorgehen beim anlegen und sag mir alle Einstellungen bez?glich FTP aus den Settings (z.B. 'FTP-Benutzerkonten @domain')

Share this post


Link to post
Share on other sites

Hi Doop,

 

nur mal so finde dein Engagement genial,

 

also unser Update war von SYSCP auf Froxlor,

 

habe heute gerne einen neuen Benutzer angelegt in Froxlor das anlegen des BEnutzer hat auch funktioniert jedoch hat das mit dem FTP-Account nicht geklappt.

 

hier die einstellungen.

 

bild1.png

bild2.png

bild3.png

Share this post


Link to post
Share on other sites

Taucht denn der neu angelegte FTP-User in der FTP-User Liste des Kunden (im Kunden-Panel unter FTP -> Benutzerkonten) auf?

Share this post


Link to post
Share on other sites

Gut, d.h. er befindet sich in der f?r Proftpd zug?nglichen Tabelle in der Datenbank (er wird also korrekt angelegt).

 

Um zu sehen wo es h?ngt, bitte ich dich, trage in die /etc/proftpd/proftpd.conf ans Ende bitte folgende Direktive

DebugLevel 6

und nopaste dann die Ausgaben eines Login-Versuches (sollte dann in der /var/log/proftpd/proftpd.log zu finden sein)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.





×
×
  • Create New...