Jump to content
Froxlor Forum
  • 0

dovecot: keine Verbindung zu mysql // Lösung: keine Sonderzeichen im Passwort für froxlor DB-User !!!


rincewind0803
 Share

Question

Posted (edited)

Hallo,

Ich habe froxlor neu aufgesetzt auf ein Buster minimal.

Mein Dovecot mag sich nicht mit der Datenbank verbinden:

vps dovecot: auth-worker(1161): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES) - waiting for 1 seconds before retry

In der /etc/dovecot/dovecot-sql.conf.ext steht, ich habe auch schon localhost statt 127.0.0.1 probiert

connect = host=127.0.0.1 dbname=froxlor user=froxlor password='richtiges_passwort'

Das Kennwort ist korrekt, ich kann mich auf der Konsole mit mysql verbinden.

Es gibt den User froxlor@127.0.0.1 froxlor@localhost und froxlor@ext_ip alle haben grant_all für froxlor und das Kennwort ist bei allen gleich.

Hat wer eine Idee ?

 

Edited by rincewind0803
Solution
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Guter Tipp !

Falls es jemandem hilft:
Ich hatte das in Hochkommata gesetzt (hatte ohne ' ' auch nicht funktioniert) weil ich vermutete das die Sonderzeichen im Passwort Probleme verursachen (ich hatte : und # drin ).
Ohne Hochkommata und ein weniger komplexes Passwort haben das Problem behoben.
Steht vermutlich irgendwo in der Doku und ich habs nicht gelesen....

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...