Jump to content
Froxlor Forum
  • 0

Composer Problem: einige requirements laufen nicht mit aktuellem php8


df8oe
 Share

Question

Bis zur Version 10.25 lief alles mit meinem php8. Mit dem Update auf 10.26 ist das leider nicht mehr so:

  Problem 1
    - Root composer.json requires phpunit/phpunit 8.4.1 -> satisfiable by phpunit/phpunit[8.4.1].
    - phpunit/phpunit 8.4.1 requires php ^7.2 -> your php version (8.0.6) does not satisfy that requirement.
  Problem 2
    - Root composer.json requires sebastian/phpcpd ^4.1 -> satisfiable by sebastian/phpcpd[4.1.0].
    - sebastian/phpcpd 4.1.0 requires php ^7.1 -> your php version (8.0.6) does not satisfy that requirement.
  Problem 3
    - Root composer.json requires phploc/phploc ^5.0 -> satisfiable by phploc/phploc[5.0.0].
    - phploc/phploc 5.0.0 requires php ^7.2 -> your php version (8.0.6) does not satisfy that requirement.

Schade.... Froxlor selbst läuft mit php8 einwandfrei.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...