Jump to content
Froxlor Forum

df8oe

Members
  • Content Count

    94
  • Joined

  • Last visited

Everything posted by df8oe

  1. Danke für die superschnelle Implementierung! Habe schon von Github gefetched 😀😀😀
  2. df8oe

    http2

    Das wird es sein. Denn ansonsten sieht in den ip/port und in der vHost selbst alles gut aus. Aber es ist eben nur die "Standard-Option" Protocols h2 http/1.1 gesetzt.
  3. df8oe

    http2

    Hallo an alle, ich habe gerade http2 auf meinem Apachen aktiviert. Wenn ich über die Developer-Konsole des Chromium schaue werden ein paar Elemente mit http2 geladen - aber viele (leider Bilder) nach wie vor mit http1.1. Ich habe das auf mehreren Domains (mit unterschiedlichen CMS) getestet - überall das selbe. http2 ist ziemliches Neuland für mich. Woran liegt es? Wer gibt vor dass die Bilder mit http1.1 geladen werden(sollen)? Oder was verhindert dass die Bilder mit http2 geladen werden? Fehlt noch eine Einstellung im Apachen / im vHost (ich habe lediglich in Froxlor global http2 aktivi
  4. Richtig. Und was das "Umgehen" angeht: Ich rede nicht von den domainbezogenen Einstellungen. Da ist AntiXss absolut sinnvoll und ich würde es auf keinen Fall dort umgehen wollen. Da haben die User ihre Finger im Spiel... Ich rede von den Admin-Einstellungen, die über die "Einstellungen / Webserver Einstellungen" gemacht werden können. An der Stelle schraubt nur der "Oberadmin". Hier sollte man AntiXss umgehen.
  5. Ergänzung: Der Auslöser für den Fehler war wohl auch nicht das Neuanlegen einer Domain sondern die Tatsache, dass ich in dem Zuge gleich http2 aktiviert habe. Das musste ja zunächst im Settingspanel für den Apachen gemacht werden...
  6. Kann ich nachvollziehen. Ich denke die vHost Config kann und sollte man davon definitiv ausnehmen. Wer hier etwas einträgt kann bei falscher Handhabung auch mit AntiXss seinen Webserver lahmlegen oder gefährden. Auf der anderen Seite nimmt man aber einem fähigen User die Möglichkeit, hier wirklich frei zu konfigurieren. Deine Vermutung stimmt. Ich habe die korrekten Zeilen mal direkt in die Tabelle eingetragen Dann geht alles wieder. Auch das Ändern einer Domain bewirkt nichts Schlimmes. Nur sowie man auf der Apache-Konfig-Seite irgendwas verändert wird (die übrigens korrekt aus der Tabel
  7. Habe die Tabelle gefunden. Die Sachen stehen schon verändert in der Tabelle. Das liegt übrigens NICHT daran, dass die vHost Config das bewirkt wenn sie einmal aktiv ist. Wie geschrieben: Ich habe das seit Jahren laufen und es hat etliche neu angelegte Domains überstanden. Das was bewirkt dass es nicht mehr geht muss ca. im letzten halben Jahr passiert sein.
  8. Ich finde die Tabelle nicht auf Anhieb. In welcher Tabelle steht denn die vHost Config? Und nein - das soll für alle Domains gelten. Es funktionierte auf jeden Fall vor ein paar Monaten noch...
  9. Ich habe in meinen Standard vHost Einstellungen ein paar Zeilen mit denen ich besonders häufig vorkommende Angriffe (mysql-Injection) auf ein bestimmtes Script umlenke. Das hat bis vor xx Monaten auch prima funktioniert. Ich habe die Zeilen für die vHost in Froxlor eingetragen, und sie wurden 1:1 übernommen. So soll es sein. Heute startete der Apache aber nach dem Neuanlegen einer Domain nicht mehr - der Grund ist dass auf einmal die eingegebenen vHost-Konfig-Zeilen vor dem Übernehmen geparst und verändert werden! Betroffen sind Zeilen die Hex-Kodierungen enthalten. Also z.B. soll sein: Re
  10. War in meinem lokalen git - habe es gerade gesehen. Danke - mein Fehler. composer install --no-dev und alles ist gut.
  11. Ich habe eben von 10.21 auf 10.22 upgegraded. Danach ist kein Aufruf der Startseite von Froxlor mehr möglich. Es erscheint nur noch die Meldung Fatal error: Uncaught Error: Class 'voku\helper\AntiXSS' not found in /var/www/froxlor/lib/init.php:94 Stack trace: #0 /var/www/froxlor_10.22/index.php(20): require() #1 {main} thrown in /var/www/froxlor/lib/init.php on line 94 Ich mache meine Updates mit den Dateien von GitHub: 1) Alle Dateien kopieren 2) lib/userdata.inc.php rüberkopieren 3) gesamten Ordner Vendor rüberkopieren (in dem Ordner von Github ist fast alles out
  12. Solange ich Debian hatte habe ich die fertigen .deb-Pakete genommen - das war für mich "das Release". Seit ich Arch habe nehme ich git - weil es sowieso auf dem Server läuft und ständig aktuell ist. Der Rest von Arch ist ja auch "bleeding edge" - da warte ich nicht auf die Releases.
  13. Wir reden einfach eine andere Sprache. Ich will niemanden ärgern Und Froxlor ist echt Klasse. Dann ändere ich es bei mir nicht sondern mache einfach ein rebase. EDIT: Ich nutze ja sowieso die Dateien von Github und nicht die eines Releases - weil ich meine Server mit Arch betreibe. DF8OE
  14. Fazit: Wenn bei jemandem dieses Problem auftritt kann man sich mit einem Workaround helfen. Vermutlich sind bei denen, die das Problem haben, im IP/PORT-SSL-Vhost die beiden Pfade "Pfad zum Zertifikat" und "Pfad zum SSL-Private-Key" nicht leer, sondern haben eine Pfad/Dateikombination, die auf dem Server nicht existiert. Löscht einfach die dort vorhandenen Einträge und lasst die Felder leer. Dann erkennt Froxlor beim Neuanlegen einer Domain mit den Defaulteinstellungen ("aktiviere SSL" gesetzt, "Letsencrypt" nicht gesetzt) dass es kein gültiges Zertifikat gibt und erstellt einen leeren S
  15. Nein, hat er nicht. Und Flames sind auch unnütze Zeitverschwendung - genauso wie Diskussionen. Ich werde mich nachher drum kümmern und hier entweder die Lösung in Form geänderter Einstellungen oder in Form eines Patches veröffentlichen. Vielleicht macht das dann das Problem transparenter. Das Ziel ist die Behebung einer Fehlfunktion, die für weniger versierte Nutzer zu einem Problem führen kann, das sie nicht ohne weiteres wieder beheben können.
  16. Ich denke ich verschwende meine Zeit nicht Logs zu verändern oder hier das Fehlverhalten zu posten, sondern den Fehler selbst zu fixen und in mein Froxlor-Github einzufügen. Es existiert auch ein Pull-Request für meine Implementierung von DKIM, der aber schwebt, weil der Part für die Erstellung der DKIM-Serverkonfigurationen fehlt (und ich keine Zeit habe ihn zu erstellen). Aktuell gibt es aber noch keine Merge-Konflikte Alles, was zum Verstehen der Fehlfunktion nötig ist, steht hier bereits. Und dass eine IP/Port-Kombination für den Vhost von Froxlor verwendet wird kann ich weder nachvo
  17. Froxlor läuft nicht über IP (weil ich kein teures IP-Zertifikat habe), sondern auf einer Subdomain. Und die hat ein Letsencrypt-Zertifikat. Das manuelle Anonymisieren frisst jede Menge zeit (ich schrieb es bereits). Ich kann also die IP/Port-Kombination für SSL nicht löschen, wenn irgend eine Domain via SSL läuft. So gut wie niemand dürfte ein IP-Zertifikat haben. Wie lange es sowas überhaupt noch gibt ist auch fraglich. Aber es werden sehr viele Leute auch ohne existentes IP-Zertifikat Domains mit SSL genutzt werden. Man *MUSS* also eine IP/Port-Kombination für SSL anlegen - au
  18. Die ganzen Einstellungen kann ich nicht unverändert posten weil da Kundendaten drin sind (DSGVO). Und die ganzen Stellen unkenntlich zu machen ist eine Heidenarbeit. Aber wir nähern uns. Es ist auf allen drei Servern auch eine IP/Port-Kombination für Port 443 in Froxlor eingetragen - aber es soll kein Vhost dafür erstellt werden. Dementsprechend stört es auch nicht, dass die dort eingetragene Pfad/Zertifikat-Kombination nicht existiert. Alle drei Server laufen seit Äonen - bis Mai mit Debian, seit Mai mit Arch Linux. Das Problem, dass ssl-Vhosts erstellt werden ohne existente Zertifikate ist e
  19. Bei Arch Linux gibt es keine Ordner oder Dateien die mit"apache*" benannt sind. Die haben alle ein "http*" im Namen - ganz sicher. Es gibt weder einen Unterordner "apache" noch irgendwo Zertifikatsdateien die mit "apache" benannt sind.
  20. Hier die beiden relevanten Zeilen aus der erstellten ssl-Vhost-conf: SSLCertificateFile /etc/ssl/apache/apache.crt SSLCertificateKeyFile /etc/ssl/apache/apache.key Ich habe es vermieden die gesamte conf zu posten da das Unkenntlichmachen der 30 für dieses Problem absolut irrelevanten Stellen sinnlos Arbeit erzeugt. Der Knackpunkt wurde klar beschrieben: Es ist default "SSL aktivieren" ausgewählt. Es gibt kein systemweites oder IP-basiertes Zertifikat. Letsencrypt ist nicht angehakt. Dann erstellt Froxlor einen ssl-Vhost mit den oben aufgeführten Zeilen und startet den Webser
  21. Leider wird der Vhost bei drei unterschiedlichen Server nicht deaktiviert. Es wird ein Vhost angelegt dessen Zertifikat in /etc/ssl/apache/apache.crt / /etc/ssl/apache/apache.key liegen soll. Da liegt aber keines (es gibt noch nicht mal den Ordner /etc/ssl/apache) und das wars dann mit dem Webserver...
  22. Das Neuanlegen einer Domain führt jetzt oft dazu, dass der Webserver nicht mehr startet. Wie kommt das zu Stande? Beim Neuanlegen einer Domain wird, wenn in den Webserver-Grundeinstellungen SSL enabled ist, in der Sektion "Webserver SSL-Einstellungen" bei "Aktiviere Nutzung von SSL:" generell ein Haken gesetzt. Bei "SSL Zertifikat erstellen (Let's Encrypt):" ist dagegen kein Haken gesetzt. Das führt dazu, dass beim nächsten Cron-Lauf die Konfiguration so geschrieben wird, dass von einem lokal vorhandenen Zertifikat ausgegangen wird. Das ist aber nicht vorhanden - und damit sta
×
×
  • Create New...