Jump to content
Froxlor Forum

df8oe

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

About df8oe

  • Rank
    Froxie
  1. df8oe

    mehrere php Versionen mittels php-fpm

    Danke für den Stupser. Ich hatte mich nur nicht getraut das auszuprobieren (ist halt ein Produktivsystem...) Mit deiner Bestätigung ist das für mich die "Lizenz zum Probieren" Danke! LG DF8OE
  2. Moin an die Community, aktuell habe ich Apache2 mit mod_php @Debian Stretch am Laufen. Es stellt sich aber immer mehr heraus dass ich für unterschiedliche Kunden unterschiedliche php-Versionen vorhalten muss. Alleine schon für mich selbst: So kann ich auf bestimmten Domains ältere php-Scripte an neue php-Versionen anpassen bevor es brenzlig wird... Ich habe mehrere Möglichkeiten im web gefunden, wie man das realisieren kann. Man kann mittels mod_proxy arbeiten und den unterschiedlichen Versionen unterschiedliche Ports geben - oder mit socks (mir am sympathischsten). Ich habe auch schon gefunden, wie man Froxlor auf php-fpm umstellt. Aber in allen Fundstellen ist immer nur die Rede von EINER php-Version, und in die Zeile zum Neustart von php kann man doch sicher auch nur einen Pfad eintragen, oder? Kann mich jemand auf einen Link stupsen, wie man mehrere php-Versionen mittels php-fpm und Froxlor hinbekommt? Und ob die php-Versionen dann via Froxlor per Domain oder via htacess gesteuert werden? LG DF8OE
  3. Gut. Dann ist die Einstellung meiner Wahl Ich weiß nicht, wie viele darüber schon gestolpert sind - aber ein Satz in den Einstellungen, dass das Anzeigen des Logs via Froxlor nur funktioniert, wenn das Log in mysql landet, wäre sicher nicht schlecht. Funktioniert. Vielen Dank df8oe
  4. Wenn ich das Log von "file" umstelle auf mysql - landen dann diese Einträge im Panel? Mit "auswerten" meinte ich "nur anzeigen" - aber eben über die Weboberfläche. Gruß df8oe
  5. Ich habe die Logs als file in /var/log/ eingerichtet, und es wird dort auch munter reingeschrieben. Im Webinterface "System-Log" von Froxlor herrscht jedoch gähnende Leere. Durch Zufall habe ich "Log leeren" angeklickt: da will er die Tabelle "panel_syslog" leeren. Aber wieso Tabelle? In den Logeinstellungen ist "file" und der entsprechende Pfad ausgewählt. Gibt es da ZWEI Stellen, an denen die Logeinstellungen ausgewertet werden und die sind nicht synchron? Gruß df8oe
  6. df8oe

    letsencrypt und mehrere Subdomains

    Tatsächlich. 5 Stunden gewartet - jetzt geht es. Nameserverproblem... Danke, dass Du mich auf den richtigen Weg geschickt hast Gruß df8oe
  7. df8oe

    letsencrypt und mehrere Subdomains

    Das liegt nicht bei mir. Der externe Nameserver reagiert je nachdem von wo aus ich ihn anfrufe anders. Ich warte einfach nochmal ab. Ich habe die Subdomain erst heute Morgen in den DNS Record eingetragen - ich vermute, dass sich hier "noch nicht alles rumgesprochen hat". Das ist vermutlich nicht nur ein Server, sondern ein Verbund, und je nachdem, von "wo aus ich reinkomme (von innerhalb der Serverfarm oder von Aussen) ist das Ergebnis anders. Danke für den goldrichtigen Tipp! Gruß df8oe
  8. df8oe

    letsencrypt und mehrere Subdomains

    Ja, mache ich. Weil ich auf zwei Subdomains je eine dynamische IP habe die der öffentliche Nameserver dann via meinem Nameserver auflöst. Deswegen ist bind9 aktiviert und hat auch für alle Hauptsomains und auch die betroffene Subdomain ein Zonefile. Er ist auch gestartet und läuft (wenn nicht würde mir das sofort auffallen weil die beiden dynamischen dann ins Nirwana laufen würden). Gruß df8oe
  9. df8oe

    letsencrypt und mehrere Subdomains

    Der Tipp war mal wieder gut. Wenn ich von extern auf die Subdomain zugreife, klappt es. Von intern nicht. Ein Ping vom Server auf die Subdomain bringt "unknown host". Alle anderen Domains dieses Servers (inkl. der Subdomains anderer Hauptdomains) sowie externen Domains wie google.de, gmx.de etc. werden 100% korrekt aufgelöst - nur diese eine Subdomain nicht. Die Subdomain ist aber im Apachen korrekt angelegt. Und in /etc/bind/domains ist auch ein entsprechendes Zonefile angelegt worden. Seltsamerweise sind bei allen anderen Subdomains (von anderen Hauptdomains) diese Probleme NICHT vorhanden (ich kann sie vom Server aus anpingen) - nur für diese Subdomain klappt das nicht. Wie kann denn das passieren?? Ratlos... Gruß df8oe
  10. Hallo an alle, ich mache irgendwas falsch und bekomme nicht raus was Letsencrypt läuft prima mit meinen Hauptdomains. Wenn ich ein neues Zertifikat erstellen will wähle ich als Alias immer "www." - und nach wenigen Minuten ist das Zertifkat vorhanden und gültig. Nun haben mehrere meiner Domains Subdomains, die auf eigene Verzeichnisse zeigen. Via http auch kein Problem. Aktiviere ich https, dann bekomme ich die Fehlermeldung, dass das zertifikat auf abc.de ausgestellt ist und nicht auf cps.abc.de passt. Stimmt ja auch. Also setze ich einen Haken bei Letsencrypt und hoff(t)e, dass jetzt für diese Subdomain ein eigenes Zertifikat abgeholt wird. Ist zwar etwas umständlich - aber sollte funktionieren. Tut es aber nicht. Wenn ich jetzt 10 Minuten warte, werde ich von LE gesperrt wegen zu vieler Fehler. Also habe ich das Script mal zu Fuß angestoßen und mit debug Option ausgeführt. Leider bringt mich das auch nicht weiter. root@serverlein.de:~# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating cps.abc.de [information] Adding SAN entry: cps.abc.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Using existing account key [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for cps.abc.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for cps.abc.de [information] letsencrypt Token for cps.abc.de saved at /var/www/froxlor/.well-known/acme-challenge/ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ and should be available at http://cps.abc.de/.well-known/acme-challenge/ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ [error] letsencrypt Please check http://cps.abc.de/.well-known/acme-challenge/ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/cps.abc.de\/.well-known\/acme-challenge\/ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/7010s4i9e1AGkPTA9sAQT4q_R2koLIsuvwMsZhjHI3I/1373449240 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for cps.abc.de: Verification ended with error: {"identifier":{"type":"dns","value":"cps.abc.de"},"status":"invalid","expires":"2017-06-26T12:07:17Z","challenges":[{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/7010s4i9e1AGkPTA9sAQT4q_R2koLIsuvwMsZhjHI3I\/1373449238","token":"DTyJJkaHGRBFOaOG4UqVw4PHbhqaIF_hYiEEgr2L38k"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/7010s4i9e1AGkPTA9sAQT4q_R2koLIsuvwMsZhjHI3I\/1373449239","token":"Ji-qoXFFuz9oScAUrV-Kfn9lSzCYJCasrEqT6gksSxo"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/cps.abc.de\/.well-known\/acme-challenge\/ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ: \"<!DOCTYPE HTML PUBLIC \"-\/\/IETF\/\/DTD HTML 2.0\/\/EN\">\n<html><head>\n<title>404 Not Found<\/title>\n<\/head><body>\n<h1>Not Found<\/h1>\n<p\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/7010s4i9e1AGkPTA9sAQT4q_R2koLIsuvwMsZhjHI3I\/1373449240","token":"ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ","keyAuthorization":"ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ.nS70pz8z8isf-avL-LlRE26VFwKXSas2iA_NnvGaoGA","validationRecord":[{"url":"http:\/\/cps.abc.de\/.well-known\/acme-challenge\/ynUC1HXxrYZvZgCI9y1kc6AaTXZEv7HjoonkpPvyMvQ","hostname":"cps.abc.de","port":"80","addressesResolved":["85.10.198.2"],"addressUsed":"85.10.198.2","addressesTried":[]}]}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@serverlein.de:~# Wenn ich in .well-known... eine Test-HTML-Datei lege, kann ich mit http://cps.abc.de/.well-known.... darauf einwandfrei zugreifen. Das Verzeichnis liegt auch im Verzeichnis des Kunden, und der alte Apache kann drin rummalern. Ich habe sowohl probiert, die Subdomain "als Kunde anzulegen" (also als Subdomain von...) als auch als Admin und als Hauptdomain (also explizit NICHT als Subdomain zuzuweisen). Das Ergebnis ist dasselbe. Da Froxlor und LE ansonst einwandfrei laufen, kann ich mir nur vorstellen, dass bei LE auffällt, dass ich ein zweites Zertifikat mit der "Endung" abc.de anfordere und er sich da irgendwie verhakt. Aber das ist reine Glaskugelreiberei - aus den Logs kann ich das nicht entnehmen. Was mache ich grundsätzlich falsch? LG df8oe
  11. df8oe

    [Apache2] vhosts werden ignoriert

    Es ist wirklich sehr ungewöhnlich. Und ich habe sowas noch nicht gesehen. Ich möchte mich zwar nicht als "Linux-Vollprofi" bezeichnen, aber ich arbeite seit fast 20 Jahren ausschließlich unter Linux (Server sowieso und auch alle Arbeitsplatzrechner). Wie ich mit der externen IP auf dem Server lande, ist mir ein Rätsel - aber ich lande dort. Ich habe das ganze zum Funktionieren gebracht (aber verstehen tue ich es nicht): Die externe IP darf nirgendwo in Froxlor eingetragen werden. Weder als "Haupt-IP" noch irgendwie als weitere IP. Da darf überall nur die interne IP (die 10.0.x.y) rein. Dann den Apachen neu starten (reload hat nicht gereicht) - und jetzt geht es. Ich werde erstmal weitermachen und die anderen Dienste testen - und dann interviewe ich nochmal den Anbieter. Sowas grundlegendes muß ich einfach verstehen - sonst bleibt da ein ungutes Gefühl. Ich danke Dir auf jeden Fall für den Tipp mit der IP und deiner Hilfe überhaupt. Es war zwar nicht ipv4/ipv6 - aber durch die sehr seltsame IP Zuweisung hatte ich die externe (hier falsche) IP benutzt. Gruß df8oe
  12. df8oe

    [Apache2] vhosts werden ignoriert

    Du hast auf jeden Fall Recht - es *ist* ein IP-Problem. Und mittlerweilen denke ich, es hat mit ipv6 nichts zu tun - es ist eine sehr seltsames Zuweisung durch den Rootserverhoster. Ich bin mittlerweilen auf drei ipv4 Adressen gekommen 1) via ifconfig erhalte ich eine IP, die nur in LANs gilt (10.0.x.y) 2) der Hoster hat mir mitgeteilt, dass meine IP a.b.c.d ist 3) rufe ich von diesem Server aus via Lynx eine Seite meiner anderen Server auf, dann sehe ich dort die IP e.f.g.h Mache ich auf dem fraglichen Server einen traceroute auf eine dieser drei IPs, dann komme ich bei jeder mit einer Zeile am Ziel an. Bei IP 1) ist die Zeit < 0.1ms, bei den beiden anderen sind es ~0.7ms. Keine der drei IP-Adressen finde ich irgendwo in einer Datei in /etc. In /etc/network/interfaces ist eth0 nicht aufgeführt - weder mit statischer IP noch mit dhcp. Die vorhandene Installation ist (bis auf die Installation von Froxlor samt nötigen OPaketen wie dovecot etc.) die vom Hoster vorgefertige Startinstallation. Am liebsten würde ich den Loglevel vom Apachen soweit raufsetzen, dass er mir komplett mitloggt, was er versucht zu finden (und ja offensichtlich nicht findet). Dazu kommt, dass bei diesen vielen IP-Adressen ich auch nicht wirklich weiß, as ich bei Froxlor in den Systemeinstellungen denn nun als Haupt-IPadresse eintragen muss. Ich möchte mich ja ungern von Froxlor selbst aussperren Gruß df8oe
  13. df8oe

    [Apache2] vhosts werden ignoriert

    Darf ich Dir die Infos als PN schicken? Würdest Du da mal einen Blick drauf werfen? Gruß df8oe
  14. df8oe

    [Apache2] vhosts werden ignoriert

    Hatte ich auch schon getestet - keine Wirkung. ich falle mit jeder http-Anfrage in /var/www/html. Hier die Ausgabe von apache2ctl -S: ############################## VirtualHost configuration: 123.234.123.234:80 hullewulle.ballaballa.de (/etc/apache2/sites-enabled/10_froxlor_ipandport_123.234.123.234.80.conf:5) [fe60::6af0:433f:fb26:ba42]:80 is a NameVirtualHost default server hullewulle.ballaballa.de (/etc/apache2/sites-enabled/10_froxlor_ipandport_fe60::6af0:433f:fb26:ba42.conf:5) port 80 namevhost hullewulle.ballaballa.de (/etc/apache2/sites-enabled/10_froxlor_ipandport_fe60::6af0:433f:fb26:ba42.conf:5) port 80 namevhost my-first-domain.de (/etc/apache2/sites-enabled/35_froxlor_normal_vhost_my-first-domain.conf:6) port 80 namevhost my-second-domain.de (/etc/apache2/sites-enabled/35_froxlor_normal_vhost_my-second-domain.de.conf:6) port 80 namevhost my-third-domain.de (/etc/apache2/sites-enabled/35_froxlor_normal_vhost_my-third-domain.de.conf:6) alias www.my-third-domain.de ServerRoot: "/etc/apache2" Main DocumentRoot: "/var/www/html" Main ErrorLog: "/var/log/apache2/error.log" Mutex default: dir="/var/lock/apache2" mechanism=fcntl Mutex mpm-accept: using_defaults Mutex watchdog-callback: using_defaults Mutex rewrite-map: using_defaults PidFile: "/var/run/apache2/apache2.pid" Define: DUMP_VHOSTS Define: DUMP_RUN_CFG User: name="www-data" id=33 Group: name="www-data" id=33 ############################## In keinem der vhosts steht jetzt noch /var/www/html drin - der 000-default ist jetzt deaktiviert. Trotzdem fällt er immer wieder auf /var/www/html zurück. Mit grep in /etc/apache2 gesucht, enthalten nur die "sites-available" 000-default.conf und default-ssl.conf diesen Pfad (und die beiden sind disabled). Er findet keinen passenden vhost und fällt zurück auf fest einkompilierten (??) Pfad... Gruß df8oe
  15. df8oe

    [Apache2] vhosts werden ignoriert

    In der Tat liegt der Hase hier im Pfeffer. An ipv6 hatte ich überhaupt nicht gedacht - alle meine anderen Server sind älter und laufen noch unter ipv4... Also ifconfig zeigt mir eine LAN-ipv4 Adresse und eine ipv6 Adresse. Die ipv4-Adresse mit der der Server von Außen zu erreichen ist ist überhaupt nicht dabei. Ich habe noch nie so eine Konfiguration gehabt - also bin ich in der Hinsicht "nur jetzt noch" dumm . Ich habe also eine neue IP/Port Kombination eingerichtet mit der ipv6 Adresse. Dann habe ich (der besseren Forensik wegen) der ipv4 und der ipv6 IP/Port-Kombination eigene (unterschiedliche) Docroots gegeben und dort was Sinniges reingelegt. Wobei mir hier die Frage kommt, was denn die ipv4-Adresse, die ich hier eintragen muss, denn eigentlich ist. Ist es die, mit der ich den Server von Außen per ipv4 erreichen kann? Oder ist es die ipv4-Adresse, die mir ifconfig zeigt? Ich habe zunächst die "externe ipv4-Adresse" gewählt - mit großem Fragezeichen im Kopf... Es gibt jetzt also außer den vhosts der Domains (deren Docroots alle auf /var/customers/webs/... zeigen) einen froxlor_ipandport_ipv4.conf und einen froxlor_ipandport_ipv6.conf (deren Docroot ebenfalls unique ist und NICHT /var/www/html). Und dann gibt es noch den 000-default.conf - dort ist der VirtualHost *:80 drin. Dessen Docroot zeigt auf /var/www/html. Ich habe die IP-Adresse der Domains auf die neu engelegte ipv6 "umgehakt". In den vhosts steht jetzt auch alles gemäß ipv6 drin - aber aufgerufen wird, egal, ob ich mit einer der Domains oder mit der ipv4-Adresse von Außen aufrufe, immer nur /var/www/html. Ich habe übrigens nur eine ipv4 Anbindung - das sollte hier aber nicht das Problem darstellen. Irgendwie findet der Apache trotz korrekter Virtual Host Namen und ipv6 Adresse den passenden Eintrag immer noch nicht. Seltsamerweise fällt er auf keine der beiden ip/Port-Kombinationen zurück, sondern ganz zurück auf die den default vhost... Hier muss irgendwas grundlegend anders gemacht werden als bei reinem ipv4 - nur was? Gruß df8oe
×