Jump to content
Froxlor Forum
  • 0

Froxlor - ProFTPd - sftp


Question

Moin zusammen,

ich habe mich jetzt einen halben Tag durch alle möglichen Anleitungen und Kommentare gelesen, um obiges zum Laufen zu bekommen, leider vergeblich.

Hat es jemand laufen? Gibt es eine Step-by-Step Anleitung?

Ich habe eine mehr oder weniger Standard-Installation von Debian 10, Froxlor und ProFTPd laufen mit Apache 2.4, PHP 7.4, MariaDB 10.3.
SSH läuft, FTP läuft, eigentlich läuft alles, und das schon seit Monaten. Geändert habe ich nur die FTP- und SSH-Ports. Schafft unheimlich Ruhe auf dem Server :).

Ich würde jetzt nur gerne SFTP über ProFTPd ermöglichen. Über den SSH-Port als root geht es auch, aber das kann ja nicht die Lösung für die anderen FTP-Benutzer sein :).

Laut einer Anleitung es es ganz einfach, man muss nur folgende sftp.conf erstellen:

<IfModule mod_sftp.c>
    SFTPEngine on
    SFTPLog /var/log/proftpd/sftp.log
    SFTPHostKey /etc/ssh/ssh_host_ecdsa_key
    SFTPHostKey /etc/ssh/ssh_host_rsa_key
</IfModule>

Wobei ich "ssh_host_dsa_key" in obiges geändert habe, denn den "..dsa.key" gibt es bei mir nicht. Und dann den FTP-Server neu starten.
Funktioniert hier aber nicht, Login scheitert. FileZilla sagt:

Fehler:    FATAL ERROR: Network error: Connection refused
Fehler:    Herstellen der Verbindung zum Server fehlgeschlagen

Muss man sonst noch was an der Froxlor-Konfiguration ändern?

Unter Einstellungen / Sicherheitseinstellungen habe ich auch mal "Erlaube Kunden für FTP Benutzer eine Shell auszuwählen" aktiviert, hilft aber auch nicht.

Kann mir irgend jemand sagen, wie man das zum Laufen bekommt? Mein Dank für ihm vielleicht nicht ewig, aber doch lange nach nachschleichen ;)

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Dafür brauchen die User eine gültige Shell, aktiviert hast du es schon systemweit, jetzt musst du natürlich dem entsprechenden user (via ftp settings des customers) auch eine shell zuweisen (default ist /bin/false damit geht es natürlich nicht)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...