Jump to content
Froxlor Forum

Aragorn

Members
  • Posts

    66
  • Joined

  • Last visited

  • Days Won

    1

Aragorn last won the day on October 30 2017

Aragorn had the most liked content!

Recent Profile Visitors

2331 profile views

Aragorn's Achievements

Contributor

Contributor (5/14)

  • Conversation Starter
  • First Post
  • Collaborator Rare
  • Week One Done
  • One Month Later

Recent Badges

1

Reputation

  1. Moin zusammen, ich habe mich jetzt einen halben Tag durch alle möglichen Anleitungen und Kommentare gelesen, um obiges zum Laufen zu bekommen, leider vergeblich. Hat es jemand laufen? Gibt es eine Step-by-Step Anleitung? Ich habe eine mehr oder weniger Standard-Installation von Debian 10, Froxlor und ProFTPd laufen mit Apache 2.4, PHP 7.4, MariaDB 10.3. SSH läuft, FTP läuft, eigentlich läuft alles, und das schon seit Monaten. Geändert habe ich nur die FTP- und SSH-Ports. Schafft unheimlich Ruhe auf dem Server :). Ich würde jetzt nur gerne SFTP über ProFTPd ermöglichen. Über den SSH-Port als root geht es auch, aber das kann ja nicht die Lösung für die anderen FTP-Benutzer sein :). Laut einer Anleitung es es ganz einfach, man muss nur folgende sftp.conf erstellen: <IfModule mod_sftp.c> SFTPEngine on SFTPLog /var/log/proftpd/sftp.log SFTPHostKey /etc/ssh/ssh_host_ecdsa_key SFTPHostKey /etc/ssh/ssh_host_rsa_key </IfModule> Wobei ich "ssh_host_dsa_key" in obiges geändert habe, denn den "..dsa.key" gibt es bei mir nicht. Und dann den FTP-Server neu starten. Funktioniert hier aber nicht, Login scheitert. FileZilla sagt: Fehler: FATAL ERROR: Network error: Connection refused Fehler: Herstellen der Verbindung zum Server fehlgeschlagen Muss man sonst noch was an der Froxlor-Konfiguration ändern? Unter Einstellungen / Sicherheitseinstellungen habe ich auch mal "Erlaube Kunden für FTP Benutzer eine Shell auszuwählen" aktiviert, hilft aber auch nicht. Kann mir irgend jemand sagen, wie man das zum Laufen bekommt? Mein Dank für ihm vielleicht nicht ewig, aber doch lange nach nachschleichen
  2. Aragorn

    http2

    Bei mir nicht. Guckst Du... Und im Thread steht (bei mir) nirgends ein Datum. Wie gesagt, "Protocols h2 http/1.1" steht nur bei den vhosts in der .conf, bei denen ich http2 Unterstützung aktiviert habe. Das sollte auch keine Beschwerde oder Fehlermeldung sein, nur ein Bericht, wie es hier aussieht und läuft. Und die Frage, ob der Schalter denn überhaupt noch notwendig ist in den Einstellungen der einzelnen Domains. Ja, das ist mir klar :). Meine Aussage ist ja auch nur, dass es, zumindest hier, anscheinend keinerlei Unterschied macht, ob der "Protocals" Eintrag in der vhost .conf der Domain nun vorhanden ist, oder nicht. Was mich dann zu obiger Frage verleitet hat ;). Ja, ich hatte mich nur ein wenig gewundert, weil man laut der Anleitung ja auch die PHP-Konfiguration ändern sollte. a2enconf php7.3-fpm a2dismod php7.3
  3. Aragorn

    http2

    Moin, ich weiß nicht, ob das Thema schon alt ist, es wird ja leider kein Datum angezeigt,. Könnte man ja evtl. mal ändern? :). Aber ich hänge mich da mal dran... Ich habe jetzt ebenfalls http2 beim Apache aktiviert (Debian 10) und mich dabei nach dieser Anleitung gerichtet: https://helgeklein.com/blog/2018/11/enabling-http-2-in-apache-on-ubuntu-18-04/ Dabei lediglich 7.2 durch 7.3 ersetzt. In der /etc/apache2/apache2.conf gibt es keinen Eintrag "Protocols h2 http/1.1". Ich habe den auch nicht hinzugefügt. In Froxlor ist unter Einstellungen / Webserver-Einstellungen die HTTP2 Unterstützung aktiviert, war es aber auch schon vorher. Nun werden alle Seiten auf dem Server mit dem http2 Protokoll ausgeliefert, auch ohne den obigen "Protocols" Eintrag irgendwo. Auch die vhost-Einträge von d00p braucht es hier wohl nicht. Ich habe die mal bei einer Domain eingetragen, aber da sie anderen Seiten auch ohne diese in h2 ausgegeben werden, habe ich es bei denen nicht gemacht. Die Frage ist, ob die http2-Unterstützung in den Einstellungen der einzelnen Domains notwendig ist. Die fügt zwar den "Protocols" Eintrag in die vhost.conf ein, aber für die Ausgabe der Seite scheint es hier keinen Unterschied zu machen... Auch die verwendete PHP-Version ist dabei wohl egal :).
  4. Ich habe jetzt erstmal incron installiert, mal schauen ob das funktioniert.
  5. Ich stelle mich jetzt mal ganz dumm und frage mich, ob es relativ leicht wäre, es so zu integrieren, indem man einen Befehl hinterlegen kann: Und in die Datei , z.B. halt restart_mailservices, darf dann jeder das reinpacken, was er braucht, mag, möchte :). Wenn das Feld leer ist, mach nix, sonst das ausführen. Siehste, ganz einfach 😂
  6. Siehst Du denn eine Chance, sowas irgendwie in Froxlor zu integrieren? Ich finde, das ist kein ganz unwichtiges Thema.
  7. Moin zusammen und ein frohes neues Jahr :). Ich bin doch sicher nicht der Einzige, der einen Mailserver mit einem LE-Zertifikat versehen hat, oder? Nun ist es so, dass alle 2 Monate, wenn das Zertifikat automatisch erneuert wurde, die Mail-Clients meckern, weil der Server wohl noch das alte Zertifikat ausliefert. Also muss man ihn (Postfix / Dovecot) neu starten, dann ist wieder alles gut. Hat jemand von euch eine Lösung, wie man das automatisch hinbekommt? So muss ich das manuell machen, nachdem ich das mitbekommen habe, weil mich jemand deswegen anmeckert ;). Wäre schon, wenn niemand erst meckern müsste, weil der Mail-Server anschließend automatisch neu gestartet würde. Gruß, Wolfgang
  8. Ok, ich hab die timeouts erhöht und das slow-query-log aktiviert. Schauen wir mal.... Der Fehler ist aber nach wie vor vorhanden und ich kann Froxlor nicht aufrufen.
  9. Moin, ich bekomme seit heute Vormittag Unmengen solcher Mails (alle 1 bis 2 Minuten): Der MySQL-Server läuft aber, die Webseiten funktionieren und mit phpMyAdmin komme ich auch problemlos auf den SQL-Server (MariaDB 10) und auch auf die DB von Froxlor. Froxlor selbst startet aber auch nicht mehr, lädt sich tot und nichts passiert. System läuft unter Debian 8.11. Froxlor ist 9.40.1 Hat jemand eine Idee? Betreff Cron <root@server> /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null froxlor[24363]: SQLSTATE[HY000]: General error: 2013 Lost connection to MySQL server during query froxlor[24363]: --- DEBUG: #0 [internal function]: PDO->query('\n\t\t\t\tSELECT `se...') #1 /var/www/froxlor/lib/classes/database/class.Database.php(186): call_user_func_array(Array, Array) #2 /var/www/froxlor/lib/classes/settings/class.Settings.php(84): Database::__callStatic('query', Array) #3 /var/www/froxlor/lib/classes/settings/class.Settings.php(84): Database::query('\n\t\t\t\tSELECT `se...') #4 /var/www/froxlor/lib/classes/settings/class.Settings.php(67): Settings->_readSettings() #5 /var/www/froxlor/lib/classes/settings/class.Settings.php(254): Settings->__construct() #6 /var/www/froxlor/lib/classes/settings/class.Settings.php(274): Settings::getInstance() #7 /var/www/froxlor/lib/functions/output/function.dieWithMail.php(32): Settings::__callStatic('Get', Array) #8 /var/www/froxlor/lib/functions/output/function.dieWithMail.php(32): Settings::Get('system.send_cro...') #9 /var/www/froxlor/lib/cron_init.php(144): dieWithMail('There is alread...') #10 /var/www/froxlor/scripts/froxlor_master_cronjob.php(20): include_once('/var/www/froxlo...') #11 {main} Im Froxlor Error-Log ist folgendes: |CODE HY000 |MSG SQLSTATE[HY000]: General error: 2013 Lost connection to MySQL server during query |FILE /var/www/froxlor/lib/classes/database/class.Database.php |LINE 186 |TRACE #0 [internal function]: PDO->query('\n\t\t\t\tSELECT `se...') #1 /var/www/froxlor/lib/classes/database/class.Database.php(186): call_user_func_array(Array, Array) #2 /var/www/froxlor/lib/classes/settings/class.Settings.php(84): Database::__callStatic('query', Array) #3 /var/www/froxlor/lib/classes/settings/class.Settings.php(84): Database::query('\n\t\t\t\tSELECT `se...') #4 /var/www/froxlor/lib/classes/settings/class.Settings.php(67): Settings->_readSettings() #5 /var/www/froxlor/lib/classes/settings/class.Settings.php(254): Settings->__construct() #6 /var/www/froxlor/lib/classes/settings/class.Settings.php(274): Settings::getInstance() #7 /var/www/froxlor/lib/functions/output/function.dieWithMail.php(32): Settings::__callStatic('Get', Array) #8 /var/www/froxlor/lib/functions/output/function.dieWithMail.php(32): Settings::Get('system.send_cro...') #9 /var/www/froxlor/lib/cron_init.php(144): dieWithMail('There is alread...') #10 /var/www/froxlor/scripts/froxlor_master_cronjob.php(20): include_once('/var/www/froxlo...') #11 {main} Und ich weiß nicht, ob es wichtig ist: Heute morgen wurde ein Update gemacht: installed systemd:amd64 215-17+deb8u13 installed man-db:amd64 2.7.0.2-5 installed libglib2.0-0:amd64 2.42.1-1+deb8u3 installed libglib2.0-data:all 2.42.1-1+deb8u3 installed proftpd-basic:amd64 1.3.5e+r1.3.5-2+deb8u3 installed proftpd-mod-mysql:amd64 1.3.5e+r1.3.5-2+deb8u3 installed libc-bin:amd64 2.19-18+deb8u10
  10. Merkwürdig... Hab's gerade mit einer anderen Subdomain ausprobiert, da wurde die fullchain nicht erstellt. Na dann such mal schön
  11. Keine Ahnung. Nach dem Update auf die 0.9.40.1 gerade eben war die fullchain (hatte sie manuell erstellt) wieder weg. Ich habe den Inhalt nun direkt in die Datenbank eingefügt und beim nächsten Durchlauf hat er dann auch die fullchain erstellt. Es sieht also so aus, dass die fullchain nicht erstellt wird, wenn das entsprechende Feld in der Tabelle NULL ist. Und das sind einige
  12. In der Datenbank, Tabelle domain_ssl_settings ist für diese Domain (ist eine subdomain) das Feld ssl_fullchain_file auch leer (Null). Bei vielen anderen Domains auch.
  13. Moin, ja, für einige Domains macht Froxlor das wohl, für meine Mail-Domain (mail,xxxx) hat er es jedenfalls nicht gemacht und schon ging nix mehr mit dem Mailserver. Any idea?
  14. Ja das funktioniert. Aber die gibt es so ja nicht, oder? Es werden generiert: /etc/apache2/ssl/mail.domain.de.crt /etc/apache2/ssl/mail.domain.de.key /etc/apache2/ssl/mail.domain.de_CA.pem /etc/apache2/ssl/mail.domain.de_chain.pem Ich habe jetzt die .crt und die _chain.pem zusammen in eine /etc/apache2/ssl/mail.domain.de.pem kopiert und bei devocot und postfix eingetragen, das scheint es zu funktionieren. Aber in 2 oder 3 Monaten wird das Zertifikat ja auslaufen und von Froxlor erneuert, dann muss ich das ja jedes mal wieder von Hand machen... Oder was übersehe ich?
×
×
  • Create New...