Jump to content
Froxlor Forum
  • 0

Mysql wont start after rsync /var/lib/mysql/* from old to new server


Question

Hello, I have been following the steps described in

https://forum.froxlor.org/index.php?/topic/13952-teil-migration-howto AND

https://forum.froxlor.org/index.php?/topic/14391-froxlor-migration-auf-neuen-server-systemupgrade

to migrate a froxlor server from Debian 8 to Ubuntu Focal

Both servers were configured and running froxlor correctly.

Old server is running Mysql 7.4
New server is running Mysql 8

The problem is that after rsync var/lib/mysql/* from old to new, the mysql server in new is not starting.

The error showed is

mysql.service - MySQL Community Server
     Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
     Active: activating (start) since Mon 2021-02-22 13:22:51 UTC; 12s ago
    Process: 1173478 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS)
   Main PID: 1173487 (mysqld)
     Status: "Data Dictionary upgrade from MySQL 5.7 in progress"
      Tasks: 2 (limit: 38476)
     Memory: 234.8M
     CGroup: /system.slice/mysql.service
             └─1173487 /usr/sbin/mysqld
 

I have been searching for info but couldnt find it.

Please if someone have experienced this can share how it was solved.

Thank you

 

 

 

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

That's right. I rsynced /var/lib/mysql/ on old to var/lib/mysql on new. Both locations are correct for mysql.

As you wrote in an old post, I stopped mysql server on new before rsyncing. 

The only thing I havent tried yet is to stop mysql on old AND new.

Any idea? Thank you

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...