Jump to content
Froxlor Forum
  • 0

Umstellung auf FPM


Go to solution Solved by d00p,

Question

Hallo,

ich habe heute den updaten auf PHP7.4 gemacht und im Anschluss auf FPM umgestellt.
Habe die Configs für FPM erstellt und auch die Einrichtung durchlaufen.

Leider bekomme ich trotzdem eine 503 Fehler.

Extrausers habe ich auch eingerichtet. Die Kunden stehen auch als User drin und die Gruppen passen meiner Meinung nach auch.

Hast du ne idée was ich noch testen kann ?
Beziehungsweise kann ich dir ein Log posten damit du vielleicht was siehst?

Viele Grüße und danke für deinen Support

Markus 

[Thu Nov 05 17:36:31.183604 2020] [proxy_fcgi:error] [pid 16917] [client XX.XX.XX.XX:52309] AH01079: failed to make connection to backend: httpd-UDS
[Thu Nov 05 17:36:50.908708 2020] [proxy:error] [pid 16882] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/run/1-martin-cloud.XXX.de-php-fpm.socket (*) failed

 

Edited by Markus76
attach log
Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
  • Solution

siehste doch, "php-fpm: pool www" und läuft unter www-data.

Normal stünde da z.B. "php-fpm: pool kunden-domain.tld" und der child-prozess läuft unter "customername".

ggfls hast du da einen alten default pfad, z.B. /etc/php-fpm.d/ oder sowas. Wenn du den richtigen Pfad gefunden hast, einfach alle pool-configs von dort nach /etc/php/7.4/fpm/pool.d/ kopieren, php7.4-fpm restarten und dann läuft das :) Dann halt im froxlor bei der entsprechenden fpm-daemon setting den Pfad korrigieren

Link to post
Share on other sites
  • 0
ps faux | grep fpm
root     17447  0.0  0.0   6728   768 pts/1    S+   17:47   0:00          \_ grep fpm
root     17117  0.0  0.2 296272 39772 ?        Ss   17:29   0:00 php-fpm: master process (/etc/php/7.4/fpm/php-fpm.conf)
www-data 17118  0.0  0.0 296272 10688 ?        S    17:29   0:00  \_ php-fpm: pool www
www-data 17119  0.0  0.0 296272 10688 ?        S    17:29   0:00  \_ php-fpm: pool www

Also FPM läuft aber Anschein werden die configs nicht an die richtige Stelle generiert.

Wie kann ich das am einfachsten checken ohne Zugriff aufs Admin Panel ?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...