Jump to content
Froxlor Forum
  • 0

Problem with PHP-FPM


I have a problem with PHP-FPM.
I installed Froxlor on Debian 9 and everything works fine.
I want to run different PHP versions for different domains.
I have installed
apt-get install libnss-extrausers
according to information from the froxlox panel

I have enabled saving data to files in a folder
/ var / lib / extrausers /

chown on debian sees froxlor users.
Of course I installed php7.3-fpm, php7.4-fpm etc.

Unfortunately, when I open PHP files, a 503 error appears
HTML files open correctly.

There is an error in the error logs
[proxy: error] [pid 8557] (13) Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket / var / lib / apache2 / fastcgi / 2-dian - *********** .pl-php-fpm.socket (*) failed

The sockets, on the other hand, are open

~ # ls -al / var / lib / apache2 / fastcgi /
total 8
drwxr-xr-x 2 www-data www-data 4096 Nov 3 16:21.
drwxr-xr-x 6 root root 4096 Oct 30 19:00 ..
srw-rw ---- 1 dian-dian 0 Nov 3 16:21 2-dian-dian. *******. pl-php-fpm.socket
srw-rw ---- 1 dian dian 0 Nov 3 16:21 2-dian - *********. com.pl-php-fpm.socket

Please help

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

be sure that you've specified the correct webserver user (www-data mostly) in the settings and that this user is member of the customer-groups ("id www-data" should output the corresponding memberships)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...