Jump to content
Froxlor Forum
  • 0

V0.10.21 | Eigene vHost-Einstellungen -> FcgidMaxRequestLen zieht nicht mehr


Go to solution Solved by d00p,

Question

Huhu,

wir stehen aktuell auf dem Schlauch, da sich bei uns plötzlich mehrere Menschen melden und von einem 500 error beim Upload in Ihrem CMS berichten.

Loganalyse betrieben -> Auffällig ist, dass sich bei den Betroffenen immer die selbe Fehlermeldung im spezifischen Domain Apache2 Log wiederfindet: mod_fcgid: HTTP request length 139264 (so far) exceeds MaxRequestLen (131072).

Auf diesen Fehler sind wir zuvor nie gestoßen, da wir den FcgidMaxRequestLen Wert immer individuell in der Domainconfig definieren. Bei einem der Betroffenen steht in der eigenen vHost-Einstellung (Froxlor GUI) beispielsweise: FcgidMaxRequestLen 204800000 drin. Nach einem Fileupload wird trotzdem bemängelt, dass der Wert (131072) überstiegen wird und er erhält einen 500 error. Hat sich diesbezüglich etwas geändert? Die logfiles sind bis auf den genannten Fehler soweit sauber. Auf der shell nachgeschaut -> Der Wert steht ebenso wie im Froxlor GUI eingetragen auch in der vHost conf.

Wir haben auch zusätzlich noch rekursiv in /etc/ nach "FcgidMaxRequestLen 131072" gesucht, da wir davon ausgingen, dass wir den Wert irgendwo versehentlich hinterlegt haben könnten, dies ist aber nicht der Fall. Es gab in letzter Zeit auch keine nennenswerte Änderungen in unserem System.

Um uns zu behelfen, haben wir nun den FcgidMaxRequestLen Wert zusätzlich in der /apache2/mods-available/fcgid.conf definiert. Wir wären jedoch weiterhin gerne in der Lage, den Wert pro Domain individuell anpassen zu können und keine globalen Schalter umlegen zu müssen.

Vielen Dank vorab für die Hilfe und Antwort!

Beste Grüße,

nova

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 1
  • Solution

Also laut apache doc geht die option auf server und auf vhost basis. Zeig uns doch bitte mal die entsprechenden vhosts und wie das eingefügt wurde 

Link to post
Share on other sites
  • 0

Tacho!
Lag wohl hier dran: Im Non-SSL-Zweig drin gewesen, aber nicht im SSL-Zweig:
Das Markierte ist nun auch drin. Ich schätze mal dass das früher ggf. einmal nur ein zentrales Setting war? Nur eine Vermutung.

image.thumb.png.cb0569b0dc7cba3bfc1a5584bc28c768.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...