Jump to content
Froxlor Forum
  • 0

Nach Umbennung Let's Encrypt Cert für Host neu erzeugen


Go to solution Solved by d00p,

Question

Hallo,

ich habe einen Host mit froxlor (war alles fertig eingerichtet) aus organisatorischen Gründen umbenannt, sprich der Server hat eine Adresse. Ging soweit alles gut, bis auf Let's Encrypt, ich kriege froxlor nicht dazu erneut eine richtige Cert anzufordern.

Was ich gemacht habe:

* Hostname geändert und alle Datein in /etc nach dem alten Hostname durchsucht und geändert (alle Dienste von Apache bis Mail)

* in froxlor überall den Hostname geändert (auch in Datenbank froxlor gesucht)

Danach hat froxlor zwar eine neue Cert generiert, aber mit der neuen Adresse in Dateiname unter /etc/ssl/froxlor-custom, aber in der Cert selbst ist noch die alte Adresse drin. Das ging auch, weil die alte Adresse noch nicht aus externen DNS gelöscht war, und Let's Encrypt über die alte Adresse den Server erreichen konnte. Diese Cert kann man natürlich nicht gebrauchen.

Dann habe per Webinterface unter "SSL certificates" die Cert (mit der flaschen Adresse drin) gelöscht, auch manuell unter /etc/ssl/froxlor-custom. Danach SSL für froxlot-VHost und Let's Encrypr Support deaktiviert, paar Minuten gewartet und wieder aktiviert - ging paar Male so hin und her. Nur ich habe es nicht geschafft, dass froxlor eine neue Cert anfordert. Wie triggere ich froxlor dazu, eine neue Cert für den Host zu erzeugen?

Edited by d00p
removed possible unwanted link to personal froxlor
Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
  • Solution
8 hours ago, epsilon said:

Danach hat froxlor zwar eine neue Cert generiert, aber mit der neuen Adresse in Dateiname unter /etc/ssl/froxlor-custom, aber in der Cert selbst ist noch die alte Adresse drin.

Das ergibt so gar keinen Sinn...warum sollte Let's Encrypt für domain-alt.tld genenieren wenn ich eins für domain-neu.tld anfordere? Wenn du tatsächlich überall den hostname korrekt geändert hast (allen voran System-Settings -> Hostname, der ist hier relevant) dann kann ich mir nicht vorstellen wieso er sowas tun sollte.

Am besten löschst du zunächst nochmal die Zertifikate von neu und alt (!) und zwar zum einen in froxlor (sofern noch vorhanden) unter dem Punkt "SSL Certificates" und zum anderen, nicht wie du vermutet hast unter /etc/ssl/froxlor-custom/ (hier werden die aus der db generierten certificates abgelegt für den webserver) sondern via acme.sh direkt.

cd /root/.acme.sh/
./acme.sh --remove -d [domain-alt.tld]
./acme.sh --remove -d [domain-neu.tld]
rm -rf /root/.acme.sh/[domain-alt.tld]
rm -rf /root/.acme.sh/[domain-neu.tld/

Und dann versuchst du es nochmal ganz in ruhe von vorne :)

Link to post
Share on other sites
  • 0

Ah, Danke! /root/.acme.sh hatte ich gar nicht auf dem Schirm.

Ja, manuell gelöscht und zack, hat froxlor ein neues Zertifikat generiert, Problem solved! 👍

Das mit der falschen Adresse, ich nehme an zum Zeitpunkt des Generierens hatte ich wohl die alte Adresse noch in der Config übersehen bei den vielen hin und her *shrugs*

  • Haha 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...